LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-28-2009, 01:05 PM   #1
AddyM
LQ Newbie
 
Registered: Sep 2009
Posts: 1

Rep: Reputation: 0
My Facebook App (dedicated windows server)


Hello, we are looking for help. We are developing a flash application in Facebook http://apps.facebook.com/farmvalley/play.php with the help of a software company based in China and, even though they have done a good job creating the game, we have encountered a problem that neither them, nor our server people seem to be able to fix.

Description of the problem:

As you can see in this video http://www.youtube.com/watch?v=Y--c08sCODw the game slows down only between the 1st and 2nd click. After that, the game seems to have caught the serverís attention and it begins to work perfectly, with no delays between clicks.

However, if the user pauses activity for a little bit, then the delay between 1 and 2 click comes right back.

Server and traffic information:

The app started just a few weeks ago so it does not have much traffic, which does not seem to be the problem because the delay happen even right after restarting the server.

The server has 2 quad core, 2.0 GHz CPUs. 2 hard drives and 8 GB of RAM which is running under 30% usage. Itís running Windows OS, mySQL and apache.

Would it work better on a Linux OS?

Please let us know if we should provide any additional information, any help with this is truly appreciated
 
Old 09-29-2009, 09:08 AM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Without any idea what the problem is, it is impossible to say if moving the server over to Linux is going to help you any. The bug could be in the application itself, in which case no operating system or amount of processing power is going to fix it.

It is is really a latency issue, that the server is not responding fast enough, then maybe moving over to a suitably tuned Linux kernel would resolve the issue. But until you know that is the problem for a fact (and honestly, it seems a little unlikely), you don't want to make such a drastic move.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Best mini distribution for use in dedicated computer running a single graphic app toglia Linux - Distributions 2 05-17-2009 07:34 PM
LXer: How-to: using the new Facebook stream API in a desktop app LXer Syndicated Linux News 0 05-04-2009 02:50 PM
C++ windows server but linux client app remotely invoking methods linuxmandrake Programming 2 10-12-2008 08:09 PM
Terminal Services on Fedora Server with Windows Clients for Multiuser Quickbooks App Bryan Henry Linux - Software 2 08-03-2005 08:40 AM
Linux app-server to server StarOffice to Windows Clients: Need advice biosx Linux - Networking 3 08-14-2002 10:14 AM


All times are GMT -5. The time now is 03:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration