LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-29-2012, 01:28 AM   #1
LinuxLover
Member
 
Registered: Feb 2004
Distribution: Solaris 10/11 , RHEL 6 ,AIX 7.1
Posts: 188

Rep: Reputation: 32
mpstat,iostat,dstat does not updating screen output


Hi,
I am facing some strange trivial problem ,I am connected with my server (RHEL 5) via ssh (using secure shell and putty from windows) when I execute the below commands by specifying time interval like

#mpstat 5

or
#iostat 5

or
#dstat

These command prints only first line on screen then cursor keep on blink on screen and next lines output does not appear on screen.

any idea ? what to do ?
 
Old 08-30-2012, 10:45 AM   #2
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,015
Blog Entries: 5

Rep: Reputation: 787Reputation: 787Reputation: 787Reputation: 787Reputation: 787Reputation: 787Reputation: 787
In PuTTY do you have translation setting set to UTF-8?

mpstat 5, iostat 5 and dstat all work fine for me using PuTTY session to RHEL5.

You might want to verify the mpstat, iostat and dstat commands are all what you think they are (e.g. NOT wrapper scripts). Some folks might put wrapper scripts in place specifically to prevent users from running continuous utilities like these.

Also you DID wait 5 seconds after seeing the first line to verify another line didn't appear right?
 
Old 08-31-2012, 05:34 AM   #3
LinuxLover
Member
 
Registered: Feb 2004
Distribution: Solaris 10/11 , RHEL 6 ,AIX 7.1
Posts: 188

Original Poster
Rep: Reputation: 32
Hi my problem resolved

In fact this was not the OS or putty problem, I am using the thin client device which was access the Winows 7 desktop through some RDP and VDI technology ( I dont have much knowledge regarding that)

When I replaced thin cleint with PC (There was some other reasons for replacement) all is working fine now.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sar iostat sadf mpstat ? vmstat ? for Cent OS 4.2 rafiqul Linux - Newbie 6 07-16-2013 02:29 PM
save mpstat output ! ghaedi591 Linux - General 1 11-11-2011 02:53 AM
can't install iostat, mpstat on fedora core 1 sneakyimp Linux - Software 4 09-10-2007 11:02 PM
how to install iostat, mpstat, vmstat commands in RHEL 3.0 kgvs_prasad Linux - Enterprise 2 02-08-2005 12:02 PM
Cannot find sar, mpstat, iostat etc. on RedHat 8 rlinuxr Linux - Software 1 08-05-2003 06:33 PM


All times are GMT -5. The time now is 11:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration