LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 07-10-2004, 11:38 PM   #1
bluedude2288
Member
 
Registered: Nov 2003
Location: Akron, Ohio
Distribution: -->Debian<--, RH, Android, Ubuntu
Posts: 62

Rep: Reputation: 15
mplayer garbled sound


I have mplayer on suse 9.1 pro, when i play a mpg video the sound is all disorted and garbled sounding, avis are ok and mp3s are ok, what could be wrong
 
Old 07-11-2004, 12:20 AM   #2
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
What (textual) output are you getting from mplayer during this? What OS and output driver are you using? Is this in ALL mpg files or just one or two? Describe "garbled". Do you mean simply indecipherable or very fast and high-pitched?
 
Old 07-11-2004, 10:49 AM   #3
bluedude2288
Member
 
Registered: Nov 2003
Location: Akron, Ohio
Distribution: -->Debian<--, RH, Android, Ubuntu
Posts: 62

Original Poster
Rep: Reputation: 15
I have tried all drivers in the list, alsa, oss, etc., I am using suse 9.1 professional, and by garbled its decheierable, except, this all I can thing of to describe it, it sounds like their singing underwater and kinda winey sounding, its on all mpg files,

Last edited by bluedude2288; 07-11-2004 at 10:52 AM.
 
Old 07-11-2004, 10:55 AM   #4
bluedude2288
Member
 
Registered: Nov 2003
Location: Akron, Ohio
Distribution: -->Debian<--, RH, Android, Ubuntu
Posts: 62

Original Poster
Rep: Reputation: 15
heres everything displayed in the terminal when i play an mpg

MPlayer 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Intel Pentium 4/Xeon/Celeron Foster 1801 MHz (Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/shawn/.mplayer/config
Reading /home/shawn/.mplayer/codecs.conf: Can't open '/home/shawn/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /home/shawn/.mplayer/font/font.desc
Font /usr/local/share/mplayer/font/font.desc loaded successfully! (206 chars)
Failed to open /dev/rtc: Permission denied (/dev/rtc should be readable by the user.)
Using usleep() timing
Can't open input config file /home/shawn/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Permission denied
Failed to open LIRC support.
You will not be able to use your remote control.

Playing /windows/C/1/Music Videos/Linkin Park/Linkin Park - In The End (video).mpeg.
MPEG-PS file format detected.
VIDEO: MPEG1 352x288 (aspect 8) 25.000 fps 1150.0 kbps (143.8 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 28000->176400 (224.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 352 x 288 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.3.1
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 352 x 288 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 352x288 => 384x288 Planar YV12
 
Old 07-11-2004, 05:27 PM   #5
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
How did you install mplayer? How did you install the codecs? Have you tried the CVS version?
 
Old 07-15-2004, 12:02 PM   #6
bluedude2288
Member
 
Registered: Nov 2003
Location: Akron, Ohio
Distribution: -->Debian<--, RH, Android, Ubuntu
Posts: 62

Original Poster
Rep: Reputation: 15
Ok its fixed, i had to use this option --with-win32libdir=PATH, where path is, is the path to the win 32 codecs
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mepis + SB Audigy 2 NX garbled sound jughead Linux - Hardware 3 11-23-2005 11:10 AM
Garbled Stepmania Sound aeuzent Linux - Games 0 10-28-2005 11:52 PM
mplayer - garbled screen with dvds japher Linux - Software 7 07-21-2004 03:04 AM
MPlayer sound is garbled mrsolo Linux - Software 3 05-07-2004 09:57 AM
Recurring garbled sound every 60 seconds XMMS Player JeffW Linux - Software 5 01-23-2004 05:08 PM


All times are GMT -5. The time now is 07:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration