LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 03-02-2007, 12:09 AM   #1
chadwick
Member
 
Registered: Apr 2005
Location: At the 100th Meridian where the great plains begin
Distribution: Debian Testing on T60 laptop
Posts: 105

Rep: Reputation: 16
mplayer -ao pcm poor quality when at slow speed


I would like to do a batch job to convert numerous audio files to slow speed.
It's for a language class. There are several files that need to be listened to, and it would be good if they could be listened to at slow speed. Since not everyone has a player that can do this, it would be good to just have the audio files available at different speeds.

I found that "mplayer -ao pcm" outputs a file called "audiodump.wav". That takes the usual flag -speed. For example "mplayer file.mp3 -ao pcm -speed 0.9" produces a file at 90 % of the regular speed.

If I listen to one of these files using mplayer (not dumping it using -ao pcm, i.e. just using "mplayer file.mp3") and slow the audio down to 80 % (using open square bracket "[" while the file is playing), then the quality is good. However, if I use -ao pcm as explained in the previous paragraph, and use -speed 0.8, then the quality of the sound is poor. It comes out with a metallic vibrating sound that is very unpleasant to listen to.

What's causing this? Is there a quality-adjusting flag that will fix this problem?

By the way, if I create audiodump.wav without the -speed flag and then listen to it at slow speed using mplayer, (with square bracket) then there is no problem.

Thanks.

Last edited by chadwick; 03-02-2007 at 12:14 AM.
 
Old 03-02-2007, 01:29 AM   #2
SciYro
Senior Member
 
Registered: Oct 2003
Location: hopefully not here
Distribution: Gentoo
Posts: 2,038

Rep: Reputation: 51
tested it on my machine, i cant see any difference.

Perhaps its your mplayer config file that has some different options?
 
Old 03-03-2007, 04:53 PM   #3
chadwick
Member
 
Registered: Apr 2005
Location: At the 100th Meridian where the great plains begin
Distribution: Debian Testing on T60 laptop
Posts: 105

Original Poster
Rep: Reputation: 16
Okay thanks for checking. My config file ~/.mplayer/config is blank.
Maybe if I tried it with your config options it would work?
 
Old 03-03-2007, 05:40 PM   #4
SciYro
Senior Member
 
Registered: Oct 2003
Location: hopefully not here
Distribution: Gentoo
Posts: 2,038

Rep: Reputation: 51
Sorry, the only options that are active are font configuration options.
Code:
fontconfig=1
subfont-osd-scale=4
subfont-text-scale=3
are you sure you looked at all the options? Mplayer contains two config files, one in /usr/share/mplayer/mplayer.conf and the other local to the user in ~/.mplayer/config, both of which are used.
 
Old 03-03-2007, 06:55 PM   #5
chadwick
Member
 
Registered: Apr 2005
Location: At the 100th Meridian where the great plains begin
Distribution: Debian Testing on T60 laptop
Posts: 105

Original Poster
Rep: Reputation: 16
I checked but the only thing in /usr/share/mplayer/ is the skins/ directory.

I did manage to stumble across a file called /etc/mplayer/mplayer.conf. That one is entirely commented out except for also a few lines about fonts.

Code:
fontconfig = yes
font = "Sans"
subfont-text-scale = 3
One of the things it says is
Code:
#
# MPlayer configuration file
#
# Configuration files are read system-wide from /usr/local/etc/mplayer.conf
# and per user from ~/.mplayer/config, where per-user settings override
# system-wide settings, all of which are overrriden by the command line.
#
so, at least according to that, ~/.mplayer/config is the relevant config file.

Oh well, thanks again. Maybe I'll look again through the different runtime options that can be passed.
 
Old 03-03-2007, 10:57 PM   #6
SciYro
Senior Member
 
Registered: Oct 2003
Location: hopefully not here
Distribution: Gentoo
Posts: 2,038

Rep: Reputation: 51
strange... owell, perhaps try another way to recode the sound, sox with the "rate" option perhaps?
 
Old 03-04-2007, 04:18 AM   #7
chadwick
Member
 
Registered: Apr 2005
Location: At the 100th Meridian where the great plains begin
Distribution: Debian Testing on T60 laptop
Posts: 105

Original Poster
Rep: Reputation: 16
I'd actually never heard of Sox, but it looks interesting. According to http://sox.sourceforge.net/, you can change the speed without changing the pitch which might end up being a nice bonus. I think I'll give that a shot but might have to put it on the backburner for a week or so.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Svideo out to TV quality is really poor vdemuth Linux - Hardware 6 01-01-2007 07:39 PM
poor sound quality verbose Linux - Hardware 6 09-11-2006 05:29 AM
poor sound quality slackware_03 Linux - Distributions 10 09-23-2004 05:17 PM
esound slow and poor quality biscristi Linux - Software 0 05-11-2004 08:56 AM
Poor VHS quality niidea Linux - Hardware 8 09-16-2003 08:26 PM


All times are GMT -5. The time now is 05:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration