LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   mouse stops responding (http://www.linuxquestions.org/questions/linux-general-1/mouse-stops-responding-560639/)

mychinko 06-10-2007 10:51 AM

mouse stops responding
 
I have a asus a6r laptop.
the problem is, that my mouse stops responding, sometimes after a few minutes, sometimes after few hours. but it just stops. when I unplug it and plug back in (USB mouse) the red LED on the mouse is dead.
the only way to get it work (as far as I know) is to reboot the machine.

I have been using FC6 for some time, without this problem.
Now I tried the following, all having the same problem:
Sabayon, LinuxMint,PClinuxOS2007,Mandriva2007.

I am desperate, coz It does not happen on Fedora7 (but I dont want to stick with that).

It usually happens when resizing a window, like amarok, or a Kaffeine window, I drag it for a while, and then it stopps. My touchpad though works unaffected. thank you all.

I am not sure if this is of importance, but when I go for reboot after the mouse stops, Stopping FUSE sends FAILED.
I am currently running PClinuxOS.

thank you so much all.

saikee 06-10-2007 12:43 PM

I had the same problem before but got over it by using a standard PS2 mouse.

I believe your case may be solved if

(1) You take a look at the FC6's /etc/X11/xorg.conf on the chosen mouse driver and record or copy the settings.

(2) In your Sabayon, LinuxMint,PClinuxOS2007,Mandriva2007 and Suse try to edit their xorg.conf to apply the same settings as in FC6.

mychinko 06-11-2007 05:07 AM

Quote:

Originally Posted by saikee
I had the same problem before but got over it by using a standard PS2 mouse.

I believe your case may be solved if

(1) You take a look at the FC6's /etc/X11/xorg.conf on the chosen mouse driver and record or copy the settings.

(2) In your Sabayon, LinuxMint,PClinuxOS2007,Mandriva2007 and Suse try to edit their xorg.conf to apply the same settings as in FC6.


Hi, saikee.

I did tried that. change the mouse settings according to the Fedora xorg(though I have only fedora7 running parallel to my PC now, but I think I ll install FC6 as well). The point is, it did not help. I even changed the settings of the display/driver to use the native xorg/radeon (coz that is what fedora uses, and it works perfect, no need for the proprietary ati, in my case). because I believe the problem might be the video.
I for sure freeze the mouse, when I resize a window, but I only freeze the USB mouse, with the touchpad I can do anything.

Also, fedora has only 1 input/mouse device, but both work ok, the USB mouse and the touchpad, with theese settings:

# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection



It did not work on PClinuxOS though.However it did work during bootup, but as soon as X started, the mouse was dead, and only the touchpad worked. Default Pclinuxos:

# File generated by XFdrake (rev 57713)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# font server independent of the X server to render fonts.
FontPath "unix/:-1"

# minimal fonts to allow X to run without xfs
FontPath "/usr/share/fonts/misc:unscaled"
EndSection

Section "Extensions"
Option "Composite"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "dri" # direct rendering
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
EndSection

Section "InputDevice"
Identifier "SynapticsMouse1"
Driver "synaptics"
Option "SHMConfig" "on"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "Flat Panel 1024x768"
HorizSync 31.5-90
VertRefresh 60

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "ATI Technologies Inc."
BoardName "ATI Radeon (fglrx)"
Driver "ati"
Option "DPMS"
Option "XaaNoOffscreenPixmaps" "1"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
InputDevice "SynapticsMouse1" "AlwaysCore"
Screen "screen1"
EndSection

thank you very much.

saikee 06-11-2007 06:56 AM

Your Fedora uses

InputDevice "Synaptics" "CorePointer"

and your PClinuxOS uses

InputDevice "Mouse1" "CorePointer"

The two are different mouse drivers but you said you have standardised them to the same as in Fedora?

mychinko 06-13-2007 01:44 AM

yes, I did, I tried several input paths and several protocols. always the same result, if it did work, it would stop after some time.
But I believe now, the problem is with the USB bus - I mean the way the sytem accesses it, coz I was copying some data from my USB disk. The mouse stopped responding as usual, but 2 minutes after that, I got the message that the disk does not exist...(of course the copying was still not over).

Thank you again

mychinko 06-13-2007 03:05 AM

ok, I think I found the solution, though not really the cause, so as a symptomatic relief, I added "irqpoll" to the boot options.and it seems so far so good. I hope it stays. I also tried "acpi=noirq" but then I could not mount USB drives. thank you again, really. I just hope this will stay...:)

laramarvin 06-14-2007 06:16 PM

"irqpoll" How do I do that?
 
Quote:

Originally Posted by mychinko
ok, I think I found the solution, though not really the cause, so as a symptomatic relief, I added "irqpoll" to the boot options.and it seems so far so good. I hope it stays. I also tried "acpi=noirq" but then I could not mount USB drives. thank you again, really. I just hope this will stay...:)

Hey mychinko, how do I add irqpoll?

mychinko 06-14-2007 11:29 PM

when booting, just add it to the booting options, or configure /boot/grub/menu.lst and add it there.

laramarvin 06-15-2007 08:46 AM

Sorry to bother you again
 
Quote:

Originally Posted by mychinko
when booting, just add it to the booting options, or configure /boot/grub/menu.lst and add it there.

Like this?:

#acpi=irqpoll

or like this?:

acpi=irqpoll

I'm completly new to linux so thanks in advance for your extra explanations.

mychinko 06-16-2007 01:06 AM

ok, try both, you will see which will work better ;) if you know what you change, you can always boot a live CD and change the settings, back ;)

but back to your Q. in linux (I guess *NIXes in general), when you have "#" in front of a argument, it means this will be left out, as oposed to ";" in windows. So just add "irqpoll" to the boot options (as I have in my first entry) or change the "acpi=on" to acpi=noirq" (see the second entry) the former works better for me.

title PCLoinuxOS -irqpol+acpi
root (hd0,4)
kernel /boot/vmlinuz BOOT_IMAGE=linux root=/dev/hda5 acpi=on irqpoll splash=silent vga=788
initrd (hd0,4)/boot/initrd.img

title PCLoinuxOS noirq
root (hd0,4)
kernel /boot/vmlinuz BOOT_IMAGE=linux root=/dev/hda5 acpi=noirq splash=silent vga=788
initrd (hd0,4)/boot/initrd.img

laramarvin 06-19-2007 12:24 PM

Thanks but didn't work for me
 
I just thried them both, unfortunately, it didn't work for me, neither of them. I'm just clueless now and thinking to get back to Windows.:cry:

mychinko 06-19-2007 11:31 PM

which distro do you have? did you try a different one?

laramarvin 06-21-2007 11:29 AM

distro
 
I have Ubuntu Feisty.

I tried also with Kubuntu (KDE), same problem.

mychinko 06-21-2007 11:13 PM

try some OTHER distro, ubuntu, kubuntu, xubuntu are all the same.
something from the other side of the linux tree, like mandriva, fedora, anything.
PClinuxOS, for the best Out of the box experience, or SAM linux for that matter


All times are GMT -5. The time now is 05:39 AM.