Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 06-03-2004, 07:16 AM   #1
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Rep: Reputation: 15
Mouse pointer distorted on XFree86 4.3 with Geforce FX 5200

Yeah, I know, it seems wierd that I use the example, but that's exactly my problem. The mouse shows just to the right of where it clicks. Any help would be appriciated...

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"

Section "Module"
Load "record"
Load "extmod"
Load "dbe"
Load "dri"
Load "glx"
Load "xtrap"
Load "type1"
Load "freetype"
Load "speedo"

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/mouse"

Section "Monitor"
#DisplaySize 300 230 # mm
Identifier "Monitor0"
VendorName "GWY"
ModelName "FPD1530"
Option "DPMS"
HorizSync 31.5-48.5
VertRefresh 50-70
ModeLine "1024x768/60Hz" 65 1024 1032 1176 1344 768 771 777 806 -HSync -VSync

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "ShadowFB" # [<bool>]
#Option "UseFBDev" # [<bool>]
#Option "Rotate" # [<str>]
#Option "VideoKey" # <i>
#Option "FlatPanel" # [<bool>]
#Option "FPDither" # [<bool>]
#Option "CrtcNumber" # <i>
Identifier "Card0"
Driver "nv"
VendorName "Generic"
BoardName "nv"

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"

Depth 16
Modes "1024x768/60Hz" "800x600" "640x480"
ViewPort 0 0
Virtual 0 0

SubSection "Display"
Depth 24
Modes "1024x768/60Hz" "800x600" "640x480"
ViewPort 0 0

Virtual 0 0

Section "InputDevice"

Identifier "Mouse"

Option "Protocol" ""
Option "Device" "/dev/mouse"
Driver "mouse"
Option "Emulate3Buttons"

Section "ServerFlags"

Old 06-06-2004, 09:51 PM   #2
Registered: Apr 2002
Location: Sydney, Australia
Distribution: Mandrake
Posts: 73

Rep: Reputation: 15
OK, I'm not sure exactly how to fix your problem, but here is what I would do.

Firstly, you are not using Nvidia's driver, but the free version that came with your distro. Download it from and follow the instructions to install it. Don't forget to modify the XF86Config when you're done as per the instructions which will be installed at /usr/share/doc/NVIDIA_GLX-1.0/README

If that doesnt fix your problem, then try editing the XF86Config, and change the line
#Option "HWcursor" # [<bool>]
Option "HWCursor" "off"

This will make sure the cursor is rendered in software so you can isolate the problem to a driver configuration problem or something else.

Hope this helps.

Last edited by floyd; 06-06-2004 at 09:52 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Distorted mouse precision on Mandrake 9.1 with a Geforce 4 Ti4200 Mr. Man Linux - General 3 08-21-2004 10:48 AM
fedora core1: serial mouse disappeared w/ geforce fx 5200 + openGL questions industry7 Fedora 1 02-17-2004 12:56 AM
Mplayer XFree86 4.3 Geforce FX 5200 jeffxor Linux - Newbie 3 02-06-2004 05:25 PM
Debian Woody Xfree86 abit Geforce 4 FX 5200 (EE) No devices detected ---> no screens /su Debian 9 07-21-2003 02:19 PM
Mouse pointer jumps all over screen : xfree86 install bigpow Linux - Software 5 12-14-2001 11:09 AM

All times are GMT -5. The time now is 02:44 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration