LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 04-10-2004, 03:41 AM   #1
BrigitteT
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Rep: Reputation: 0
Angry Mouse and Keyboard stop working when X loads


Trying to do an install of Red Hat 9 on an Abit BE6 II motherboard. Installed it on another machine just fine, but the board died. Brought out the old board, updated the BIOS. When loading RH9 in text mode, keyboard works fine. But when X finally starts, the screen goes blank for a long time, then my mouse and keyboard stop completely - as if they are not even plugged in! Then X comes up and there is no mouse and keyboard functionalty at all.

When Linux boots, I see it is loading USB drivers (they say "OK"). I tried disabling USB. My mouse and KB are both PS/2. Linux doesn't even detect my mouse.

I am very new to this. I need to know if there is a way to fix this problem.

Any help please???????

Last edited by BrigitteT; 04-10-2004 at 03:43 AM.
 
Old 04-10-2004, 01:16 PM   #2
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
veiw the contents of /etc/X11/XF86Config file. (plain text)

there should be an InputDevice line that should point to /dev/psaux for the mouse.

actually just post your XF86Config file, and I may be able to tell you exactly what to change.

 
Old 04-10-2004, 02:08 PM   #3
BrigitteT
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Original Poster
Rep: Reputation: 0
OKay. I'll do this. I have to capture the contents in text mode on the downed machine, copy it to a file and then move it to the machine that I am using to talk to you. The machine that is down is obviously not on the web. I have just abandoned Microsoft stuff and am very new to Linux. So I do apologize for my ignorance. But I am about to get this done and posted here.

Thanks for your reply. Finally I have some hope!

-BT
 
Old 04-10-2004, 05:33 PM   #4
BrigitteT
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Okay. I finally figured out how to get the XF86Config file here. I hope you can help. Here it is:

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "ViewSonic OptiQuest V773-2"
DisplaySize 320 240
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 180.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "savage"
VendorName "Videocard vendor"
BoardName "S3 Savage4"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 04-10-2004, 09:01 PM   #5
BrigitteT
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Just in case no one is able to help me actually solve this problem, I wonder if maybe someone can help me try to solve it by answering a few questions.

On my other motherboard Redhat recognized the mouse and keyboard just fine. And there was no loooong pause before loading X. With this other board Redhat doesn't find the mouse at all. Is there are reason why it won't even find the mouse?????

I'm wondering if maybe I should just get another motherboard.
 
Old 04-11-2004, 03:00 AM   #6
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection


Change the line InputDevice "DevInputMice" "AlwaysCore"

to read #InputDevice "DevInputMice" "AlwaysCore"

and restart the comp. hopefully starting X.
If you would study the file for a moment youd notice that the identifier lines:
DevInputMice --> (/dev/input/mice)
and
Mouse0 ---> (/dev/psaux)

are two different mouse devices.

and the USB mouse is set to. AlwaysCore no less.
That is exactly why your mouse doesnt work.

if it still fails, keep the existing changes but also make the Mouse0 the Always Core. instaed of Core Pointer .. make one change at a time. and retry.

Mouse0 is the ps/2 mouse hub.
DevInputMice is the USB mouse .
Also make sure the ps/2 equipment is enabled from the BIOS.
I can be of further assistance if you need.

Last edited by AutOPSY; 04-11-2004 at 03:03 AM.
 
Old 04-12-2004, 01:10 AM   #7
BrigitteT
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Well, I tried everything you said and then some. It had no effect.

I think this may be a bit more fundamental than a bad X configuration. I say this because even when I try to install Linux from scratch, all goes well until it tries to detect my mouse. I get "No Mouse" when in fact the mouse is certainly installed and the ports enabled. As long as I am in text mode, the keyboard works fine. But when the graphical interface tries to load, the video flashes, turns black and sits for a long time, then I get the graphical login screen and both mouse and keyboard are dead. The only thing I can do at that point is just reset the machine.

If you have any other ideas, I am all ears. Otherwise, thanks so much for your help.

-BT
 
Old 04-12-2004, 02:21 AM   #8
vinay_s_s
Member
 
Registered: Jul 2003
Posts: 658

Rep: Reputation: 30
well u can try this:
do all stuff as root and not user.

move the /etc/X11/XF86Config file to some other directory as a backup.

go to runlevel 3 by running
init 3

and then run:
redhat-config-xfree
if that command doesn't exist, then try
redhat-config-xfree86

ps: sorry i dont remember the commands of redhat exactly since i have stopped using it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard and Mouse randomly stop working link470 Linux - Hardware 3 08-03-2005 08:12 PM
keyboard and mouse suddenly stop working TexasDex Linux - Hardware 2 06-05-2004 12:26 AM
Bug? USB Keyboard and Mouse Stop Working KingofBLASH Slackware 3 04-09-2004 01:04 PM
mouse & keyboard stop working! shycalais Linux - Hardware 6 03-19-2004 08:52 AM
Mouse and Keyboard stop working in any Windows Manager? dend Slackware 5 03-14-2004 07:56 PM


All times are GMT -5. The time now is 10:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration