LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-09-2002, 04:57 PM   #1
glock19
Member
 
Registered: Aug 2001
Distribution: Debian Etch
Posts: 510

Rep: Reputation: 31
mounting samba share


How do I use the mount command to mount a samba share on my local network? I tried looking in the man, but I couldn't figure it out.
 
Old 01-09-2002, 05:09 PM   #2
mAineAc
Member
 
Registered: Nov 2000
Location: Hermon, ME
Distribution: slackware
Posts: 201

Rep: Reputation: 30
try 'man smbmount'
 
Old 01-09-2002, 08:13 PM   #3
theFuzzyOne
Member
 
Registered: Dec 2001
Distribution: redhat
Posts: 154

Rep: Reputation: 30
smbmount

if you are using a somewhat new version of smbmount, it could be
smbmount //computer/sharename /mnt/point
or
smbmount //computer/share /mnt/point -o ip=x.x.x.x

check the man page or other docs for other options like username/password
 
Old 01-09-2002, 10:14 PM   #4
knobby
Member
 
Registered: Jan 2002
Location: Austin, Texas
Posts: 31

Rep: Reputation: 15
this is the way I mount samba shares on other machines:

mount -t smbfs -o username=name,password=password //machinename/sharename /mnt/smbshare

This work but I don't know if it's the best way
 
Old 01-10-2002, 06:45 PM   #5
glock19
Member
 
Registered: Aug 2001
Distribution: Debian Etch
Posts: 510

Original Poster
Rep: Reputation: 31
When I try this command:

Code:
mount -t smbfs //192.168.168.253/tmp /mnt/smbshare
I get the following error:

Code:
Could not resolve mount point /mnt/smbshare
Do you know what this means?
 
Old 01-10-2002, 06:50 PM   #6
knobby
Member
 
Registered: Jan 2002
Location: Austin, Texas
Posts: 31

Rep: Reputation: 15
i means there is no /mnt/smbshare. create one first:

#mkdir /mnt/smbshare
 
Old 01-10-2002, 07:06 PM   #7
glock19
Member
 
Registered: Aug 2001
Distribution: Debian Etch
Posts: 510

Original Poster
Rep: Reputation: 31
Ahh ok. I thought it would just dynamically create that directory for me. Thanks, now it works.

How do I make it so I do this mount every time my linux box boots?
 
Old 01-10-2002, 07:11 PM   #8
knobby
Member
 
Registered: Jan 2002
Location: Austin, Texas
Posts: 31

Rep: Reputation: 15
that depends on what *nix you are using. If you are using redhat, the simple way is to add that exact mount command to your /etc/rc.d/rc.local file. The right way would be to add it to /etc/fstab but I can't explain how to do that. Try doing a 'man fstab' and hack away.
 
Old 01-10-2002, 08:54 PM   #9
theFuzzyOne
Member
 
Registered: Dec 2001
Distribution: redhat
Posts: 154

Rep: Reputation: 30
automount

or u could use the automounter... lookup autofs for details
 
Old 10-01-2003, 05:47 PM   #10
Piro
LQ Newbie
 
Registered: Oct 2003
Distribution: Ubuntu 6.0
Posts: 14

Rep: Reputation: 0
ive made an sh file to mount my windows share for me... ive typed this in it...
mount -t smbfs -o username=samba,password=samba //Desktop/Public /mnt/public

ive tried everything i know, including reading the man files... i can't find smbmount either... and both dont work... ive also tried making the credentials file but nothing works... it comes out with an error of the following
mount: mount point \\Desktop\Public does not exist
./mountshares.sh: /mnt/public: is a directory

thing is, i know this directory works because when i use my other home made sh file containing
/usr/local/samba/bin/smbclient \\\\Desktop\\Public -U samba samba
it seems to work fine... and it does connect...

ive also tried to use \\\\Desktop\\Public in the original sh file to mount my shares but it doesn't seem to work, it gives me the same error...

PLEASE HELP ME!!! it seems as if its not working no matter what i try, ive also recompiled samba 3 times and each time it doesn't work...
as a note im running slackware 8.1

Looking forward to getting some help or insight on this... thanks in advance
 
Old 07-08-2011, 01:29 AM   #11
fayazvf
LQ Newbie
 
Registered: Mar 2010
Posts: 1

Rep: Reputation: 0
hi,
i tried the following command
sudo mount -t smbfs 10.102.11.79:/mnt /home/user/dir

but i get the error:
mount: unknown filesystem type 'smbfs'

What could be the problem?
I have samba installed on both the linux machines.
 
Old 07-08-2011, 04:38 AM   #12
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,408
Blog Entries: 2

Rep: Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994
Try it with -t cifs instead of -t smbfs.
 
Old 07-09-2013, 11:55 PM   #13
squirrelj
LQ Newbie
 
Registered: Jul 2013
Posts: 1

Rep: Reputation: Disabled
solution

Quote:
Originally Posted by TobiSGD View Post
Try it with -t cifs instead of -t smbfs.
guys the solution is:


# mount -t cifs -o username:<username of the smb server> <nfs-server>:/<share> /mnt/<share-loc>

- dont have to add the password option as it will be prompted when the command is entered.
- make sure the package "smbmount" is installed else install it (i.e. ubuntu --> apt-get install smbmount"

e.g.

# mount -t cifs -o username:john server1:/share1 /mnt/MyShare
 
Old 07-15-2013, 08:50 PM   #14
choronozon
LQ Newbie
 
Registered: Mar 2009
Distribution: Debian lenny & squeeze servers. Mint 13 and 14 desktops
Posts: 16

Rep: Reputation: 2
Quote:
Originally Posted by squirrelj View Post
guys the solution is:


# mount -t cifs -o username:<username of the smb server> <nfs-server>:/<share> /mnt/<share-loc>

- dont have to add the password option as it will be prompted when the command is entered.
- make sure the package "smbmount" is installed else install it (i.e. ubuntu --> apt-get install smbmount"

e.g.

# mount -t cifs -o username:john server1:/share1 /mnt/MyShare

After months of cifs hell, I decided the right answer was to use NFS, and never looked back :-)

OK that means you need the far end to run *nix as well...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting Samba Share linux_or_bust Linux - Software 6 02-16-2005 09:38 AM
Mounting XP share w/Samba KFoldesi Linux - Software 7 06-29-2004 09:51 PM
samba share mounting bacon22 Linux - Software 1 01-24-2004 07:13 AM
Mounting Samba shares and Samba Share Login time112852 Linux - Software 1 09-14-2003 02:23 PM
Mounting a Samba Share msjenkins Linux - Software 0 07-16-2003 10:19 PM


All times are GMT -5. The time now is 01:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration