LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Mounting Issues- along with GNOME issues (http://www.linuxquestions.org/questions/linux-general-1/mounting-issues-along-with-gnome-issues-647730/)

shane25119 06-08-2008 12:50 AM

Mounting Issues- along with GNOME issues
 
Hi everyone

I have been using Ubuntu since the second release or so and I upgraded to Hardy Heron a few days after it came out. This time I did a fresh install and seem to be having two issues which I suspect are related.

Firstly: My two disc drives (one a CD-RW, the other a DVD-RW) will not mount when a disc is inserted. If I reboot the system with a disc in the drive it is ok, but if I take the disc out or burn a CD/DVD and insert another disc it will not appear on the desktop, any attempt to mount is met with an error message declaring 'there appears to be no media in the drive.'

Secondly: Once this first program begins I often have trouble launching the programs that came with Ubuntu (ie: Totem, and sometimes even the file manager itself.)

Obviously this is a bit of a pain.... my question to you all is this: I read a thread on Ubuntuforums (unfortunately I did not bookmark it and cannot find it again) which suggests the easiest fix might be to reinstall Ubuntu or can this be fixed conventionally with some measure of ease?


Thanks in advance folks


Shane

eggixyz 06-08-2008 11:31 PM

Hey There,

When you take the disk out (sorry if anything I put in here is a little off, since I'm Ubuntu isn't my primary distro) and replace it, are you using umount and then mount?

Secondly, assuming you had to do umount to even get your cd rom drive to open up and let you take out the cd, what options are you giving to the mount command? It may be that the options automatically set for mount at boot up are different than what you're using when you re-mount. If you check /etc/fstab it may give you a clue, but, in any event, if you could post your mount command (that results in the error), I might see the issue there.

Thanks :)

, Mike

shane25119 06-09-2008 11:55 PM

Howdy

When I unmount I usually just right click on the disc logo on the GNOME desktop and hit the 'unmount volume' option. Funny thing happened actually.... I reinstalled Ubuntu thinking maybe the Nautalis package got corrupted somehow... I had a blank cd in the drive which I mounted and unmounted a whole shlew of times.... I went to work this morning... and when I came home the cd was no longer on the desktop, but my DVD drive which had a movie DVD in it, was still there. So I tried to unmount it.... that unceremoniously froze and no my desktop is all lonesome....

Also, now Brasero (a GNOME) cd burning application refuses to start, as does the 'Computer' window (think of it as a GNOME version of 'My Computer' {Don't mean to imply you don't know this... just don't know if you're a KDE or XFCE kinda person} ).

So perhaps my /etc/fstab is relevant? Everything is fine upon bootup, so I have copied that file here.

Thanks much in advance for your help

Shane

Code:

# /etc/fstab: static file system information.
#
# <file system> <mount point>  <type>  <options>      <dump>  <pass>
proc            /proc          proc    defaults        0      0
# /dev/sda1
UUID=ee5801c7-e680-44c3-8d8a-0b911760bf93 /              ext3    relatime,errors=remount-ro 0      1
# /dev/sda3
UUID=58b45b5d-990f-4865-b92f-e7a114823c4d /home          ext3    relatime        0      2
# /dev/sda2
UUID=ba59e2e2-fb45-43ff-b0e1-fc70b94fa688 none            swap    sw              0      0
/dev/scd0      /media/cdrom0  udf,iso9660 user,noauto,exec,utf8 0      0
/dev/scd1      /media/cdrom1  udf,iso9660 user,noauto,exec,utf8 0      0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0      0


eggixyz 06-10-2008 11:41 AM

Hey There,

No offense taken. I actually am more of a command-line junkie. Lots of bad experiences back in the 90's and forced to SSH to boxes at work ;)

I wonder if the shortcuts (or however Nautilus has the CD/DVD mounts set up) isn't goofy. If you could open up an xterm window, after ejecting a working CD from boot up, put it back in and then run either:

mount /dev/scd0

or

mount /media/cdrom0

either should, theoretically, work, and grab the options info from /etc/fstab

Otherwise, you could be very specific on the command line and do

mount -t udf,iso9660 -o user,noauto,exec,utf8 /dev/scd0 /media/cdrom0

or try not using either udf or iso9660 as the fstype:

mount -t iso9660 -o user,noauto,exec,utf8 /dev/scd0 /media/cdrom0

or

mount -t udf -o user,noauto,exec,utf8 /dev/scd0 /media/cdrom0

From the -o side, maybe taking out "noauto" might help, althought it shouldn't make a difference.

Of course, there are a lot of different ways you can put that command line together, using various options, and combinations of. If any of those work, check the GUI and see if you can look at the command it's running (Hoping it's like Windows, somewhat, and will let you look at the properties of the link and show the command line :)

Best wishes,

Mike

shane25119 12-14-2008 02:11 AM

I know this is far after the fact- but I want to give this thread some closure. I work in politics- so I hadn't much time to do this since back in June... and I just so happen to be bored at 3am searching my old threads....

The problem lay with the CD-RW drive which was dying- so I simply removed that drive- no more problem :-)

eggixyz 12-14-2008 05:12 PM

Whatever works is the best solution ;)

Glad to hear you're all set :)

Best wishes,

Mike


All times are GMT -5. The time now is 03:28 AM.