LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-14-2004, 04:29 PM   #1
timsch75
Member
 
Registered: Feb 2004
Location: austin, TX
Distribution: slackware 10
Posts: 169

Rep: Reputation: 30
mounting FAT (not FAT32) file systems w/ 2.4 kernel


I have an mp3 player (iriver ifp-300) that will only allow FAT formatting. I have no problem mounting fat32 filesystems in linux but have not had to mount FAT fs until now. I put the line

/dev/sdb2 /mnt/mp3 vfat noauto,users 0 0

in fstab and the device would mount, but the folders and files were unrecognizable. I changed the line to:

/dev/sdb2 /mnt/mp3 fat noauto,users 0 0

blindly hoping that would be correct, but i then get the following error message:

mount: fs type fat not supported by kernel

I've got slack 10 with the 2.4.26 kernel. I'd have thought that it would support FAT....

What do I need to do to be able to mount FAT fs?
 
Old 11-14-2004, 04:56 PM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 67
vfat is the device driver to support both FAT16 and FAT32 filesystems.

The most likely problem is that your mount-point is wrong; many such devices only use one partition, in which case it would be /dev/sdb1 not sdb2. Also, sdb is the second SCSI (or USB mass storage) device; make sure you have the right one.

The fact that you use the word unrecognizable implies that you are seeing files and directories with strange names (unusual characters). In which case, you have the wrong codepage selected; you'll probably want something like UTF8 or Unicode (at a guess).

You can change this in the options column of the fstab entry; A list of options for vfat can be found in the file /usr/src/linux/Documentation/filesystems/vfat.h

eg.
Code:
/dev/sdb2 /mnt/mp3 vfat noauto,users,utf8=true 0 0
 
Old 11-14-2004, 08:53 PM   #3
timsch75
Member
 
Registered: Feb 2004
Location: austin, TX
Distribution: slackware 10
Posts: 169

Original Poster
Rep: Reputation: 30
I use sdb2 because I have my camera mount on sdb1 in fstab. This is what I get when I plug the mp3 player in:


Nov 14 20:51:22 sbc kernel: sdb: sdb1 sdb2 sdb4

so I just picked sdb2 and it does mount there without error messages. I can change to the mp3 directory. when I list contents, I get the following (in part):

? ntldr ntldr ?.} <?msdos.5.0 <?msdos.5.0 at2nt??. ; at2nt??. ; estart?? f??f??v?.?f? f??f??v?.?f? ?Ѽ{?ٸ ??v$?a.ar? ??v$?a.ar? ntldr ntldr ?.} <?msdos.5.0 <?msdos.5.0 at2nt??. ; estart?? estart?? f??f??v?.?f? f??f??v?.?f? ?Ѽ{?ٸ ??v$?a.ar? ??v$?a.ar? ntldr ?.} ?.} <?msdos.5.0 <?msdos.5.0 at2nt??. ; estart?? estart?? f??f??v?.?f? f??f??v?.?f? ?Ѽ{?ٸ ??v$?a.ar? ??v$?a.ar? ntldr ?.} ?.} <?msdos.5.0 <?ms

I've tried the utf8 option as you listed, to no effect.
 
Old 11-15-2004, 04:07 AM   #4
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 67
What happens when you try it with sdb4?

Also, just looking at this text, it looks like the filesystem is encrypted; at least .ar? looks like it should be .mp3. This isn't UTF8 or unicode, but it might be some other codepage.

You might have to use one of the crypto loopback device options to make this work; I don't have any details to hand but I'd recommend looking through the kernel documentation for options etc.
 
Old 11-15-2004, 09:49 AM   #5
timsch75
Member
 
Registered: Feb 2004
Location: austin, TX
Distribution: slackware 10
Posts: 169

Original Poster
Rep: Reputation: 30
I'm not at my computer now, so I cannot try /sdb4, but why would the mount point make a difference? I agree that it looks like a conversion problem. I'll look at the kernel documentation when I get home. I'm just surprised I'm having a problem with FAT conversion.
 
Old 11-16-2004, 02:46 PM   #6
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 67
The mount point won't make any difference, but the device file you use is set by the kernel, and that must be correct. The device file is /dev/sdb2 or /dev/sdb4. The mount point can be almost anything , but usually starts with /mnt/ or /media/

If you get the device file wrong, you'll be trying to mount the wrong device, or the wrong partition/filesystem. I can imagine an mp3 player might use both encrypted and non-encrypted mount-points, for example.
 
Old 11-16-2004, 05:17 PM   #7
timsch75
Member
 
Registered: Feb 2004
Location: austin, TX
Distribution: slackware 10
Posts: 169

Original Poster
Rep: Reputation: 30
Ok, I figured it out. The line in dmesg pertaining to my mp3 player was

Nov 14 20:51:22 sbc kernel: sdb: sdb1 sdb2 sdb4

I was trying to mount /dev/sdb2 in fstab. I needed to mount /dev/sdb
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Question on Mounting Virtual Kernel File Systems satimis Linux From Scratch 4 07-21-2005 09:04 PM
Problem in "Mounting Virtual Kernel File Systems" satimis Linux From Scratch 7 07-05-2005 06:57 AM
Mounting Virtual Kernel File Systems - Help Pls chakkaradeepcc Linux From Scratch 2 05-13-2005 06:53 AM
Is arrangement of file systems will differ if we copy a file from FAT 32 to ext 3 ? anindyanuri Linux - Software 2 02-20-2005 11:39 AM
kernel 2.6.10 - error mounting local file systems sirrus_linux Linux - Software 6 02-12-2005 01:07 PM


All times are GMT -5. The time now is 09:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration