LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-11-2006, 04:03 PM   #1
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
mount: server:/home can't read superblock


I have some nfs shares on a server that are mounted on my workstation, if I reboot the workstation then on startup when mounting the nfs shares the system hangs for a couple of minutes and spits out this message:
Code:
mount server0:/home can't read superblock
But once I get a prompt I can mount the nfs filesystem.

If I shutdown the workstation for five minutes or so then boot up normally the nfs shares mount fine during the boot process.

The server runs FreeBSD 6.0 Release-p6 and I'm using nfs that comes with the system (not the one from ports). The workstation runs arch current.

This is a home network so most of the time there is only one workstation mounting these nfs shares and never more than 3.

The relevant part of /etc/fstab from the workstation goes like this:
Code:
server0:/home         /home       nfs          defaults               0      0
server0:/disk1/music  /mnt/music  nfs          defaults               0      0
server0:/disk1/films  /mnt/films  nfs          defaults               0      0
/etc/exports from the server is:
Code:
/home   -maproot=nobody -network 192.168.10.0 -mask 255.255.255.240
/disk1/music /disk1/films \
        -maproot=nobody -network 192.168.10.0 -mask 255.255.255.240
I am not running the statd or lockd daemons, on the server but I am running nfsd, rpcbind and mountd. The output of rpcinfo -p from the server is
Code:
   program vers proto   port  service
    100000    4   tcp    111  rpcbind
    100000    3   tcp    111  rpcbind
    100000    2   tcp    111  rpcbind
    100000    4   udp    111  rpcbind
    100000    3   udp    111  rpcbind
    100000    2   udp    111  rpcbind
    100000    4 local    111  rpcbind
    100000    3 local    111  rpcbind
    100000    2 local    111  rpcbind
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100005    1   udp    891  mountd
    100005    3   udp    891  mountd
    100005    1   tcp    900  mountd
    100005    3   tcp    900  mountd
Code:
showmount -e server0
issued from the workstation correctly displays all the nfs shares on the server

On the workstation I made sure the network was initialised and the portmap daemon started before mounting the nfs shares.

When running mountd and rpcbind in debug mode on the server mountd reports mount successful when the workstation tries to mount the first nfs share even though 2 mins later the client says can't read superblock. On the server /var/db/mountdtab reckons the share is mounted even though it isn't. On shutting down the client the appropriate entries are removed from /var/db/mountdtab as I would expect. rpcbind remains silent.

I have tried using nfs version 3 on the client, using tcp instead of udp, I've tried using 1 and 2 for dump and pass respectively in /etc/fstab on the client. I've tried using the IP address of the server rather than it's hostname. There are 3 nfs shares that are mounted and I've tried changing the order in which they are mounted.

I've replaced network cables, cards, and the switch just in case it was some bizarre hardware problem, but the problem persists.

Finally if I shutdown the client and start up again after 30 seconds then mounting the first nfs share takes about a minute but is successful.

Once the nfs shares are mounted they work flawlessly

It seems to me, there is some timeout value, or some thing isn't properly registering when the client shuts down, I've run out of ideas and can't seem to find anything useful in the man pages. If I umount an nfs share from the command line then immediately mount it again it works no problem and with no hesitation.

Rarely when I boot up the client even though it has been turned off for a night ~8 hours mounting the nfs share fails with the same message, I'm hoping its related and fixing one will fix the other.

OK, the actual question: How do I get the nfs shares to mount properly after a reboot of the client?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I get mount: /dev/cdrom: can't read superblock, How to fix? zLinuxz Linux - General 12 06-18-2008 02:42 AM
error mounting ext3 filesystem... mount: /dev/hdd1: can't read superblock versaulis Linux - Software 5 11-26-2006 08:34 PM
mount: /dev/cdrom: can't read superblock raynmune Linux - Hardware 7 07-09-2005 04:02 PM
unable to Mount server home directory to clients abhishek124 Linux - Networking 1 06-24-2005 02:44 AM
read-only shared mount between linux and w2k server fostiator Linux - Networking 1 06-10-2004 03:14 AM


All times are GMT -5. The time now is 10:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration