LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Poll: Is this common problem ?
Poll Options
Is this common problem ?

You must log in and have one post to vote in this poll. If you don't have an account, you can register here.
Results will be available after the polls close.

The nominees are:

yes
no
not very
Don't Know

Reply
 
Search this Thread
Old 12-28-2001, 02:52 AM   #1
atul_jadhav
LQ Newbie
 
Registered: Dec 2001
Location: Pune
Posts: 1

Rep: Reputation: 0
Unhappy Mount Problem for NTFS (WIN2k) FIle System


Hello there ,
I was trying to mount a win2k ntfs partition on linux 7.1
i used command
"mount -t ntfs /dev/hdc2 /mnt/hdc2"
but then system gave me message that
"kernal doesn't support ntfs file system"

is there any other way to mount win2k ntfs partition or what should i do to mount ntfs partition on linux 7.1

If you know the solution please email me at atul_jadhav@rediffmail.com

Thanks You Very Much
Best Regards

Atul
 
Old 12-28-2001, 05:50 AM   #2
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
This is not a problem, it is going to require kernel support or module support for the file system. Most distros do not install with support for ntfs by default. As a matter of fact I don't know of any that do.

You should recompile your kernel and add support if you need it.
 
Old 12-28-2001, 06:27 AM   #3
elist
Member
 
Registered: Dec 2001
Location: MK - UK
Distribution: Mandrake
Posts: 94

Rep: Reputation: 15
Don't know. When I installed ML8.1 I was able to mount the NTFS partition while I was doing all the others, it ended up being on
/mnt/windows
I also had a FAT32, and the XP hidden partition so there was also
/mnt/win_c
/mnt/win_d
 
Old 12-30-2001, 05:25 PM   #4
bobirt
LQ Newbie
 
Registered: Dec 2000
Distribution: Mandrake 8.0
Posts: 9

Rep: Reputation: 0
Mount ntfs

I had the same message in MDK 8.0 but follow the steps:


0) in /mnt : mkdir (your hdXX or how you want to call it but keep it the same after)

1) In root: cat /proc/filesystems
-> it will give you the supported filesystems by your kernel
-> if ntfs is there then you must be able to mount it

2) /etc : vi fstab
-> add the line (in my case it is after cdrom)
-> dev/hdXX /mnt/hdXX ntfs defaults 0 0

save the file and exit.

reboot your system and hopefully it should work.

If you are using MDK 8.0 go to root:diskdrake
-> choose partitions to mount; then choose Toggle to expert mode, it will give you the options to whwre do you want to mount it. From there it is easy.

Hope it works.
 
Old 12-30-2001, 09:53 PM   #5
infinity6
Member
 
Registered: Dec 2001
Posts: 66

Rep: Reputation: 15
I don't know about Mandrake, but as of kernel 2-4, NTFS support was still experimental. Before you start playing around with NTFS partitions, realize that the kernel support may still be experimental!!! This could cause irreperable damage to files, file-system, or even the hard disk. If you want the whole details, I would check out http://www.kernel.org and see what the kernel developers have done lately before playing with it.
 
Old 12-31-2001, 09:50 AM   #6
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
A lot of this depends on distrobution. NTFS support, at least read-only, has been in the kernel since mid-2.2.x, but most of the major distros didn't put it in as a module in their default shipping kernel until a major version later. I think for RH it first appeared as a default module in 6.2, Slackware I know it was in 7.0, the rest I'm fuzy on, but its part of the default in all of them now. Also, depending on distro, daemons like mountd may or may not be allowed to call for the loading of modules. Probably all you need to do is: insmod ntfs, and then go ahead and mount the drive as normal (just like you had it). There's a lot of scuttlebutt as to how un-stable leaving that module in the running kernel actually makes things. Basically, read-only; no problem in 2.4.x but kinda iffy in 2.2.x. Since 2.4.3 (I think), there has been write support, but using that is just a bad idea unless you want to hose your NTFS partition.

Read-write support for NTFS is probably going to kick off in a big way now that everyone and their dog has a dual boot win2k/XP+Linux box.

Cheers,

Finegan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to read .chm file in fedora, can't mount ntfs file system ishti_du Linux - Newbie 12 03-06-2007 04:27 AM
How do I Mount a Windows NTFS file system explorer Linux - Networking 15 05-06-2004 09:01 PM
NTFS file system mount problems Fedora 2.4 jjisnow Linux - Newbie 2 03-23-2004 06:42 PM
Can We Mount NTFS Windows file System from linux gautam_iiith Linux - General 6 10-23-2003 07:47 PM
mount the ntfs file system jdevanand Linux - General 3 01-22-2002 02:25 PM


All times are GMT -5. The time now is 05:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration