LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 11-27-2003, 12:34 PM   #1
abruneau
LQ Newbie
 
Registered: Nov 2003
Posts: 2

Rep: Reputation: 0
Unhappy mount: /dev/cdrom is not a valid block device


Help!

Since today, I can't mount a cdrom on my Red Hat 7.2 Compaq:

[root@coffeemaker root]# mount /dev/cdrom
mount: /dev/cdrom is not a valid block device

[root@coffeemaker root]# cat /etc/fstab
....
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0
0
.....

[root@coffeemaker root]# ls -l /dev/cdrom
lrwxrwxrwx 1 root root 8 fv 14 2003 /dev/cdrom -> /dev/hda
[root@coffeemaker root]#

[root@coffeemaker root]# dmesg |grep hda
ide0: BM-DMA at 0x2000-0x2007, BIOS settings: hdaio, hdbio
hda: CD-224E, ATAPI CD/DVD-ROM drive
hda: driver not present
hda: driver not present

root@coffeemaker root]# cat /var/log/messages
....
Sep 14 19:18:27 coffeemaker kernel: ide-floppy driver 0.97
Sep 14 19:18:27 coffeemaker modprobe: modprobe: Can't locate module ide-cd
Sep 14 19:18:27 coffeemaker kernel: hda: driver not present

Thanks you for your help.
Alain Bruneau.
 
Old 11-27-2003, 01:21 PM   #2
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
hi pal

if u have defined ur cdrom as mount point, then try

mount /mnt/cdrom

this wud mount your cd-drive. If u have not defined any mount-points, u will have to try

mount /dev/scd0

ie, u will have to give the device name.

Hope this helps
 
Old 11-27-2003, 01:27 PM   #3
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
u definetely need to define mount points.

and if u then mount a device, like ur hard-disk partition or ur cd

mount /dev/hda3 /mnt/cdrom

ie, u mount ur hda3(say) partition onto ur predefined cdrom mount-point.

Always remember, u have to be root to be able to mount.
 
Old 11-27-2003, 01:29 PM   #4
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
did a little googling

http://members.blue.net.au/felgall/lincmd2.htm

This will surely help.
 
Old 11-27-2003, 01:36 PM   #5
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
hi pal

if u have defined ur cdrom as mount point, then try

mount /mnt/cdrom

this wud mount your cd-drive. If u have not defined any mount-points, u will have to try

mount /dev/scd0

ie, u will have to give the device name.

Hope this helps
 
Old 11-28-2003, 02:58 AM   #6
abruneau
LQ Newbie
 
Registered: Nov 2003
Posts: 2

Original Poster
Rep: Reputation: 0
Thank you for your replies. I tried to apply your advice ithout success (see output) :

[root@coffeemaker root]# ls -l /dev/cdrom
lrwxrwxrwx 1 root root 8 fv 14 2003 /dev/cdrom -> /dev/hda
[root@coffeemaker root]# cat /etc/fstab |grep cdrom
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0
0
[root@coffeemaker root]# mount /dev/cdrom
mount: /dev/cdrom is not a valid block device
[root@coffeemaker root]# mount /dev/cdrom /mnt/cdrom
mount: /dev/cdrom is not a valid block device
[root@coffeemaker root]# mount /dev/hda /mnt/cdrom
mount: /dev/hda is not a valid block device
[root@coffeemaker root]# mount /dev/scd0 /mnt/cdrom
mount: /dev/scd0: unknown device
[root@coffeemaker root]# ls -l /dev/scd0
brw-rw---- 1 root disk 11, 0 ao 30 2001 /dev/scd0

I think it's a driver problem. And you ?
 
Old 11-28-2003, 01:35 PM   #7
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
hi fella.

I dont thinks its a driver problem. Do the following.

1. Go to the console. You shud be root.

2. Change directory to /mnt

3. do ls.

4. Do u see any list.

5. if u see nothing, then u have not defined ur mount points.

6. Check out the url i gave b4.

http://members.blue.net.au/felgall/lincmd2.htm

Following the steps explained on this web page will definetely solve ur problems.
 
Old 12-04-2003, 05:31 AM   #8
heckler
LQ Newbie
 
Registered: Dec 2003
Location: matrix
Distribution: debian
Posts: 1

Rep: Reputation: 0
hi there

got a similar or just the same prob with my knoppix/debian sys - first it worked with mounting just
/cdrom
and an fstab entry like
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
however after some time (or after installing whatever, or mounting whatever disc) it said:
mount: /dev/cdrom is not a valid block device
no matter whether i told
mount /cdrom
or
mount /dev/cdrom
which both should work fine
changing my fstab to
/dev/hdc ................
for @ startup (dmesg) the sys recognices my cdrom (dvd combo) as hdc fixed the prob, however, now i e.g cannot 'eject' it, i also have not yet tried to burn a cdrom or dvd.... so it may not be the most elegant/sophisticated way....

hope it helps
......
h

Last edited by heckler; 12-04-2003 at 05:40 AM.
 
Old 01-01-2004, 09:31 PM   #9
w_ashley
LQ Newbie
 
Registered: Jan 2004
Posts: 10

Rep: Reputation: 0
I'm having the same issue. I was able to succsfully mount my floppy but no luck wiith the cdrom.

Note my install was a little "odd"

the bios on this older ast model has a bios that doesn't support cdrom boot... and I have yet to be able to flash one that does since ast went offline.

So in order to install I had the drive hooked up to another computer which did support cdrom boots... the issue being that my graphics card and other hardware which it was configured to was different and debian doesn't seem to autoconfigure each boot like windows does.Note it does detect it but it doesn't automatically recofigure access it seems nor promt reconfiguration(perhaps that is an idea for a software program.or future feature of the os)

I had another harddrive hooked up to the ide point however it didn't seem to be mountable either.. I'm tempted just to get my data via ftp and reformat.. however I relize now that it doesnt make much of a difference since I would have to reinstall on the other system again anyway.. UNLESS I use the 20 disk boot method... then see if it mounts at that point that would be a slight pain in the but. Thing is it is saying "/dev/cdrom is not a block device" it says that /cdrom is not iin fstab however it is... it just doesn't logically make sense. I'm a newbie ... it detected on boot fine.. so what is the issue? note I'm still looking aroud if I find a solution I'll run back ":even: if the sollution is wiping the system and fresh installing off floppies... 2 days latter... oh and happy new year..
 
Old 01-01-2004, 09:39 PM   #10
w0000422
Member
 
Registered: Dec 2003
Distribution: redhat linux 9.0
Posts: 60

Rep: Reputation: 15
that's what i normally do for mounting the cdrom...
1st u need to create a directory, let's say is win, using this command line "mkdir win",
then use this command "mount /dev/cdrom /win" to mount ur cdrom to win,
finally, u can use "ls /win" to check.

this method is always work fine to me but u need to remount again once u reboot...
to make it permanently change u need to modify the /etc/fstab file.
 
Old 01-01-2004, 09:54 PM   #11
sharper
Member
 
Registered: Aug 2002
Location: MN USA
Distribution: slakware 9.0
Posts: 121

Rep: Reputation: 15
You used to be able to mount the CD-Rom?

What does ls -l /dev/hda give you. It should be something like
brw_r_____ followed by some other stuff. Owner should probably be root. If you don't have a /dev/hda you'll have to get one of the gurus to tell you how to run MAKEDEV



Also you might want to double check and make sure iso9660 for a file system is in your kernel. If you recently recompiled it would be easy to leave that out.

Last edited by sharper; 01-01-2004 at 09:56 PM.
 
Old 01-01-2004, 10:24 PM   #12
w_ashley
LQ Newbie
 
Registered: Jan 2004
Posts: 10

Rep: Reputation: 0
a partial fix was the following.. although it is still buggy

ls -l /dev/cdrom
gives listing
protection 3 date "ASSOSATION"
lrwxrwxrwx 1 root root 3 Dec 21 9:16 /dev/cdrom -> hdc

using ASSOSIATION which happens to be hdc

I can do the following

mount /dev/hdc /mnt/cdrom

and iit mounts

well nearly.. you see its not really hdc anymore its hdd......

so I have to use

mount /dev/hdd /mnt/cdrom

and it mounts...???

although it says block devioce /dev/hdd is write protected, mounting readonly.. like I could write anyway.... although it would be interesting to see what happens if I enable wriite on hte device.. .. my burer is on another box that does its stuff fine it seems.. so yah that fixed it...

so IF the device show up in initial hardware check.. then it should be on a device point somewhere so if you try to mount them all using the

mount /dev/[devicename hdahdbhdc etc..] you should be able to mount it.. although if you blindly try mounting everything ... you may ... if it isnt protected remount a already mounted system as something else.. so.... just try the ones that you know arn't already mounted.. like for instance your root mount most certainly already will be.. .anyway



note you cant open the cdrom whuile it is mounted ...... although if you umount /mnt/cdrom you can open it .. so IT WORKS.. well almost......

you see once you read the device point /mnt/cdrom .... you can't umount it... cause /mnt/cdrom:device is busy....... and it sounds like it is spinning...
so you can't stop it ok hold on it stopped spiinng lets see..

ok it stops and you can open it but it takes around a minute .... hardware with personality.. wheres my shotgun

note befor you can open it after it stops spinning you still have to umount it.

so yah it seems to be a fix... unless thats the way its suppose to work and all the turorials are maddening propaganda.. anyway

It may be that my fstab reads the hdc while it is hdd so if I change hdc to hdd on my /dev/cdrom line in fstab it may fix it??????

Last edited by w_ashley; 01-01-2004 at 10:45 PM.
 
Old 01-01-2004, 10:30 PM   #13
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
there was a bug in RH7.2. enter 'depmod -ae' at a root term. if you haven't totally hosed your system with all the mount point twiddling, the depmod should take care of it.
 
Old 01-01-2004, 10:33 PM   #14
w_ashley
LQ Newbie
 
Registered: Jan 2004
Posts: 10

Rep: Reputation: 0
I tried the depmod -ae

didn't work

I'm using debian not redhat.
 
Old 01-01-2004, 10:50 PM   #15
w_ashley
LQ Newbie
 
Registered: Jan 2004
Posts: 10

Rep: Reputation: 0
ok I added the line
/dev/hdd /cdrom iso9660 ro,user,noauto 0 0

and when I type

mount /dev/hdd it mounts my cdrom now......... in /cdrom

now i just need to figure out how to change hdd to cdrom in the /dev listing whereever that file is and I get the feeling it will be the sollutino and that is the file I should have changed in the first place
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/dev/cdrom is not a valid block device cannot mount eatmars Linux - Hardware 1 10-02-2005 08:50 AM
mount: /dev/cdrom is not a valid block device aikempshall Slackware 7 01-15-2005 03:36 AM
/dev/cdrom is not a valid block device ukrainet Linux - Newbie 1 12-27-2004 05:29 AM
mount: /dev/cdrom is not a valid block device FXRS Slackware 2 05-25-2004 12:32 AM
/dev/cdrom is not a valid block device kryptotronic Debian 8 04-04-2004 06:11 PM


All times are GMT -5. The time now is 06:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration