LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-05-2007, 02:41 AM   #1
g4j31a5
Member
 
Registered: Sep 2006
Distribution: open SuSE 10.0
Posts: 116

Rep: Reputation: 15
Monitor suspension


Hi, actually I've posted a similar thread but because it's ages ago, I decided to start a new one.

I know that to disable the monitor suspension, I have to use the "xset -dpms" in the console. I've done that and it worked. At least until I resetted the machine and the DPMS was turned on again automatically. I've also deleted the "DPMS" option in the Monitor section in xorg.conf but the monitor suspension is always turned on everytime I resetted the computer. How do I set the monitor suspension off permanently?

Thanks in advance.

BTW, I used SuSe 10.0 with KDE.

Last edited by g4j31a5; 01-05-2007 at 02:47 AM.
 
Old 01-05-2007, 09:06 PM   #2
FnordPerfect
Member
 
Registered: Dec 2006
Location: Germany
Distribution: Kubuntu (Feisty Fawn), Debian (SID)
Posts: 127

Rep: Reputation: 15
You have to make sure, that xset -dpms is executed every time your X session starts. Depending on how your distro is configured, it might be sufficient to create a simple shell script in your home directory which is automatically executed when you log in.
It is called ~/.Xsession
Just put your command in there, make it executable (by typing chmod +x ~/.Xsession) and hope that I'm not telling bullshit here. ;-)

Also, in my KDE 3.5.5 there is a tab in kcontrol (KDE Control Center) to comfortable configure this stuff. It is in
Peripherals -> Display
The one with the energy star logo.
 
Old 01-05-2007, 10:26 PM   #3
hbush
Member
 
Registered: Aug 2003
Location: Iecava, Latvia, EU
Distribution: PCLinuxOS, Mandriva x86-64
Posts: 48

Rep: Reputation: 15
Quote:
Originally Posted by FnordPerfect
You have to make sure, that xset -dpms is executed every time your X session starts.
For some distributions (e.g. PCLinuxOS 0.93) it might be necessary also to switch off X Screensaver (which is another one, besides screenserver mentioned in KDE Control Center). This X Screensaver blanks screen after some inactivity even if there is no screensaver defined in KDE CC and shows white letter X on it (different size).

To take off both forms of blanking, use (as root):
xset s off
xset -dpms


And then to see if it's OK,

xset -q

timeout: 0 Means Screensaver is off.

In previous versions of PCLinuxOS it wasn't necessary to switch off explicitly this X Screensaver. However for some unknown reason this X thing comes up even unwanted in 0.93 .
 
Old 01-08-2007, 01:22 AM   #4
g4j31a5
Member
 
Registered: Sep 2006
Distribution: open SuSE 10.0
Posts: 116

Original Poster
Rep: Reputation: 15
Sigh... Didn't work. I tried disabling the Energy Star in KDE's Control Panel but didn't work. I tried editing the Xsession, didn't work.

BTW, when I located Xsession, I found 2 of them. One in "/etc/X11/xdm" and the other one is in "/opt/kde3/share/config/kdm/". I've added "xset -dpms" and "xset s off" to both of them and still the screen blanking occurs.

What should I do now?
 
Old 01-11-2007, 07:47 PM   #5
FnordPerfect
Member
 
Registered: Dec 2006
Location: Germany
Distribution: Kubuntu (Feisty Fawn), Debian (SID)
Posts: 127

Rep: Reputation: 15
Puzzling.

So when you booted into KDE, with Energy Star stuff in KDE's Control Panel turned off, what does the output of xset -q say?

Perhaps KDE or some other stuff re-enables DPMS along the way.
So... just let's make sure it is turned off again by adding it to some other random places... :-/
Let's create a simple shell script in ~/.kde/Autostart (or whatever folder you set as being the Autostart folder).

DisableDPMS.sh:
Code:
#!/bin/sh
xset -dpms
xset s off
Be sure you made it executable with chmod +x DisableDPMS.sh


(Oh dear, I hope that helps. If you sometimes get that feeling that in Linux one has to invest far too much time in some trivial things, I sadly have to agree...
but "this other OS" has its own share of problems, too, I guess.)

cheers
 
Old 01-12-2007, 12:43 AM   #6
g4j31a5
Member
 
Registered: Sep 2006
Distribution: open SuSE 10.0
Posts: 116

Original Poster
Rep: Reputation: 15
>>So when you booted into KDE, with Energy Star stuff in KDE's Control Panel turned off, what does the output of xset -q say?

It said that the DPMS was still on.

BTW, I've tried your suggestion of making a shell script in autostart and it worked. Thanks alot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
default monitor on nvidia / dual monitor setup fenderog Suse/Novell 3 05-01-2009 05:36 PM
Issue trying to dual monitor with Dell 2005FPW LCD monitor damg Linux - Hardware 2 12-05-2005 10:13 AM
New monitor problems, Fedora Cora 3, Samsung 913N monitor gingermeatboy Linux - Hardware 2 08-23-2005 08:22 AM
Monitor doesn't wake up after stanby and battery monitor problems (tm) Linux - Laptop and Netbook 2 03-23-2004 06:34 AM
Monitor problems -- changing resolution back w/o monitor Jiawen Linux - Hardware 5 03-17-2004 10:06 PM


All times are GMT -5. The time now is 10:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration