LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Monitor resolution too high for my monitor (http://www.linuxquestions.org/questions/linux-general-1/monitor-resolution-too-high-for-my-monitor-155054/)

mjames_84 03-08-2004 01:24 PM

Monitor resolution too high for my monitor
 
I Installed a copy of SuSE on a PC using a friends PC, which has a 17" TFT Monitor with a resolution of 1280*1024 however now that ive got the computer home, i cant get the GUI to start because the resoltion is set too high for my 15" CRT Monitor to display.

I know I perhaps should have thought of this before I brought it home but its too late now, is there a way of altering the resolution kde starts in using the command prompt? or a way of starting in safe mode.

Whist i consider myself an advanced user, im relativley new to the world of Linux (a bit of a contridiction there perhaps but never mind) anyway any help would be greatly recieved

Creak 03-08-2004 03:15 PM

We agree that all you need is to change the XF86Config-4 file (which is the Xserver config file) and that the problem is that u cant access to a term before X starts.

So, i don't know if it works, but u can try ;)
I suppose the Suse installation is almost like the debian one (i never tried Suse)
With your installation CD, try to boot on it. when u have loaded a kernel, try to press CTRL+ALT+F2. you should arrive at a term prompt.
try to mount your "/" partition, there edit the /etc/X11/XF86Config-4 file with vi or nano or any editor you have. and there change the appropriate value (if you r using 24bit depth resolution, change the line refering to this one by deleting the "1280x1024" string.

normally it should works...
hope it helps
Creak

mjames_84 03-08-2004 03:35 PM

That isn't an option at the moment, my install disk is a DVD+R i used my friends DVD Drive to install it but the system now only has a CDRW drive....

ProtoformX 03-08-2004 03:50 PM

login as root and do a xf86config, with this does is setup xfree86 by asking you some questions....

Creak 03-08-2004 05:50 PM

if u have an access to the net, download an cd-iso image of any distrib (Debian?) and burn it. Or get a distrib CD from a friend, just have another boot than the default one. There, you could have a term...

Maybe there is another solution (like the F8 for windows before the boot) but i really don't know it, although i think i've heard of some kind of manipulation in a forum but i can't tell you more, sorry. I only know that the script that launch the services is "C-c proof" (i don't know how to say it, but i like the expression :)) so don't try to abort it when it is launched...

Hope youll find a solution
Creak

DavidPhillips 03-08-2004 08:46 PM

Your system still boots right?

I don't know exactly where your files are so try this..
Code:

cat /var/log/* | grep /etc/X11/XF86
you'll see something like this..
Code:

(==) Using config file: "/etc/X11/XF86Config"
That's the file to edit.

now look at this..
Code:

cat  /etc/X11/XF86Config |grep Modes
                Modes    "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
                Modes    "640x480"

The Modes line needs to be edited. Here is a way to do it with sed..

Include the exact text in the file to be removed like this.. sed s/'Modes *text to be removed'/Modes/ as shown..
[code]

cat /etc/X11/XF86Config |sed s/'Modes *"1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768"'/Modes/ > newconfig



Check the results with diff the difference in the two files will be displayed

Code:

diff newconfig /etc/X11/XF86Config
116c116
<              Modes "800x600" "640x480"
---
>              Modes    "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"

Now you can backup and replace the contents of the file /etc/X11/XF86Config
Code:

cp /etc/X11/XF86Config /etc/X11/XF86Config.bak
cat newconfig > /etc/X11/XF86Config


You could also edit the file with an interactive editor if you want.

RolledOat 03-08-2004 10:06 PM

If you can get to the command prompt, enter
sax2
as root, it brings up the Suse X configurator. If you are stuck looping with X trying to start, reboot, start linux safe, and then start sax2 once you are logged into the console as root.

RO

DavidPhillips 03-09-2004 10:51 PM

I would not attempt to reconfigure X just to change the screen size, but that is just my opinion.


All times are GMT -5. The time now is 11:07 AM.