Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 11-22-2003, 01:08 AM   #1
Registered: Oct 2003
Location: India
Distribution: Debian
Posts: 95

Rep: Reputation: 15
Question Modules not loading in New kernel

I am using 2.2.16.SuSe kernel.Recenntly i compiled a 2.4.15(greased turkey) kernel for using my USB DSL modem.I am facing a problem with this new kernel.
NO modules are loading.(I compiled and installed all USb and net modules).if I tried to load a module using insmod usb-ohci.o it says unresolved symbol ***.other modules can be loaded using insmod(I checked a few only).

In my var/log/messages
NO modules symbols loaded
can not find map file

--This messages are there.
In my new kernel modules are located in /lib/modules/2.4.15 greased turkey/kernel/drivers.

In my old SUSE kernel they are in /lib/modules/2.2.16.

I changed my modules.conf like this
1. path[***]=/lib/modules/2.2.16.(it is already there for my old kernel)
2.path[new]=/lib/modules/2.4.15 greased-turkey[this line i added]
is it necessary to give the full path (/lib/modules/2.4.15 greased turkey/kernel/drivers. )
where i went wrong?.Please help me.I am new to this area.
Old 11-22-2003, 06:31 AM   #2
Registered: Apr 2003
Location: Madrid
Distribution: RHAS, Kubuntu, Solaris, TRU64
Posts: 381

Rep: Reputation: 31
You can't use modules compiled under a different kernel version.
Seems like you are trying to load 2.2 modules under 2.4 kernel.

It's like trying to use W95 drivers under W2K.

You can have an explanation on:


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Loading Kernel Modules superdude_876 Linux - Software 1 10-28-2005 11:46 PM
Loading sound modules into Kernel rgbrock1 Linux - Hardware 1 05-09-2005 01:48 PM
Loading modules error after loading compiled kernel td0l2 Linux - Newbie 12 07-28-2004 11:10 AM
Loading Correct Kernel Modules rridler Linux - Newbie 4 04-15-2004 04:37 PM
Problems with loading modules in new kernel beejayzed Linux - Newbie 5 02-07-2004 03:29 PM

All times are GMT -5. The time now is 11:45 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration