LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 12-16-2006, 09:17 AM   #1
android6011
Member
 
Registered: May 2005
Posts: 255

Rep: Reputation: 30
module-assistant cant build fglrx


I am running debian etch and when I do "m-a a-i fglrx" I get

dh_testdir  ▒
│ /usr/bin/make -C /lib/modules/2.6.19.1/source  ▒
│ SUBDIRS=/usr/src/modules/fglrx modules  ▒
│ make[1]: Entering directory `/usr/src/linux-2.6.19.1'  ▮
│ CC [M] /usr/src/modules/fglrx/firegl_public.o  ▒
│ /usr/src/modules/fglrx/firegl_public.c:89:26: error: linux/config.h: No  ▒
│ such file or directory  ▒
│ /usr/src/modules/fglrx/firegl_public.c:456: warning: initialization from  ▒
│ incompatible pointer type  ▒
│ /usr/src/modules/fglrx/firegl_public.c: In function  ‘firegl_stub_openn’:  ▒
│ /usr/src/modules/fglrx/firegl_public.c:579: warning: assignment discards  ▒
│ qualifiers from pointer target type
 
Old 12-16-2006, 10:26 AM   #2
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
Are you running this from single-user mode? What kernel? The drivers from ATI, or the ones from Debian?
 
Old 12-16-2006, 03:35 PM   #3
android6011
Member
 
Registered: May 2005
Posts: 255

Original Poster
Rep: Reputation: 30
no, not single user, should I? kernel 2.6.19.1 , driver from ati 32.5 for x86_64
 
Old 12-16-2006, 03:41 PM   #4
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
Quote:
no, not single user, should I?
Yes. m-a is probably conflicting with a currently active video module. Reboot to single-user, then:

# m-a a-i -f fglrx
# modprobe -v fglrx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue with module assistant on debian mazza Linux - Newbie 1 11-05-2010 07:35 PM
module-assistant problem Slade901 Linux - Software 1 08-24-2006 11:15 AM
Installing Module-Assistant Sleepy_Sentry Ubuntu 4 01-18-2006 08:19 PM
module-assistant auto-install ov511 ... make: *** [build-stamp] Error 2 brynjarh Linux - Hardware 1 11-13-2005 02:31 PM
Problem with module-assistant fakesource WoofDeF Debian 1 06-29-2005 08:37 PM


All times are GMT -5. The time now is 04:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration