LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-13-2005, 02:13 PM   #1
meres
LQ Newbie
 
Registered: Oct 2005
Distribution: Debian Sarge, SUSE10.0
Posts: 12

Rep: Reputation: 0
missing /dev/rtc


running debian Sarge on a dual opteron246 system with 2GB system mem, dual SATA drives, etc, etc.

i have notices that the CMOS clock reading and the system clock reading are different. not different in the terms of utc vs est, which i believe would be 5 hours???, but sometimes 12 hours off and a day behind, sometimes by an odd amount.

i then noticed that i received the following on start up:
Code:
Setting the System Clock using the Hardware Clock as reference...
Cannot access the Hardware Clock via any known method.
Use the --debug option to see the details of our search for an access method.
System Clock Set. Local Time: Mon Oct 10 16:48:35 EDT 2005
The actual time at that instance was Tue Oct 11 9:48:35 EDT 2005

I tried hwclock --debug and received:

Code:
hwclock from util-linux-2.12p 
hwclock: Open of /dev/rtc failed, errno=2: No such file or directory. 
No useable clock interface found. 
Cannot access the Hardware Clock via any known method.
I was able to get hwclock temporarily by using mknod /dev/rtc c 10 135
but this doesn't persist through start up.

Right now i have installed and run adjtimex which seems to have straightened things out...i still can't get a positive result back from hwclock though.

Any ideas why i don't have a /dev/rtc?
thanks
 
Old 10-13-2005, 08:15 PM   #2
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
Do you have CONFIG_RTC set in the kernel (and rtc module loaded if necessary)? I just looked at a udev setup and /dev/rtc is supposed to be created by this module.
 
Old 10-14-2005, 08:18 AM   #3
meres
LQ Newbie
 
Registered: Oct 2005
Distribution: Debian Sarge, SUSE10.0
Posts: 12

Original Poster
Rep: Reputation: 0
Tanks for the reply. I'm new to linux so could you explain how to check if CONFIG_RTC is set in the kernel. I did check to see if udev was installed...it is, but I think I recall someone stating that the latest udev caused some problems. I don't know if i have the lastest version...the one i have installed is 0.056-3.

Here a portion of the results from kern.log from yesterday.

If you notice at the beginning it appears that no module sysmbols were loaded...is this right?
Also, why is it ignoring one of my processors?
Closer to the end there is something the APIC and about ungzip failed....don't know what that means....

Thanks again.

Code:
Oct 13 01:03:02 localhost kernel: klogd 1.4.1#17, log source = /proc/kmsg started.
Oct 13 01:03:02 localhost kernel: Inspecting /boot/System.map-2.6.8-11-amd64-k8
Oct 13 01:03:02 localhost kernel: Loaded 27210 symbols from /boot/System.map-2.6.8-11-amd64-k8.
Oct 13 01:03:02 localhost kernel: Symbols match kernel version 2.6.8.
Oct 13 01:03:02 localhost kernel: No module symbols loaded - kernel modules not enabled. 
Oct 13 01:03:02 localhost kernel: 76 pages, LIFO batch:16
Oct 13 01:03:02 localhost kernel:   HighMem zone: 0 pages, LIFO batch:1
Oct 13 01:03:02 localhost kernel: ACPI: RSDP (v000 ACPIAM                                    ) @ 0x00000000000f6d20
Oct 13 01:03:02 localhost kernel: ACPI: RSDT (v001 A M I  OEMRSDT  0x06000513 MSFT 0x00000097) @ 0x000000007fff0000
Oct 13 01:03:02 localhost kernel: ACPI: FADT (v001 A M I  OEMFACP  0x06000513 MSFT 0x00000097) @ 0x000000007fff0200
Oct 13 01:03:02 localhost kernel: ACPI: MADT (v001 A M I  OEMAPIC  0x06000513 MSFT 0x00000097) @ 0x000000007fff0380
Oct 13 01:03:02 localhost kernel: ACPI: OEMB (v001 A M I  OEMBIOS  0x06000513 MSFT 0x00000097) @ 0x000000007ffff040
Oct 13 01:03:02 localhost kernel: ACPI: SRAT (v001 A M I  OEMSRAT  0x06000513 MSFT 0x00000097) @ 0x000000007fff3b10
Oct 13 01:03:02 localhost kernel: ACPI: ASF! (v001 AMIASF AMDSTRET 0x00000001 INTL 0x02002026) @ 0x000000007fff3c20
Oct 13 01:03:02 localhost kernel: ACPI: DSDT (v001  0AAAA 0AAAA000 0x00000000 INTL 0x02002026) @ 0x0000000000000000
Oct 13 01:03:02 localhost kernel: ACPI: Local APIC address 0xfee00000
Oct 13 01:03:02 localhost kernel: ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
Oct 13 01:03:02 localhost kernel: Processor #0 15:5 APIC version 16
Oct 13 01:03:02 localhost kernel: ACPI: LAPIC (acpi_id[0x02] lapic_id[0x01] enabled)
Oct 13 01:03:02 localhost kernel: Processor #1 15:5 APIC version 16
Oct 13 01:03:02 localhost kernel: WARNING: NR_CPUS limit of 1 reached. Processor ignored.
Oct 13 01:03:02 localhost kernel: ACPI: LAPIC (acpi_id[0x03] lapic_id[0x82] disabled)
Oct 13 01:03:02 localhost kernel: ACPI: LAPIC (acpi_id[0x04] lapic_id[0x83] disabled)
Oct 13 01:03:02 localhost kernel: ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
Oct 13 01:03:02 localhost kernel: IOAPIC[0]: Assigned apic_id 2
Oct 13 01:03:02 localhost kernel: IOAPIC[0]: apic_id 2, version 17, address 0xfec00000, GSI 0-23
Oct 13 01:03:02 localhost kernel: ACPI: IOAPIC (id[0x03] address[0xfebff000] gsi_base[24])
Oct 13 01:03:02 localhost kernel: IOAPIC[1]: Assigned apic_id 3
Oct 13 01:03:02 localhost kernel: IOAPIC[1]: apic_id 3, version 17, address 0xfebff000, GSI 24-27
Oct 13 01:03:02 localhost kernel: ACPI: IOAPIC (id[0x04] address[0xfebfe000] gsi_base[28])
Oct 13 01:03:02 localhost kernel: IOAPIC[2]: Assigned apic_id 4
Oct 13 01:03:02 localhost kernel: IOAPIC[2]: apic_id 4, version 17, address 0xfebfe000, GSI 28-31
Oct 13 01:03:02 localhost kernel: ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
Oct 13 01:03:02 localhost kernel: ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
Oct 13 01:03:02 localhost kernel: ACPI: IRQ0 used by override.
Oct 13 01:03:02 localhost kernel: ACPI: IRQ2 used by override.
Oct 13 01:03:02 localhost kernel: ACPI: IRQ9 used by override.
Oct 13 01:03:02 localhost kernel: Using ACPI (MADT) for SMP configuration information
Oct 13 01:03:02 localhost kernel: Checking aperture...
Oct 13 01:03:02 localhost kernel: CPU 0: aperture @ f37c000000 size 32 MB
Oct 13 01:03:02 localhost kernel: Aperture from northbridge cpu 0 too small (32 MB)
Oct 13 01:03:02 localhost kernel: No AGP bridge found
Oct 13 01:03:02 localhost kernel: Built 1 zonelists
Oct 13 01:03:02 localhost kernel: Kernel command line: root=/dev/sda1 ro console=tty0 
Oct 13 01:03:02 localhost kernel: Initializing CPU#0
Oct 13 01:03:02 localhost kernel: PID hash table entries: 16 (order 4: 256 bytes)
Oct 13 01:03:02 localhost kernel: time.c: Using 1.193182 MHz PIT timer.
Oct 13 01:03:02 localhost kernel: time.c: Detected 1992.045 MHz processor.
Oct 13 01:03:02 localhost kernel: Console: colour VGA+ 80x25
Oct 13 01:03:02 localhost kernel: Dentry cache hash table entries: 524288 (order: 10, 4194304 bytes)
Oct 13 01:03:02 localhost kernel: Inode-cache hash table entries: 262144 (order: 9, 2097152 bytes)
Oct 13 01:03:02 localhost kernel: Memory: 2054252k/2097088k available (1586k kernel code, 42092k reserved, 901k data, 124k init)
Oct 13 01:03:02 localhost kernel: Calibrating delay loop... 3915.77 BogoMIPS
Oct 13 01:03:02 localhost kernel: Security Scaffold v1.0.0 initialized
Oct 13 01:03:02 localhost kernel: Capability LSM initialized
Oct 13 01:03:02 localhost kernel: Mount-cache hash table entries: 256 (order: 0, 4096 bytes)
Oct 13 01:03:02 localhost kernel: CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
Oct 13 01:03:02 localhost kernel: CPU: L2 Cache: 1024K (64 bytes/line)
Oct 13 01:03:02 localhost kernel: CPU: AMD Opteron(tm) Processor 246 stepping 0a
Oct 13 01:03:02 localhost kernel: Using local APIC NMI watchdog using perfctr0
Oct 13 01:03:02 localhost kernel: ENABLING IO-APIC IRQs
Oct 13 01:03:02 localhost kernel: init IO_APIC IRQs
Oct 13 01:03:02 localhost kernel:  IO-APIC (apicid-pin) 2-0, 2-16, 2-17, 2-18, 2-19, 2-20, 2-21, 2-22, 2-23, 3-0, 3-1, 3-2, 3-3, 4-0, 4-1, 4-2, 4-3 not connected.
Oct 13 01:03:02 localhost kernel: ..TIMER: vector=0x31 pin1=2 pin2=-1
Oct 13 01:03:02 localhost kernel: Using local APIC timer interrupts.
Oct 13 01:03:02 localhost kernel: Detected 12.450 MHz APIC timer.
Oct 13 01:03:02 localhost kernel: checking if image is initramfs...it isn't (ungzip failed); looks like an initrd
Oct 13 01:03:02 localhost kernel: NET: Registered protocol family 16
Oct 13 01:03:02 localhost kernel: PCI: Using configuration type 1
Oct 13 01:03:02 localhost kernel: mtrr: v2.0 (20020519)
Oct 13 01:03:02 localhost kernel: ACPI: Subsystem revision 20040326
Oct 13 01:03:02 localhost kernel: ACPI: Interpreter enabled
Oct 13 01:03:02 localhost kernel: ACPI: Using IOAPIC for interrupt routing
Oct 13 01:03:02 localhost kernel: ACPI: PCI Root Bridge [PCI0] (00:00)
Oct 13 01:03:02 localhost kernel: PCI: Probing PCI hardware (bus 00)
 
Old 10-14-2005, 10:02 AM   #4
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
I'm not an expert at interpreting kernel logs, but to use mulitiple processors you also need to enable SMP in the kernel. If you have the kernel source the file .config in the top directory has all the settings. Alternatively if you are lucky the kernel has stashed a compressed copy at /proc/config.gz, so

gzip -cd /proc/config.gz | grep RTC

should give you the RTC status. You could also try 'lsmod' and see if rtc module is listed. This will also tell you what other kernel modules are loaded. There are a number of ways modules get loaded. I don't know the full picture myself. You can always load manually with e.g. 'modprobe rtc' (as root). This might give you a /dev/rtc also if you don't have one.

There should be a line in /etc/udev/rules.d/udev.rules referring to rtc.
 
Old 10-14-2005, 11:12 AM   #5
meres
LQ Newbie
 
Registered: Oct 2005
Distribution: Debian Sarge, SUSE10.0
Posts: 12

Original Poster
Rep: Reputation: 0
These are the results of what I tried.
I installed using binary cds. I couldn't find .config
I tried lsmod and didn't see anything resembling rtc.
I looked at /etc/udev/rules.d/udev.rules and didn't see anything referring to rtc.
What should be my next step? Should i try to get the soure for the kernel and reconfigure it?
Not sure if I'm ready for that.

Code:
fserver:~# gzip -cd /proc/config.gz | grep RTC
# CONFIG_HPET_EMULATE_RTC is not set
CONFIG_RTC=m
CONFIG_GEN_RTC=m
CONFIG_GEN_RTC_X=y
# CONFIG_HPET_RTC_IRQ is not set
CONFIG_SENSORS_RTC8564=m
CONFIG_SND_RTCTIMER=m
Code:
fserver:~# gzip -cd /proc/config.gz | grep SMP
CONFIG_BROKEN_ON_SMP=y
# CONFIG_SMP is not set
fserver:~#
Code:
fserver:~# modprobe rtc
FATAL: Error inserting rtc (/lib/modules/2.6.8-11-amd64-k8/kernel/drivers/char/rtc.ko): No such device
fserver:~#
 
Old 10-14-2005, 10:07 PM   #6
FinalFantasy
Member
 
Registered: Sep 2003
Location: UK
Distribution: CLFS-32bit-x86 / LFS-SVN-20060210
Posts: 49

Rep: Reputation: Disabled
CONFIG_HPET_EMULATE_RTC=y
CONFIG_RTC=y
CONFIG_SND_RTCTIMER=y

that's what i have for my kernel.
The /dev/rtc node is always there.
 
Old 10-15-2005, 02:25 AM   #7
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
Your kernel does not exactly match your module installation for some reason. I think Debian provides various packages with a range of ready-compiled kernels. You could try installing one with SMP enabled - it might fix your RTC problem also. Or there are several guides to compiling a new kernel in a Debian framework - e.g.

http://www.debian.org/doc/manuals/re...kernel.en.html

http://myrddin.org/howto/debian-kernel-recompile.php

Here is the line from udev.rules that is supposed to create the rtc device

KERNEL="rtc", NAME="misc/%k", SYMLINK="%k", MODE="0664"

This is from a non-Debian system. I'm not sure how udev is set up on Debian. I still have old-style.

EDIT: Looking at your modprobe error message again - I think this is a udev problem. See

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=308693

Last edited by maroonbaboon; 10-15-2005 at 12:02 PM.
 
Old 10-17-2005, 02:37 PM   #8
meres
LQ Newbie
 
Registered: Oct 2005
Distribution: Debian Sarge, SUSE10.0
Posts: 12

Original Poster
Rep: Reputation: 0
Thnks for all the help. I'll see what i can do from here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Not unknown problem with /dev/rtc carbono Linux - Newbie 1 10-13-2005 09:04 AM
/dev/rtc problem with gmplayer on Slackware 10 alagenchev Linux - Software 29 07-18-2005 02:31 PM
mplayer: failed to open /dev/rtc no such device darkleaf Linux - Software 2 02-18-2005 06:07 PM
Share interrupts with /dev/rtc (IRQ 8) godOfThunder Linux - Software 1 08-03-2004 01:36 AM
/dev/rtc not currently available in VMWARE, Mandrake 9.2 Guitarist88 Linux - Software 1 04-11-2004 02:54 PM


All times are GMT -5. The time now is 09:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration