LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   misaligned manual pages (http://www.linuxquestions.org/questions/linux-general-1/misaligned-manual-pages-511979/)

rsashok 12-19-2006 12:28 PM

misaligned manual pages
 
when I type 'man any_topic> I get misaligned pages, plus some escape chars, such as 7m<80><99>word<7m<80><90>, are not interpreted by the terminal. I run RedHat(enterprise edition 4) with KDE's Konsole. The /etc/man.config file looks good to me (but what do I know?!), and I tried different setting for KDE Konsole to no avail. Plus every line in man displayed with a number, which is not normal plain 'man'. I guess there is some setting somewhere which twists the output. I'd be very thankful to anybody who has ideas.

b0uncer 12-20-2006 08:52 AM

What locales are you using? They might do odd stuff for your console..and which shell are you running, bash or sh or ksh or what?

rsashok 12-20-2006 10:31 AM

I am using BASH, and output of the 'locale' is:

LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

bigrigdriver 12-20-2006 11:00 PM

Quote:

7m<80><99>word<7m<80><90>,
This is the kind of output you would get if you used man with the -t option (or if a setting somewhere in the MAN environment variables is to use that option).

Try 'man -D <some man page>' to see what you get.

rsashok 12-21-2006 01:02 PM

I figured out my problem. The pager used for 'man' is 'less'. I looked at my environment variables and discovered that I have settings for LESSCHARSET='latin1', LESS='-i -N -w -z-4 -g -e -M -X -F -R' coming from my .bashrc file, which I acquired from the WEB while ago without really looking, tweaking and understanding portions which I don't use.

I commented out LESSCHARSET, and LESS and it solved the problem. Little things create huge problems!
(some say if Napoleon didn't have a cold he might have won Waterloo)

Thanks for the tips. Looking at the output of 'man -d some_command' gave me the idea.


All times are GMT -5. The time now is 05:19 PM.