LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-19-2010, 09:33 AM   #1
joe.attaboy
LQ Newbie
 
Registered: Jun 2009
Posts: 4

Rep: Reputation: 0
Mint 8: regular user can't access ext3 partition on mounted microSD card


This is a problem that has me somewhat baffled, and I haven't received any help on the Mint or Ubuntu forums, so here we go:

I have an HP laptop with a recently installed copy of Mint 8 KDE Community Edition. I created the initial admin user account ("joseph") when I installed.

I had an existing home directory under a different name from another installation, so I added a user with that name ("joe") and imported a copy of the original home directory. The user "joe" didn't have the same admin privileges as the initial "joseph" account, so I added "joe" to the sudoers file and the same groups as the initial admin user.

Everything works perfectly under this arrangement, for the most part. Now here's the problem:

I have a T-Mobile G1 phone that uses Android. I've rooted and ROM-modded the G1, and have the microSD card in the phone set up with two partitions. The vfat partition stores all the photos, music and other stuff the phone needs. The ROM mod allows me to store apps on the SD card, so that second partition uses ext3 for its file system.

When I'm logged in as the admin "joseph" account and I insert the SD card in the laptop's card slot (or plug the phone into the USB port), the SD card can be mounted, and I have full access to both card partitions. I can see all folders. I do this to backup the contents of the card to an external drive (especially the apps in the ext3 partition, since that's been trashed on me once before on the phone).

However, when I log in as "joe", I cannot view the contents of the ext3 partition at all. I can see the vfat drive fine, and the ext3 partition mounts, but with user/group "joseph/joseph." When I open Dolphin to view the mounted ext3 partition, I get the error "could not enter folder /media/disk-1" at the bottom of the view window in Dolphin.

Here are the relative entries returned when I run "mount" to view the mounted drives:

/dev/mmcblk0p1 on /media/disk type vfat (rw,nosuid,nodev,uhelper=hal,uid=1001,utf8,shortname=mixed,flush)
/dev/mmcblk0p2 on /media/disk-1 type ext3 (rw,nosuid,nodev,uhelper=hal)

Note that the uid listed on the vfat mount is 1001, which is the gid for the "joe" account.

I know there must be a configuration setting somewhere that will allow the ext3 partition to automount under the "joe" user account. I suppose that using the admin account to change the permissions would be the easy way to do this, but there must be something that would do it automagically. I've ripped through all the config files I can find, but can't seem to find anything that would help.

All I'm looking for here is enough access to be able to copy the directories on that mount to my external drive.

If anyone has any clue about this, I'd greatly appreciate any assistance.
 
Old 02-19-2010, 01:30 PM   #2
jiobo
Member
 
Registered: Nov 2008
Posts: 180

Rep: Reputation: 36
Many of the automatic mounts are described in the file /etc/fstab. Read the man pages for mount under the ext3 file type for options to use.

Code:
man mount
 
Old 02-19-2010, 01:51 PM   #3
frisil
LQ Newbie
 
Registered: Feb 2010
Location: behind you ;-)
Distribution: SimplyMepis
Posts: 17

Rep: Reputation: 1
Add 'users' to the mount options for your partition and try to mount it as joe.
If that doesn't help, check the groups for each user, maybe one user is in a group that has access to the device and the other is not.
 
Old 02-19-2010, 03:31 PM   #4
jiobo
Member
 
Registered: Nov 2008
Posts: 180

Rep: Reputation: 36
http://www.linuxmint.com/wiki/index.php/Main_Page
 
Old 02-20-2010, 08:58 AM   #5
joe.attaboy
LQ Newbie
 
Registered: Jun 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jiobo View Post
Many of the automatic mounts are described in the file /etc/fstab. Read the man pages for mount under the ext3 file type for options to use.

Code:
man mount
jiobo:

fstab was the first place I looked. Only the hard disk partitions and the CD drive are listed there.
 
Old 02-20-2010, 09:32 AM   #6
joe.attaboy
LQ Newbie
 
Registered: Jun 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by frisil View Post
Add 'users' to the mount options for your partition and try to mount it as joe.
If that doesn't help, check the groups for each user, maybe one user is in a group that has access to the device and the other is not.
Tried that early on as well. Actually, neither user was in the "users" groups, but adding the "joe" account into it didn't help. Thanks.
 
Old 01-23-2011, 07:11 PM   #7
jamessp007
Member
 
Registered: Aug 2002
Location: Highland, UT
Distribution: Linux Mint 9
Posts: 44

Rep: Reputation: 15
man mount

What a waste of time. Man pages are the biggest waste of time to noobies . They are full of jargon and semi-descriptive steps to do something so a newbie gets an answer that might as well be greek . A link to YouTube would be much better.
 
Old 01-23-2011, 11:37 PM   #8
joe.attaboy
LQ Newbie
 
Registered: Jun 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jamessp007 View Post
What a waste of time. Man pages are the biggest waste of time to noobies . They are full of jargon and semi-descriptive steps to do something so a newbie gets an answer that might as well be greek . A link to YouTube would be much better.
Well, if you're talking about me (the original poster), you're assuming I'm a "noobie."

Just so you know, I've been using Linux since Linus first put his original source on funet in 1991.

This problem was also solved a long time ago.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
EXT3-fs error partition mounted read only karthi26 Linux - Hardware 6 08-03-2009 07:26 AM
Help Me!! I can't write to a mounted (ext3) partition - permission denied!! goja Linux - Newbie 4 12-28-2007 04:54 AM
Question about mounted ext3 usb partition in FC4 2.6 linux_marine Fedora 2 09-19-2006 12:53 PM
ext3 partition on external USB hard drive mounted, but only root access allowed leontini Linux - Hardware 4 02-17-2006 01:54 AM
Can't access NTFS partition as regular user Spasmolytic Linux - Newbie 3 05-13-2004 05:46 PM


All times are GMT -5. The time now is 03:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration