Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 06-11-2008, 10:03 PM   #1
CJ Chitwood
Registered: Dec 2006
Location: Jacksonville, FL
Distribution: Mint. Regrettably.
Posts: 127

Rep: Reputation: 16
Middle mouse button doesn't paste

Hello all

I've searched for a brief time -- regrettably time is in short supply for me lately -- and I'm as yet unable to find a solution to my dilemma.

I recently was tinkering with AMD64 Debian on a spare system, and when my AMD AthlonXP (i586) system bit the dust, the AMD64 system became my only decent workable machine.

However, since first install on that machine, middle mouse button does absolutely nothing. This is extremely irritating, when I have grown so dependent on that middle-button paste feature.

I have found numerous threads on "how do I disable" the feature, most of them pointing to xmodmap or "ButtonMapping" on the xorg.conf, but if I understand correctly xmodmap is something of a TSR where the default middle-button-paste feature is built in to X11, and the ButtonMapping trick did nothing for me.

My current xorg.conf is at the end of the post.

I love Linux and can't stand using Windows, but odd inconsistencies between versions of Linux -- even between platforms of the same distro -- is one of the things that I don't miss when I'm using other systems.

The main reason I need this now is that I prefer using a specific terminal (ETerm) because of its default settings being so close to what I need. However, it has no copy-paste option. I need this, though, because when my Evolution crashes -- AGAIN -- with that same error about gdk-painter line 111 and assertions failing -- AGAIN -- well, it's much easier to copy and paste by highlighting the error and middle-clicking in Google search...

I may just have to move to another terminal proggy for now. In the meantime, if anyone can solve this, I would be VERY much obliged.

Many thanks in advance,

CJ Chitwood

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

Section "Module"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"    
# When DRI is loaded, "(EE) AIGLX: Screen 0 is not DRI capable" occurs in 
# the X log file.  However, with it disabled, certain fullscreen applications
# that use GL are killed to about 1 frame per 1.5 seconds.  The only speedup
# has been to reenable DRI, which brings them back to a fast enough framerate
# that you can't see the pauses inbetween.  Disable "flipping" in the 
# nVidia control application to remove flicker.
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"vbe"

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
#  The following two lines not originally in the file.  Adding them, 
#  uncommented of course, did nothing;  so I've commented them back out.

#	Option		"ZAxisMapping"		"4 5"
#	Option		"ButtonMapping"		"1 2 3 4 5"

Section "Device"
	Identifier	"nVidia Corporation NV4 [RIVA TNT]"
#	Driver		"nv"		# OSS
	Driver		"nvidia"	# proprietary
#	BusID		"PCI:2:10:0"
	BusID		"PCI:1:0:0"

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	HorizSync	28-60
	VertRefresh	43-60

Section "Screen"
	Identifier	"Default Screen"
	Device		"nVidia Corporation NV4 [RIVA TNT]"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1200x800" "1152x864" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		4
		Modes		"1200x800" "1152x864" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		8
		Modes		"1200x800" "1152x864" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		15
		Modes		"1200x800" "1152x864" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		16
		Modes		"1200x800" "1152x864" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		24
		Modes		"1200x800" "1152x864" "1024x768" "800x600" "640x480"

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"

Section "DRI"
	Mode	0666
Old 06-12-2008, 12:57 AM   #2
LQ Newbie
Registered: Jun 2008
Distribution: RHEL, Fedora, Gentoo, Slackware
Posts: 27

Rep: Reputation: 15
If you change:
Option "Emulate3Buttons" "true"

Option "Emulate3Buttons" "false"

and restart X, does it make a difference?
Old 06-12-2008, 07:44 PM   #3
CJ Chitwood
Registered: Dec 2006
Location: Jacksonville, FL
Distribution: Mint. Regrettably.
Posts: 127

Original Poster
Rep: Reputation: 16
No, no difference.

Anything else? Thanks...

Old 06-12-2008, 11:32 PM   #4
CJ Chitwood
Registered: Dec 2006
Location: Jacksonville, FL
Distribution: Mint. Regrettably.
Posts: 127

Original Poster
Rep: Reputation: 16
Ladies and gentlemen, I'm an idiot.

The button is intermittent electronically.

It just hit me... I was having trouble with it in GIMP using it to move the view of the picture I was editing around...

It works fine if I press into just right... just like in GIMP.

My apologies for what could be considered a not-very-useful thread....

Cheers, and thanks anyway!



buffer, button, cut, paste, terminal

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable copy-paste on middle mouse button 311Sam Ubuntu 6 10-09-2006 09:40 PM
how should i enable the middle button of 3-button mouse ?? b0nd Slackware 1 07-17-2006 03:46 AM
disable middle button paste feature in linux linuxmandrake Linux - Software 1 03-16-2006 12:59 PM
thinkpad T42 middle button - paste functionality primorec Linux - Laptop and Netbook 0 12-19-2005 03:43 AM
middle mouse button is paste.. but what if i dont have a mid mouse button? kublador Linux - Newbie 4 09-02-2003 09:59 AM

All times are GMT -5. The time now is 09:29 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration