LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 12-04-2005, 06:04 AM   #1
0mn1z10n
LQ Newbie
 
Registered: Jun 2005
Distribution: PCLOS, DSL, Kubuntu, Debian
Posts: 15

Rep: Reputation: 0
Messed up an attempt at dual boot install- GRUB on one, LILO on the other


I resized my partition and installed a secondary distribution on the free space which went fine, trouble is, I was using LILO with the first distro, and the second distro installed GRUB..I can't boot into my primary distribution anymore. Is there a way I can fix it?

Primary Distribution is PCLinuxOS on /dev/hda1, and was LILO
The other one is FC4 on /dev/hda3, is GRUB

Last edited by 0mn1z10n; 12-04-2005 at 06:19 AM.
 
Old 12-04-2005, 06:27 AM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
You need to create an entry in your /boot/grub.conf for PCLinuxOS. Mount /dev/hda1 somewhere on your system, navigate to its /boot directory and check the lilo settings for PCLinuxOS. Use those settings as a guide for creating your PCLinuxOS grub entry. If you need more help, post back.
 
Old 12-04-2005, 09:32 AM   #3
0mn1z10n
LQ Newbie
 
Registered: Jun 2005
Distribution: PCLOS, DSL, Kubuntu, Debian
Posts: 15

Original Poster
Rep: Reputation: 0
Hi redazz, thanks for the reply.
Yeah I probably need a little more guidance as to how to use the lilo settings as a guide. Is there an explanation somewheres you know about that could give me a bit of a walkthrough as to what the syntax of the settings I need to put into the grub.conf file should be, or can you tell me what I need? My pclinux lilo.conf looks like this
Code:
boot=/dev/hda
map=/boot/map
default="pclinuxos"
keytable=/boot/livecd.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz-2.6.12-oci6.mdk-i586-up-1GB
        label="pclinuxos"
        root=/dev/hda1
        initrd=/boot/initrd-2.6.12-oci6.mdk-i586-up-1GB.img
append="noapic nolapic acpi=ht nomce psmouse.proto=imps splash=silent"
vga=788
read-only
and my grub.conf looks like this
Code:
default=2
timeout=5
splashimage=(hd0,2)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.14-1.1644_FC4)
        root (hd0,2)
        kernel /vmlinuz-2.6.14-1.1644_FC4 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.14-1.1644_FC4.img
title Fedora Core (2.6.11-1.1369_FC4)
        root (hd0,2)
        kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.11-1.1369_FC4.img
title PCLinuxOS
        rootnoverify (hd0,0)
        chainloader +1
 
Old 12-04-2005, 10:31 AM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
You could also do something similar to the code below
Code:
title PCLinuxOS
    root (hd0,1)
    kernel /boot/vmlinuz/vmlinuz-2.6.12-oci6.mdk-i586-up-1GB root=/dev/hda1 vga=788 noapic
    initrd /boot/initrd/initrd-2.6.12-oci6.mdk-i586-up-1GB.img
 
Old 12-04-2005, 11:57 AM   #5
0mn1z10n
LQ Newbie
 
Registered: Jun 2005
Distribution: PCLOS, DSL, Kubuntu, Debian
Posts: 15

Original Poster
Rep: Reputation: 0
Cool, thanks but it's still giving me some error at boottime.. it shows
Code:
boot (hd0,1)
Filesystem type unknown, partition type 0x5
Do you think it's because my filesytem for that partition is reiserfs?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching from grub to lilo, messed up Lilo.conf, rescuing via Knoppix. SonicGT Debian 2 08-21-2005 01:15 PM
Lilo lost, Install disk failing to restore Lilo on dual boot? Dobie Linux - Newbie 2 05-05-2004 05:00 PM
Getting Grub to dual boot with Morphix running Lilo Momboking Linux - Newbie 3 03-08-2004 09:17 PM
Dual boot with Lilo not working after install Gates1026 Linux - General 3 02-17-2004 02:36 PM
First attempt at RH7 dual boot install not going well Cheetahsloth Linux - Software 10 05-08-2001 01:31 AM


All times are GMT -5. The time now is 12:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration