LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-26-2013, 09:11 AM   #1
kishor joshi
Member
 
Registered: Jan 2013
Location: Pune,India
Distribution: Linux Mint16 Cinnamon, 64-bit,Linux Mint 17
Posts: 49
Blog Entries: 1

Rep: Reputation: Disabled
Question Message about disk drive not ready while booting


OS. Linux Mint 14 Nadia.
while booting I get following msg
The disk drive for /media/Windows is not ready yet or not present
-Continue to wait,or press S to skip mounting or M for manual recovery.
I stared getting this message after I installed Oracle Virtual Box.
I had installed Ubuntu 12.04,Lubuntu 12.04,kbuntu 12.04 and windows XP on Virtual Box.
The problem started ( probably) when I had deleted Windos- XP folder from
/Home/Virtual Box VMS folder,insted of removing host Windos- XP from Oracle VM Virtual Box Manager.I had again installed Win XP.Virtual Box is runnig fine.
The folder /media contains a folder named Windows and geeta (user/administrator).
How to rectify this ?
With new installatin /media contains which subfolers?
 
Old 02-26-2013, 12:29 PM   #2
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,568

Rep: Reputation: 411Reputation: 411Reputation: 411Reputation: 411Reputation: 411
Can you check your /etc/fstab and just remove the mount line for it? You should always remove it from within VirtualBox because of these other config files that get changed.
 
1 members found this post helpful.
Old 02-26-2013, 10:39 PM   #3
kishor joshi
Member
 
Registered: Jan 2013
Location: Pune,India
Distribution: Linux Mint16 Cinnamon, 64-bit,Linux Mint 17
Posts: 49
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Thanks a lot.
However there is no file in /etc/fstab.
Now the qustion is how to restore this file and edit it?
I had visited linux forum for how to restore fstab.
and tried to run $ cat /etc/fstab interminal which has given following result in Terminal
===============================================================
geeta@geeta-MS-7576 ~ $ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda4 during installation
UUID=4fadeae6-5cf9-40e5-83a8-7b461eafd176 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda3 during installation
UUID=0bc7876f-e55b-4ebd-884f-db5dccba510f none swap sw 0 0
/dev/disk/by-id/usb-hp_v165w_AA00000000005141-0:0-part2 /mnt/usb-hp_v165w_AA00000000005141-0:0-part2 auto nosuid,nodev,nofail,noauto,x-gvfs-show 0 0
UUID=f7927995-b098-42be-ada0-987857f5177a /media/Windows ext4 defaults,noatime 0 2
geeta@geeta-MS-7576 ~ $ cat /etc/fstab.bak
cat: /etc/fstab.bak: No such file or directory
geeta@geeta-MS-7576 ~ $
===================================================================
I am contining my homework (effots)for this.
Thanks once again.
Regards
Kishor
 
Old 02-26-2013, 11:15 PM   #4
kishor joshi
Member
 
Registered: Jan 2013
Location: Pune,India
Distribution: Linux Mint16 Cinnamon, 64-bit,Linux Mint 17
Posts: 49
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Thumbs up editing fstab file

Further to my earlier reply.
I could open (probably) the file in gedit.
I tried $ sudo gedit /etc/fstab
in Terminal.
geeta@geeta-MS-7576 ~ $ sudo gedit /etc/fstab
[sudo] password for geeta:

After that gedit was opened automatically.
Gedit shows following result
=================================================================
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda4 during installation
UUID=4fadeae6-5cf9-40e5-83a8-7b461eafd176 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda3 during installation
UUID=0bc7876f-e55b-4ebd-884f-db5dccba510f none swap sw 0 0
/dev/disk/by-id/usb-hp_v165w_AA00000000005141-0:0-part2 /mnt/usb-hp_v165w_AA00000000005141-0:0-part2 auto nosuid,nodev,nofail,noauto,x-gvfs-show 0 0
UUID=f7927995-b098-42be-ada0-987857f5177a /media/Windows ext4 defaults,noatime 0 2Gedit ======================================================================
Please confirm whether this is fstb file,if yes please help me to edit this file.
I had forget to mention that there are two OS 1)linux Mint 14 Nadia and 2)Win- XP
Since Virtual Box is installed on linus and WIN-XP as guest ,I always boot linux which is a first choice.
Regards
Kishor
=======================================
after $ sudo gedit /etc/fstab
in Terminal, gedit was automatically opened
last two lines were deletedand problem is solved.

Last edited by kishor joshi; 02-27-2013 at 04:55 AM. Reason: the problem is solved ,after editing fstab file
 
Old 02-27-2013, 12:39 PM   #5
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,568

Rep: Reputation: 411Reputation: 411Reputation: 411Reputation: 411Reputation: 411
Just put a # in front of this line:

Code:
UUID=f7927995-b098-42be-ada0-987857f5177a /media/Windows ext4 defaults,noatime 0 2
 
Old 02-28-2013, 12:34 AM   #6
kishor joshi
Member
 
Registered: Jan 2013
Location: Pune,India
Distribution: Linux Mint16 Cinnamon, 64-bit,Linux Mint 17
Posts: 49
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Thumbs up

Quote:
Originally Posted by Kustom42 View Post
Just put a # in front of this line:

Code:
UUID=f7927995-b098-42be-ada0-987857f5177a /media/Windows ext4 defaults,noatime 0 2
=====================================
after $ sudo gedit /etc/fstab
in Terminal, gedit was automatically opened
last two lines were deletedand problem is solved.

I had saved Fstab file (which was existing on(24/2/2013)an the existing one.So that I will have one ftsab file which works.
Thanks a lot.
Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
disk drive for / is not ready yet or not present arunkumarev Linux - Newbie 3 10-08-2012 11:25 PM
New Install of Debian of PPC G4 not booting with repeated message "drive not ready.." jeffpeck Linux - Newbie 7 03-23-2010 08:58 PM
Fedora 7 DVD after booting stops with a READY message JGRetired Fedora - Installation 0 08-18-2007 09:42 PM
Message : 'Drive Not Ready' while I insert an Audio CD anindyanuri Linux - Software 0 06-30-2006 10:48 PM
EIDE Tape drive not ready message DevO Mandriva 0 02-27-2004 08:24 PM


All times are GMT -5. The time now is 05:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration