LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Memory corruption detected in low memory (http://www.linuxquestions.org/questions/linux-general-1/memory-corruption-detected-in-low-memory-827890/)

chris1274 08-22-2010 09:47 PM

Memory corruption detected in low memory
 
Hi everyone,

This is my first post in these forums. I'm still quite new to Linux (using Mint 9) so please bear with my not-very-articulate question(s) ...

When I boot up and open up a tty terminal I get a message saying "Memory corruption detected in low memory." I've done an extensive google search about the issue and it seems not uncommon. I ran a memtest with no errors returned, so I'm sure that there's nothing really wrong with the memory; apparently it's a bug in the kernel that's causing this.

I came across this message in the Arch Linux forum about this very issue:

Quote:

Fancy thing this "Corrupted Low Memory", as I get it as well on my T42...
I downgraded to kernel 2.6.30.1 and still had the Corrupt message in my dmesg. I then downgraded to 2.6.29.1 and voila the Corrupt messages went away, and so did the random module crashes (as you seem to be getting too after the Corrupt messages).
The problem seems to be with:
CONFIG_X86_CHECK_BIOS_CORRUPTION: Check for low memory corruption
Which is a new feature ever since 2.6.28.x kernel. It was working properly for us T42 ppl, until 2.6.30.x came along, and still hasn't been fixed in 2.6.31.x. To fix this and get system stability back, add the following to the end of your kernel line (in either Lilo or Grub):
memory_corruption_check=0
That stops the kernel from checking for corrupted low memory, but, since the check procedure messes up the system and causes modules to crash, it's better to disable it until the problem is worked out.
To be on the safe side, I ran a few memory check programs, and they all ran without errors. So my low memory isn't corrupt after all, just a bug in a feature that can be disabled.
This seems a promising way to deal with this false flag, but I just don't know what file this person is referring to that needs to be edited. Can anyone tell me where the "kernel line" is? Thanks very much in advance.

bigrigdriver 08-22-2010 10:47 PM

Quote:

This seems a promising way to deal with this false flag, but I just don't know what file this person is referring to that needs to be edited. Can anyone tell me where the "kernel line" is? Thanks very much in advance.
The file is the grub configuration file in /boot/grub, or /etc/lilo.conf (I think: I haven't used lilo in years). In the menu list of operating systems available to boot, each menu item has a kernel line. Add memory_corruption_check=0 to the end of that line.

chris1274 08-23-2010 10:27 PM

I'm not sure disabling the memory corruption check is the right way to go after all. Apparently the BIOS is corrupting the first 64K of physical RAM, and the check prevents the system from using that memory later on.

The odd thing is that this didn't start happening until I installed the 2.6.34 kernel.


All times are GMT -5. The time now is 11:32 AM.