LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 12-18-2002, 05:52 PM   #1
serquicia
LQ Newbie
 
Registered: Dec 2002
Location: Argentina
Distribution: Fedora Core 1
Posts: 15

Rep: Reputation: 0
machine name changed by DHCP


I'm running RH8 with a cable modem. Each time I turn on my PC the name of it changed to something that it is set by my ISP. When I log in to GNOME it says that it could'n find and address or something like it for the name of my machine. How can I fix it?
 
Old 12-18-2002, 06:51 PM   #2
nxny
Member
 
Registered: May 2002
Location: AK - The last frontier.
Distribution: Red Hat 8.0, Slackware 8.1, Knoppix 3.7, Lunar 1.3, Sorcerer
Posts: 771

Rep: Reputation: 30
Try setting your hostname in /etc/sysconfig/network

It should look something like..
NETWORKING=yes
HOSTNAME=myhostnamewithoutdomain

Could you post what your
/etc/sysconfig/network-scripts/ifcfg-eth0
says? I just want to find out if we need to make a tweak there.
 
Old 12-18-2002, 07:04 PM   #3
serquicia
LQ Newbie
 
Registered: Dec 2002
Location: Argentina
Distribution: Fedora Core 1
Posts: 15

Original Poster
Rep: Reputation: 0
My /etc/sysconfig/network-scripts/ifcfg-eth0 says:

DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
USERCTL=no
PEERDNS=no
TYPE=Ethernet

and my /etc/sysconfig/network says:

NETWORKING=yes
HOSTNAME=localhost.localdomain
 
Old 12-18-2002, 08:14 PM   #4
nxny
Member
 
Registered: May 2002
Location: AK - The last frontier.
Distribution: Red Hat 8.0, Slackware 8.1, Knoppix 3.7, Lunar 1.3, Sorcerer
Posts: 771

Rep: Reputation: 30
su -
to become root temporarily. Supply root password

Go ahead and change your HOSTNAME entry in /etc/sysconfig/network to whatever you want it to be.

HOSTNAME=pluto

and then add a line to your /etc/hosts so it would look something like ..

127.0.0.1 localhost
127.0.0.1 pluto.mydomain.com pluto

now type in
/sbin/service network restart

exit root shell using Ctrl-D

type in
hostname
and see what it says.
 
Old 12-18-2002, 08:53 PM   #5
serquicia
LQ Newbie
 
Registered: Dec 2002
Location: Argentina
Distribution: Fedora Core 1
Posts: 15

Original Poster
Rep: Reputation: 0
That worked great.

I did that through System Settings -> Network.

Under DNS I put "pluto" as my Hostname.

Then under hosts I put:
IP: 127.0.0.1 Name: pluto.provider.com Aliases: pluto

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ip from dhcp changed after new install mht Linux - Networking 7 07-07-2005 07:02 AM
Mandrake changed login screen and includes machine users motorbelly Mandriva 4 03-31-2004 10:11 PM
changed ifcfg from dhcp to static ip monc Linux - Software 3 01-21-2004 08:12 AM
Linux machine as DHCP server spony Linux - Networking 4 12-23-2003 08:47 AM
Machine gets IP from DHCP but can't see the world JoAnywhere Linux - Networking 7 10-28-2003 07:28 PM


All times are GMT -5. The time now is 02:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration