LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Machine locks up at 100% usage... (http://www.linuxquestions.org/questions/linux-general-1/machine-locks-up-at-100-usage-81803/)

vbp6us 08-13-2003 11:18 PM

Machine locks up at 100% usage...
 
Hi,

I think I posted on this before but I couldnt find my thread. I run a forum and sometimes my machine locks up at 100% usage. The cpu stays like that until i reset the computer. What could be the problem?

Im running Suse 8.1 pro
on 400mhz AMD K6
294mb ram
15gb HD

Shouldn't that be more than enough?

Thank you.

teval 08-13-2003 11:29 PM

*wonders what you mean by locks up*
What I'd do is.. keep an xterm open... or have another comp so you can ssh into it.. or just be in a terminal (alt+shift+control+f2) log on.. with root.
Type top
Wait until the 100% thing happens and see what's guzzling up all that CPU power.
Try replacing that program with something else.. or upgrading it.
Else.. post here and with your configuration and we'll take a look :)

vbp6us 08-13-2003 11:42 PM

Quote:

Originally posted by teval
*wonders what you mean by locks up*
What I'd do is.. keep an xterm open... or have another comp so you can ssh into it.. or just be in a terminal (alt+shift+control+f2) log on.. with root.
Type top
Wait until the 100% thing happens and see what's guzzling up all that CPU power.
Try replacing that program with something else.. or upgrading it.
Else.. post here and with your configuration and we'll take a look :)

By lock up i mean it stays 100% used according to Gkrellm. I just learned of the command Top before i read your reply and did it. It keeps changing. Sometimes X is the top guzzler while other times it's kdeinit. Im not sure what the later one is.

I read the Tips for Optim. Memory in linux article too but nothing. It's not locked up now so there is no use in checking. How do i exit X and stay in some low memory consuming environment? And how do i come back when i have the need? This is a server which i manage from online...nothing really from sitting behind it. SO. How can i exit X and what command brings me back in?

thank you.

vbp6us 08-15-2003 01:31 PM

<bumb>

Anyone? No one here knows how to leave all webservices on but log into a command mode so that there is no gui?

I need an environment where no gui exists. Then when i want, be able to type something in and go back into KDE.

I know it's possible so come on. :D

Thanks.

Proud 08-15-2003 01:39 PM

Alter your configuration for runlevel3, that usually just lacks X but runs other services.

vbp6us 08-15-2003 02:02 PM

Hi,

How would i go about doing this? All i want it to do is when the computer starts(i dont restart/shutdown too often) in runlevel and then from runlevel go into KDE if i want. Then from KDE, after doing what i have to do, go back into runlevel.

Proud 08-15-2003 02:14 PM

If you normally use a graphical login then you're booting into runlevel5 (or 4 if Slackware). Runlevel3 normally starts all the same services except the display manager, and ends with a command prompt. If you log in via this and then startx then you probably use runlevel3.
Unless you've added some strange services and they arent set up for 3 and 5, you should be able to alter the line in /etc/inittab and switch from 5 to 3 easily, and then log in via the command prompt. If you then ever want to use X, either start the dm service, or use the command startx.
Check your runlevel settings via the SysV-Init Editor, or look at the symlinks in /etc/rc5.d/ and /etc/rc3.d/ which link to scripts in /etc/rc.d/init.d/ :)

zLinuxz 08-15-2003 02:42 PM

if your GKrellm is telling you that your CPU locks up at 100%, and then your pc begins to really slow down, it is probably because of a faulty software that is running in your linux box.

do as root

#]: ps -aux

you will get all the processes in your computer, you need to see, by shutting down one by one which one you can find out which one is causing your CPU to get locked up at 100%

I use to get this problem a couple of versions ago with GAIM, but then they fixed.

It is usually an endless loop that makes your CPU do the same little thing over, and over, and over, and it fills up your cpu, that is the problem

So check it out, and let us know how it goes.

Have fun!

zLinuxz

vbp6us 08-16-2003 02:05 PM

Funny thing is it's not happenning. :D


That maybe good but i want to do what you just gave me so i can find out for sure.

How would I go about doing the following:


Have my computer boot into runlevel by default.

Then have it start X/KDE

After Im done using KDE, go back into Runlevel?

Thank you.

broxys 08-16-2003 02:24 PM

i would suggest finding another window manager than KDE too. KDE is really heavy and sucks processes like a hoover. Maybe something simpler like blackbox or fluxbox?

zLinuxz 08-18-2003 01:24 PM

once you Turn on your computer, depending on whether you are using GRUB or LILO, you need to get into the prompt, so that you can type

linux 3

and then hit enter, after you do that, you will boot into Text login, and then can start Xwindow by simply typing: startx

that's all you need to do bro, good luck, :)

oh, and you go back to text mode, you simply logout of Xwindow, with your logout button.

cheers!


All times are GMT -5. The time now is 05:59 AM.