LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 03-14-2011, 05:23 PM   #1
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: SLED, openSUSE
Posts: 1,032

Rep: Reputation: 174Reputation: 174
Unhappy lzip compressed data


How the ****** do I unpack this?

Code:
mike@continuity:~$ file ddrescue-1.14.tar.lz 
ddrescue-1.14.tar.lz: lzip compressed data, version: 1
Nothing I've found via Google works. E.g.
Code:
mike@continuity:~$ tar Jxvf ddrescue-1.14.tar.lz 
xz: (stdin): File format not recognized
tar: Child returned status 1
tar: Error is not recoverable: exiting now
mike@continuity:~$ xzcat ddrescue-1.14.tar.lz 
xzcat: ddrescue-1.14.tar.lz: File format not recognized
mike@continuity:~$ tar --lzma -xvf ddrescue-1.14.tar.lz 
lzma: (stdin): File format not recognized
I even tried double clicking it in Nautilus but that just got me "There is no command installed for Lzip archive files.
Do you want to search for a command to open this file?" followed by an error when I responded in the affirmative.

Last edited by arizonagroovejet; 03-14-2011 at 05:24 PM. Reason: Angry smiley, that's not what I was aiming for but appare
 
Old 03-14-2011, 05:37 PM   #2
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
You need lzip! Which OS are you running? For OpenSuSE I found it through the "package search" form on the official site, since it is not placed in the standard repositories. Once you have lzip installed you can simply do
Code:
tar xvf ddrescue-1.14.tar.lz
or more explicitly:
Code:
tar --lzip -xvf ddrescue-1.14.tar.lz
Hope this helps.
 
1 members found this post helpful.
Old 03-15-2011, 04:53 AM   #3
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: SLED, openSUSE
Posts: 1,032

Original Poster
Rep: Reputation: 174Reputation: 174
Quote:
Originally Posted by colucix View Post
You need lzip!
I thought I had it, but apparently not. I'm using openSUSE 11.4. There isn't an lzip package for 11.4 available from software.opensuse.org but the 11.3 package works.

Thanks!

Last edited by arizonagroovejet; 03-15-2011 at 04:53 AM. Reason: formatting
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
invalid compressed data--format violated holland.d LinuxQuestions.org Member Success Stories 6 01-26-2010 06:31 PM
Linux Compressed ROM file data ?? maas187 Linux - Software 7 08-20-2008 11:42 AM
FC 6: gunzip: stdin: invalid compressed data--format violated jnonaka Linux - Newbie 14 03-23-2007 03:24 PM
invalid compressed data error Seyfert Linux - Newbie 1 04-26-2006 04:47 PM
invalid compressed data crc--error aurelio26 Linux - Newbie 3 10-08-2004 03:53 PM


All times are GMT -5. The time now is 02:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration