LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 03-25-2006, 11:18 PM   #1
quzax
LQ Newbie
 
Registered: Oct 2002
Posts: 5

Rep: Reputation: 0
LVM mounts not showing up in Samba shares


I am running FC4, Samba 3.0.14a-2, and LVM 2.01.08.

LVM is configured and running without issue.

I have configured Samba and I am able to see my server from my PC and my mac and am able to mount shares on both.

However I am unable to mount a share or view any mount points for LVM partitions from within the smb shares.

The main directory I am trying to share is "/data" this is a directory off of my root filesystem (ext3). Within this directory I have mounted several LVM VGs, and one file for testing purposes. The directory structure looks like:
Code:
/data (directory on root)
/data/brian (LVM VG mounted here)
/data/photos (LVM VG mounted here)
/data/test.txt (sample file for testing)
I have also setup a share for /opt just for tesing.

I have one other share setup for /data/brian also for testing.

Now what happens is I can mount the "opt" share from windows or mac & everything looks fine. I can traverse directories, view files etc. Works perfectly.

I can mount the "data" share in windows and mac but the ONLY thing I see in this mount is the test.txt file the two LVM mounts don't show up at all.

If I attempt to mount the "brian" share windows gives me the message that the network provider could not be found. And Mac os just sits there attempting to mount the share & never times out.

I get lines similar to this back from 'dmesg':
smb_add_request: request [cde9be00, mid=50504] timed out!

but I'm not sure if that is related to this issue or just a timeout of one of the smb shares I have mounted on the server using smbclient.

My 'mount' output is (I removed lines unrelated to this issue):
Code:
/dev/sde2 on / type ext3 (rw)
/dev/sde5 on /opt type ext3 (rw)
/dev/mapper/vg-data--brian on /data/brian type ext3 (rw,noatime)
/dev/mapper/vg-photos on /data/photos type ext3 (ro)
Here is my samba.conf:
Code:
[global]
        workgroup = IRK
        log file = /var/log/samba/log.smbd
        security = share
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        workgroup = irk
        server string =
[data]
        path = /data
        writeable = yes
        guest ok = yes
        browseable = yes
[brian]
        path = /data/brian
        writeable = yes
        guest ok = yes
        browseable = yes
[opt]
        path = /opt
        writeable = no
        guest ok = yes
        browseable = yes
Log.smbd gives the following output repeatedly, although I'm not too worried about this yet, I'd first like to figure out why the shares don't show up.:
Code:
[2006/03/25 21:51:35, 0] passdb/pdb_smbpasswd.c:startsmbfilepwent(204)
  startsmbfilepwent_internal: unable to open file /etc/samba/smbpasswd. Error was: Permission denied
[2006/03/25 21:51:36, 0] passdb/pdb_smbpasswd.c:add_smbfilepwd_entry(606)
  add_smbfilepwd_entry: unable to open file.
[2006/03/25 21:51:36, 1] auth/auth_sam.c:check_sam_security(291)
  Failed to modify entry.
[2006/03/25 21:51:36, 1] smbd/service.c:make_connection_snum(642)
  gir (192.168.0.101) connect to service data initially as user nobody (uid=99, gid=99) (pid 29751)
[2006/03/25 21:51:36, 0] passdb/pdb_smbpasswd.c:startsmbfilepwent(279)
  startsmbfilepwent_internal: failed to set 0600 permissions on password file /etc/samba/smbpasswd. Error was Permission denied
Any suggestions would be appreciated.
Thanks
quzax
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandriva shares NOT showing up on WinXP Box Honkeychops Linux - Newbie 3 06-10-2005 01:56 AM
samba not showing all shares haora Linux - Software 5 05-25-2005 02:48 PM
Smb4k not showing Windows shares Latem Linux - Software 2 03-09-2005 10:32 AM
Samba shares not showing up eroica Linux - Software 3 03-19-2004 07:48 AM
Linux can mount samba shares but not windows shares bindsocket Linux - Software 1 12-01-2003 06:28 PM


All times are GMT -5. The time now is 03:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration