LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 10-28-2003, 02:17 AM   #1
zstingx
LQ Newbie
 
Registered: Oct 2003
Posts: 21

Rep: Reputation: 15
lock the screen as a root user?


Hello,

I am running RedHat 9 ; is there some utility to lock the screen when logging was done as root user?
If I try to go to Start->Lock Screen nothing happen ; and trying xscreensaver gives the following error:

xscreensaver: Can't open display: :0.0
xscreensaver: initial effective uid/gid was root/root (0/0)
xscreensaver: running as nobody/nobody (99/99)

xscreensaver: This is probably because you're logging in as root. You
shouldn't log in as root: you should log in as a normal user,
and then `su' as needed. If you insist on logging in as
root, you will have to turn off X's security features before
xscreensaver will work.

well , I do really do not want to turn off X's security features;

Is there some other soluton/workaround/utility to achieve locking
the screen when logging was done as root user?

regards,
sting
 
Old 10-28-2003, 03:11 AM   #2
BittaBrotha
Member
 
Registered: Jan 2002
Location: Third Stone from the Sun
Distribution: Debian Sid, SourceMage 0.9.5, & To be Continued on a TP
Posts: 800

Rep: Reputation: 31
That is a security feature...maybe just logout of root and log back in when you are ready to use it.

Why you want to log in as root and leave it open?
 
Old 10-28-2003, 03:14 AM   #3
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
http://www.jwz.org/xscreensaver/faq.html#root-lock
not with xscreensaver as far as locking the screen.

the easiest "workaround" i can think of is to make the default desktop environment for root kde.

but as stated before, the best policy if logged in as root and you need to leave for some reason, is to logout instead.

Last edited by megaspaz; 10-28-2003 at 03:23 AM.
 
Old 10-28-2003, 04:10 AM   #4
UltimaGuy
Member
 
Registered: Aug 2003
Location: Chennai, India
Distribution: PCLinuxOS .92, FC4
Posts: 840

Rep: Reputation: 31
You can add the root account to the trusted users list by the command

"xhost +localhost"

This will enable you to use both the xscreensaver and the locking facility as root.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
lock the screen problem with "root" hetzme Linux - Newbie 1 07-13-2005 06:11 PM
New install 9.1 no root user at login screen glennl Mandriva 5 09-03-2003 03:39 PM
Lock screen not working with root sikandar Linux - Software 1 09-02-2003 09:06 AM
screen to small as root user jkp Linux - Newbie 12 01-16-2003 09:21 AM
Starting 'Screen' from rc.local as a user other than root Mulefire Linux - General 0 02-21-2002 11:05 AM


All times are GMT -5. The time now is 10:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration