LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 07-11-2001, 11:44 AM   #1
cinnix
Member
 
Registered: Jun 2001
Location: Northern Ohio
Distribution: RedHat, Engarde and LFS
Posts: 237

Rep: Reputation: 30
Locale


I get this error when I try to execute one of my perl programs. Can anyone tell me what these settings should be.

I set the LANG one myself to en_US but I am not sure if that is correct.

I am english speaking (duh) from the united states. Please let me know of any other related variables that I should check that may cause related problems.

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en",
LC_ALL = (unset),
LANG = "en_US"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

This is happening on a LInux Redhat 7.0 system with all of the software updates applied.
 
Old 07-11-2001, 05:08 PM   #2
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Read your perllocale man page. It should give you all the information you need.
 
Old 07-11-2001, 08:44 PM   #3
cinnix
Member
 
Registered: Jun 2001
Location: Northern Ohio
Distribution: RedHat, Engarde and LFS
Posts: 237

Original Poster
Rep: Reputation: 30
[root@lockbox /usr/share/locale]# ls
C da en es_ES fr hr it l10n no pt_BR sk sv zh br de en_GB et ga hu ja lt no@nynorsk pt_PT sl tr zh_CN.GB2312 ca de_AT eo eu gl id ja_JP.eucJP nl pl ro sp uk zh_CN.gb2312
cs el es fi gr_GR is ko nn pt ru sr wa zh_TW.Big5
[root@lockbox /usr/share/locale]# cd en
[root@lockbox /usr/share/locale/en]# ls
man
[root@lockbox /usr/share/locale/en]#

I read over the page but things didn't seem to make much sense as I know nothing at all about perl. It appears to me like I am missing the locale files that I need. Any extra help would be appreciated.
 
Old 07-12-2001, 07:39 AM   #4
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Try this page out, it might be in better english: http://www.perldoc.com/perl5.6/pod/perllocale.html
 
Old 07-13-2001, 12:03 AM   #5
cinnix
Member
 
Registered: Jun 2001
Location: Northern Ohio
Distribution: RedHat, Engarde and LFS
Posts: 237

Original Poster
Rep: Reputation: 30
It looks like it was an error in my perl upgrade, I made a couple of edits in my /etc directory and all was fine. I edited things here because redhat put some scripts into /etc/sysconfig that sets these parameters.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 10 03-24-2013 08:35 PM
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 03:34 AM
"locale not supported by Xlib, locale set to C" Irad Linux - Software 3 06-25-2006 03:59 PM
C locale and system locale johnnydangerous Fedora 4 04-11-2005 03:37 PM
locale da Perp Linux - Newbie 7 01-23-2002 01:45 AM


All times are GMT -5. The time now is 12:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration