LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Linux Stopped Booting (http://www.linuxquestions.org/questions/linux-general-1/linux-stopped-booting-101233/)

helios007 10-07-2003 10:15 AM

Linux Stopped Booting
 
Hi,

Yesterday I attempted to start my linux system, and it won't boot. It might be that I added an additonal HD to my system a week ago, and this might have been the first time that I have rebooted since then. I was careful when I installed the new drive, but maybe I made a mistake editing the fstab.

Here's the error that I get when booting:
Couldn't find matching filesystem:
LABEL=/main
***An error occured during the file system check

So, I tried to use my RH9 rescue cds to recover the system, and get this error when I choose "Upgrade existing system" (edited because of length).
From anacdump.txt:

Traceback (most recent call last):
File "/usr/lib/anaconda/gui.py", line 761, in nextClicked
self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 157, in gotoNext
self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 225, in moveStep
rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/upgrade.py", line 249, in upgradeMountFilesystems
allowDirty = 0)
File "/usr/lib/anaconda/upgrade.py", line 131, in mountRootPartition
oldfsset.mountFilesystems(instPath, readOnly = readOnly)
File "/usr/lib/anaconda/fsset.py", line 1260, in mountFilesystems
if isinstance(root.device, LogicalVolumeDevice):
AttributeError: 'NoneType' object has no attribute 'device'

Local variables in innermost frame:
readOnly: 0
instPath: /mnt/sysimage
entry: fsentry -- device: hde3 mountpoint: swap
fsystem: swap format: 0
ismounted: 0

self: <fsset.FileSystemSet instance at 0x81ae4ec>
root: None
raiseErrors: 0


Dispatcher instance, containing members:
method: CdromInstallMethod instance, containing members:
messageWindow: <bound method InstallInterface.messageWindow of <gui.InstallInterface instance at 0x8713904>>
loopbackFile: None
progressWindow: <bound method InstallInterface.progressWindow of <gui.InstallInterface instance at 0x8713904>>
device: hdc
timestamp: 1047611055.799229
tree: /mnt/source
rootPath: /mnt/sysimage
currentDisc: [1]
step: 16
intf: InstallInterface instance, containing members:
icw: InstallControlWindow instance, containing members:
displayHelp: 1
....

mountcount: 4
entries: [fsentry -- device: hde1 mountpoint: /boot
fsystem: ext3 format: 0
ismounted: 1

, fsentry -- device: none mountpoint: /dev/pts
fsystem: devpts format: 0
ismounted: 1

, fsentry -- device: none mountpoint: /dev/shm
fsystem: tmpfs format: 0
ismounted: 0

, fsentry -- device: hdf1 mountpoint: /mnt/hdf1
fsystem: ext3 format: 0
ismounted: 1

, fsentry -- device: none mountpoint: /proc
fsystem: proc format: 0
ismounted: 1

, fsentry -- device: hde3 mountpoint: swap
fsystem: swap format: 0
ismounted: 0

]
progressWindow: <bound method InstallInterface.progressWindow of <gui.InstallInterface instance at 0x8713904>>
migratedfs: 0
keyboard: Keyboard instance, containing members:
....


type: PC
beenset: 1
timezone: Timezone instance, containing members:
utc: 0
utcOffset: 0
arc: 0
tz: None
dst: 0
bootloader: x86BootloaderInfo instance, containing members:
kickstart: 0
doUpgradeOnly: 0
useLinear: 1
defaultDevice: None
useGrubVal: 1
args: KernelArguments instance, containing members:
args: hdg=ide-scsi
kernelLocation: /boot/
images: BootImages instance, containing members:
default: None
images: {}
configfile: /etc/lilo.conf
above1024: 0
serialOptions: None
pure: None
serialDevice: None
device: None
drivelist: [hde, hdf]
serial: 0
password: None
forceLBA32: 0
mouse: FULLNAME="Generic - Wheel Mouse (PS/2)"
MOUSETYPE="imps2"
XEMU3="no"
XMOUSETYPE="IMPS/2"

extraModules: []
network: Network instance, containing members:
domains: []
isConfigured: 0
overrideDHCPhostname: 0
netdevices: {}
primaryNS:
hostname: localhost.localdomain
secondaryNS:
gateway:
ternaryNS:
instClass: InstallClass instance, containing members:
upgradeRemove: []
upgrade: Boolean instance, containing members:
val: 1
monitor: Already dumped
comps: None
floppyDevice: fd0
firstboot: 0
methodstr: cdrom://hdc/mnt/source
videocard: Already dumped
desktop: Desktop instance, containing members:
info: {}
runlevel: 3
instLanguage: InstallTimeLanguage instance, containing members:
current: en_US.UTF-8
....

langList: None
default: None
langNicks: None
supported: []
allSupportedLangs: None
partitions: Partitions instance, containing members:
useFdisk: 0
useAutopartitioning: 1
autoClearPartType: 3
nextUniqueID: 5
reinitializeDisks: 0
autoClearPartDrives: None
zeroMbr: 0
isKickstart: 0
requests: [PreexistingPartitionSpec instance, containing members:
currentDrive: None
badblocks: None
format: None
migrate: None
origfstype: ext3FileSystem instance, containing members:
partedPartitionFlags: []
checked: 1
name: ext3
migratetofs: None
deviceArguments: {}
supported: -1
partedFileSystemType: <PedFileSystemType object at 0x8469900>
defaultOptions: defaults
maxSizeMB: 2097152
extraFormatArgs: [-j]
formattable: 1
linuxnativefs: 1
maxLabelChars: 16
primary: None
fstype: Already dumped
preexist: 1
dev: None
uniqueID: 4
device: hdf1
mountpoint: None
requestSize: 29311.7036133
maxSizeMB: None
size: 29311.7036133
end: 60030431
drive: hdf
fslabel: None
grow: 0
start: 63
protected: 0
ignoreBootConstraints: 0
type: 1
, PreexistingPartitionSpec instance, containing members:
currentDrive: None
badblocks: None
format: None
migrate: None
origfstype: Already dumped
primary: None
fstype: Already dumped
preexist: 1
dev: None
uniqueID: 1
device: hde1
mountpoint: None
requestSize: 99.8833007812
maxSizeMB: None
size: 99.8833007812
end: 204623
drive: hde
fslabel: /boot
grow: 0
start: 63
protected: 0
ignoreBootConstraints: 0
type: 1
, PreexistingPartitionSpec instance, containing members:
currentDrive: None
badblocks: None
format: 1
migrate: None
origfstype: swapFileSystem instance, containing members:
partedPartitionFlags: []
checked: 0
name: swap
migratetofs: None
deviceArguments: {}
supported: 1
partedFileSystemType: <PedFileSystemType object at 0x83ef360>
defaultOptions: defaults
maxSizeMB: 2097152
extraFormatArgs: []
formattable: 1
linuxnativefs: 1
maxLabelChars: 16
primary: None
fstype: Already dumped
preexist: 1
dev: None
uniqueID: 3
device: hde3
mountpoint: None
requestSize: 1279.6875
maxSizeMB: None
size: 1279.6875
end: 78177455
drive: hde
fslabel: None
grow: 0
start: 75556656
protected: 0
ignoreBootConstraints: 0
type: 1
, PreexistingPartitionSpec instance, containing members:
currentDrive: None
badblocks: None
format: None
migrate: None
origfstype: Already dumped
primary: None
fstype: Already dumped
preexist: 1
dev: None
uniqueID: 2
device: hde2
mountpoint: None
requestSize: 36792.984375
maxSizeMB: None
size: 36792.984375
end: 75556655
drive: hde
fslabel: /
grow: 0
start: 204624
protected: 0
ignoreBootConstraints: 0
type: 1
]
autoPartitionRequests: []
deletes: []
upgradeDeps:
configFileData: .

...

flags: Flags instance, containing members:
flags: {'test': 0, 'setupFilesystems': 1, 'serial': 0, 'expert': 0, 'autostep': 0}
dispatch: Already dumped
instPath: /mnt/sysimage
firstStep: 0
id: Already dumped
dir: 1
skipSteps: {'writeconfig': 1, 'xcustom': 1, 'firewall': 1, 'languagesupport': 1, 'firstboot': 1, 'desktopchoice': 1, 'bootloaderadvanced': 1, 'betanag': 1, 'partitionmethodsetup': 1, 'writexconfig': 1, 'networkdevicecheck': 1, 'bootloadersetup': 1, 'accounts': 1, 'makebootdisk': 1, 'installtype': 1, 'partitiondone': 1, 'timezone': 1, 'indivpackage': 1, 'bootloader': 1, 'autopartition': 1, 'selectlangpackages': 1, 'confirminstall': 1, 'enablefilesystems': 1, 'network': 1, 'partitionmethod': 1, 'writeksconfig': 1, 'partition': 1, 'handleX11pkgs': 1, 'setuptime': 1, 'videocard': 1, 'fdasd': 1, 'package-selection': 1, 'authentication': 1, 'monitor': 1, 'autopartitionexecute': 1, 'fdisk': 1}


/tmp/syslog:
<4>Linux version 2.4.20-8BOOT (bhcompile@porky.devel.redhat.com) (gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)) #1 Thu Mar 13 17:31:38 EST 2003
<6>BIOS-provided physical RAM map:
<4> BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
<4> BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
<4> BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
<4> BIOS-e820: 0000000000100000 - 0000000027ff0000 (usable)
<4> BIOS-e820: 0000000027ff0000 - 0000000027ff3000 (ACPI NVS)
<4> BIOS-e820: 0000000027ff3000 - 0000000028000000 (ACPI data)
<4> BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
<5>0MB HIGHMEM available.
<5>639MB LOWMEM available.
<4>On node 0 totalpages: 163824
<4>zone(0): 4096 pages.
<4>zone(1): 159728 pages.
<4>zone(2): 0 pages.
<4>Kernel command line: initrd=initrd.img BOOT_IMAGE=vmlinuz
<6>Initializing CPU#0
<4>Detected 551.264 MHz processor.
<4>Console: colour VGA+ 80x25
<4>Calibrating delay loop... 1101.00 BogoMIPS
<6>Memory: 638984k/655296k available (1209k kernel code, 13748k reserved, 350k data, 104k init, 0k highmem)
<6>Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes)
<6>Inode cache hash table entries: 65536 (order: 7, 524288 bytes)
<6>Mount cache hash table entries: 512 (order: 0, 4096 bytes)
<4>Buffer-cache hash table entries: 65536 (order: 6, 262144 bytes)
<4>Page-cache hash table entries: 262144 (order: 8, 1048576 bytes)
<6>CPU: L1 I Cache: 32K (32 bytes/line), D cache 32K (32 bytes/line)
<7>CPU: After generic, caps: 008021bf 808029bf 00000000 00000002
<7>CPU: Common caps: 008021bf 808029bf 00000000 00000002
<4>CPU: AMD-K6(tm) 3D processor stepping 0c
<6>Checking 'hlt' instruction... OK.
<6>Checking for popad bug... OK.
<4>POSIX conformance testing by UNIFIX
<4>mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
<4>mtrr: detected mtrr type: AMD K6
<6>PCI: PCI BIOS revision 2.10 entry at 0xfb3e0, last bus=1
<6>PCI: Using configuration type 1
<6>PCI: Probing PCI hardware
<6>PCI: Using IRQ router VIA [1106/0586] at 00:07.0
<6>Activating ISA DMA hang workarounds.
<6>Linux NET4.0 for Linux 2.4
<6>Based upon Swansea University Computer Society NET3.039
<4>Initializing RT netlink socket
<6>BIOS EDD facility v0.09 2003-Jan-22, 2 devices found
<4>Starting kswapd
<4>pty: 256 Unix98 ptys configured
<6>Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
<6>ttyS0 at 0x03f8 (irq = 4) is a 16550A
<6>ttyS1 at 0x02f8 (irq = 3) is a 16550A
<6>Floppy drive(s): fd0 is 1.44M
<6>FDC 0 is a post-1991 82077
<6>NET4: Frame Diverter 0.46
<4>RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
<6>loop: loaded (max 8 devices)
<6>Uniform Multi-Platform E-IDE driver Revision: 7.00beta-2.4
<6>ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
<6>VP_IDE: IDE controller at PCI slot 00:07.1
<6>VP_IDE: chipset revision 6
<6>VP_IDE: not 100% native mode: will probe irqs later
<6>ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
<6>VP_IDE: VIA vt82c586b (rev 47) IDE UDMA33 controller on pci00:07.1
<6> ide0: BM-DMA at 0xa000-0xa007, BIOS settings: hda:DMA, hdb:DMA
<6> ide1: BM-DMA at 0xa008-0xa00f, BIOS settings: hdc:DMA, hdd:DMA
<6>PDC20267: IDE controller at PCI slot 00:09.0
<6>PCI: Found IRQ 5 for device 00:09.0
<6>PDC20267: chipset revision 2
<6>PDC20267: not 100% native mode: will probe irqs later
<6>PDC20267: ROM enabled at 0xe8000000
<6>PDC20267: (U)DMA Burst Bit ENABLED Primary PCI Mode Secondary PCI Mode.
<6> ide2: BM-DMA at 0xc000-0xc007, BIOS settings: hde:pio, hdf:DMA
<6> ide3: BM-DMA at 0xc008-0xc00f, BIOS settings: hdg:pio, hdh:pio
<4>hdc: IRQ probe failed (0xfff8)
<4>hdc: IDE DVD-ROM 16X, ATAPI CD/DVD-ROM drive
<4>hde: MAXTOR 6L040L2, ATA DISK drive
<4>hdf: Maxtor 5T030H3, ATA DISK drive
<4>blk: queue c02f5a20, I/O limit 4095Mb (mask 0xffffffff)
<4>blk: queue c02f5b64, I/O limit 4095Mb (mask 0xffffffff)
<4>hdg: PLEXTOR CD-R PX-W4012A, ATAPI CD/DVD-ROM drive
<4>ide1 at 0x170-0x177,0x376 on irq 15
<4>ide2 at 0xb000-0xb007,0xb402 on irq 5
<4>ide3 at 0xb800-0xb807,0xbc02 on irq 5
<4>hde: host protected area => 1
<6>hde: 78177792 sectors (40027 MB) w/1820KiB Cache, CHS=77557/16/63, UDMA(100)
<4>hdf: host protected area => 1
<6>hdf: 60030432 sectors (30736 MB) w/2048KiB Cache, CHS=59554/16/63, UDMA(100)
<4>hdc: ATAPI 48X DVD-ROM drive, 512kB Cache
<6>Uniform CD-ROM driver Revision: 3.12
<4>hdg: ATAPI 40X CD-ROM CD-R/RW drive, 4096kB Cache
<4>ide-floppy driver 0.99.newide
<6>Partition check:
<6> hde: hde1 hde2 hde3
<6> hdf: hdf1
<4>ide-floppy driver 0.99.newide
<6>usb.c: registered new driver usbdevfs
<6>usb.c: registered new driver hub
<6>usb-uhci.c: $Revision: 1.275 $ time 17:33:52 Mar 13 2003
<6>usb-uhci.c: High bandwidth mode enabled
<6>usb-uhci.c: USB UHCI at I/O 0xa400, IRQ 10
<4>usb-uhci.c: Detected 2 ports
<6>usb.c: new USB bus registered, assigned bus number 1
<6>hub.c: USB hub found
<6>hub.c: 2 ports detected
<6>usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
<6>usb.c: registered new driver hiddev
<6>usb.c: registered new driver hid
<6>hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
<6>hid-core.c: USB HID support drivers
<6>mice: PS/2 mouse device common for all mice
<6>md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
<6>md: Autodetecting RAID arrays.
<6>md: autorun ...
<6>md: ... autorun DONE.
<6>NET4: Linux TCP/IP 1.0 for NET4.0
<6>IP Protocols: ICMP, UDP, TCP
<6>IP: routing cache hash table of 8192 buckets, 64Kbytes
<6>TCP: Hash tables configured (established 262144 bind 65536)
<6>NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
<5>RAMDISK: Compressed image found at block 0
<6>Freeing initrd memory: 2640k freed
<4>EXT2-fs warning: checktime reached, running e2fsck is recommended
<4>VFS: Mounted root (ext2 filesystem).
<7>vga16fb: initializing
<6>vga16fb: mapped to 0xc00a0000
<4>Console: switching to colour frame buffer device 80x30
<6>fb0: VGA16 VGA frame buffer device
<6>SCSI subsystem driver Revision: 1.00
<6>Linux Tulip driver version 0.9.15-pre12 (Aug 9, 2002)
<6>PCI: Found IRQ 11 for device 00:0a.0
<6>IRQ routing conflict for 00:0a.0, have irq 9, want irq 11
<7>divert: allocating divert_blk for eth0
<6>eth0: ADMtek Comet rev 17 at 0xe886e000, 00:04:5A:50:92:10, IRQ 9.
<7>ISO 9660 Extensions: RRIP_1991A
<4>Unable to identify CD-ROM format.
<4>VFS: Can't find ext2 filesystem on dev loop(7,0).
<4>hdc: command error: status=0x51 { DriveReady SeekComplete Error }
<4>hdc: command error: error=0x54
<4>end_request: I/O error, dev 16:00 (hdc), sector 1257152
<4>Error -3 while decompressing!
<4>c02d54dc(-51022844)->e73a3000(4096)
<6>md: raid0 personality registered as nr 2
<6>md: raid1 personality registered as nr 3
<6>raid5: measuring checksumming speed
<4> 8regs : 708.800 MB/sec
<4> 32regs : 454.400 MB/sec
<4> 8regs_prefetch: 721.200 MB/sec
<4> 32regs_prefetch: 458.400 MB/sec
<4> pII_mmx : 981.600 MB/sec
<4> p5_mmx : 914.000 MB/sec
<4>raid5: using function: pII_mmx (981.600 MB/sec)
<6>md: raid5 personality registered as nr 4
<6>Journalled Block Device driver loaded
<6>LVM version 1.0.5+(22/07/2002) module loaded
<6>parport0: PC-style at 0x378 [PCSPP(,...)]
<6>kjournald starting. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide2(33,1), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>kjournald starting. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide2(33,2), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>kjournald starting. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide2(33,65), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>kjournald starting. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide2(33,2), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>kjournald starting. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide2(33,1), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>kjournald starting. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide2(33,65), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.


/tmp/anaconda.log:
* modules to insert fbcon-vga-planes vga16fb
* loaded fbcon-vga-planes from /modules/modules.cgz
* loaded vga16fb from /modules/modules.cgz
* inserted /tmp/fbcon-vga-planes.o
* inserted /tmp/vga16fb.o
* load module set done
* 643804 kB are available
* modules to insert cramfs vfat sunrpc lockd nfs loop
* loaded sunrpc from /modules/modules.cgz
* loaded lockd from /modules/modules.cgz
* loaded nfs from /modules/modules.cgz
* module(s) cramfs vfat loop not found
* inserted /tmp/sunrpc.o
* inserted /tmp/lockd.o
* inserted /tmp/nfs.o
* load module set done
* modules to insert ide-cd
* module(s) ide-cd not found
* load module set done
* modules to insert scsi_mod sd_mod sr_mod
* loaded scsi_mod from /modules/modules.cgz
* loaded sd_mod from /modules/modules.cgz
* loaded sr_mod from /modules/modules.cgz
* inserted /tmp/scsi_mod.o
* inserted /tmp/sd_mod.o
* inserted /tmp/sr_mod.o
* load module set done
* looking for usb controllers
* found USB controller usb-uhci
* modules to insert usb-uhci
* module(s) usb-uhci not found
* load module set done
* waiting for usb to become stable...
* 2 seconds.
* modules to insert hid keybdev
* module(s) hid keybdev not found
* load module set done
* no firewire controller found
* no pcic controller found
* probing buses
* finished bus probing
* modules to insert tulip usb-uhci
* loaded tulip from /modules/modules.cgz
* module(s) usb-uhci not found
* inserted /tmp/tulip.o
* load module set done
* trying to mount device hdc
* mntloop loop0 on /mnt/runtime as /mnt/source/RedHat/base/stage2.img fd is 10
* MD5SUM -> e4db359dbb5cdd2b215059ce70f251a5
* skipsectors = 15
* isostatus = 0
* getting ready to spawn shell now
* exec of /bin/sh failed: Permission denied
* modules to insert ide-cd
* module(s) ide-cd not found
* load module set done
* modules to insert
* load module set done
* probing buses
* finished bus probing
* modules to insert agpgart usb-uhci
* module(s) agpgart usb-uhci not found
* load module set done
* looking for video cards requiring agpgart module
* found video card controller unknown
* modules to insert raid0 raid1 xor raid5 msdos jbd ext3 reiserfs jfs xfs lvm-mod
* loaded raid0 from /mnt/runtime/modules/modules.cgz
* loaded raid1 from /mnt/runtime/modules/modules.cgz
* loaded xor from /mnt/runtime/modules/modules.cgz
* loaded raid5 from /mnt/runtime/modules/modules.cgz
* loaded msdos from /mnt/runtime/modules/modules.cgz
* loaded jbd from /mnt/runtime/modules/modules.cgz
* loaded ext3 from /mnt/runtime/modules/modules.cgz
* loaded reiserfs from /mnt/runtime/modules/modules.cgz
* loaded jfs from /mnt/runtime/modules/modules.cgz
* loaded lvm-mod from /mnt/runtime/modules/modules.cgz
* module(s) xfs not found
* inserted /tmp/raid0.o
* inserted /tmp/raid1.o
* inserted /tmp/xor.o
* inserted /tmp/raid5.o
* inserted /tmp/msdos.o
* inserted /tmp/jbd.o
* inserted /tmp/ext3.o
* inserted /tmp/reiserfs.o
* inserted /tmp/jfs.o
* inserted /tmp/lvm-mod.o
* load module set done
* loading parallel port drivers...
* modules to insert parport parport_pc
* loaded parport from /mnt/runtime/modules/modules.cgz
* loaded parport_pc from /mnt/runtime/modules/modules.cgz
* inserted /tmp/parport.o
* inserted /tmp/parport_pc.o
* load module set done
* looking for USB mouse...
* Running anaconda script /usr/bin/anaconda
* ddcprobe returned bogus values:
ID: None
Name: None
HorizSync: None
VertSync: None

* Started mini-wm
* anaconda floppy device fd0
* running ['/usr/X11R6/bin/setxkbmap', '-layout', 'us', '-model', 'pc105', '-option', '']
* moving (1) to step welcome
* moving (1) to step language
* moving (1) to step keyboard
* running ['/usr/X11R6/bin/setxkbmap', '-layout', 'us', '-model', 'pc105', '-option', '']
* moving (1) to step mouse
* moving (1) to step findrootparts
* going to mount /tmp/hde1 on /mnt/sysimage
* going to mount /tmp/hde2 on /mnt/sysimage
* going to mount /tmp/hdf1 on /mnt/sysimage
* moving (1) to step findinstall
* moving (1) to step partitionobjinit
* moving (1) to step upgrademount
* going to mount hde2 on /mnt/sysimage as ext3
* going to mount /tmp/hde2 on /mnt/sysimage
* Warning: fstab file has LABEL=/main, but this label could not be found on any file system
* going to mount /dev/hde1 on /mnt/sysimage/boot
* going to mount none on /mnt/sysimage/dev/pts
* going to mount /dev/hdf1 on /mnt/sysimage/mnt/hdf1
* going to mount none on /mnt/sysimage/proc
* going to mount /tmp/fd0 on /tmp/crash


/tmp/lvmout:
vgchange -- no volume groups found

"/etc/lvmtab.d"
vgscan -- creating empty "/etc/lvmtab" and "/etc/lvmtab.d"
vgscan -- reading all physical volumes (this may take a while...)
vgscan -- "/etc/lvmtab" and "/etc/lvmtab.d" successfully created
vgscan -- WARNING: This program does not do a VGDA backup of your volume group


Any help would be appreciated. This is my main computer right now, so I am somewhat stuck without it.

Thanks,
Helios007

jailbait 10-07-2003 05:14 PM

I suggest that you boot a rescue CD, mount your / partition, and then edit /etc/fstab to comment out the new partition entry. Then try booting.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites

helios007 10-11-2003 10:25 AM

Thanks for the suggestion. I tried doing that, but it's only allowing me to get to the file as read-only. I changed the chmod to let everyone access it, but it still comes up read-only.

Any other ideas?

Megamieuwsel 10-11-2003 10:35 AM

Ofcourse , you should mount your system without the "ro"-option in the bootcommand.
This assumes ,you're trying to boot your rescue-system from the prompt. I'm not sure if a graphical rescue-disk lets you choose that.

jailbait 10-11-2003 12:10 PM

When you get straightened out I suggest that you make yourself a decent rescue CD:

http://users.rcn.com/srstites/LifeBo...home.page.html


__________________

Steve Stites

kuyalfinator 11-06-2003 08:53 PM

My two cents
 
I have a mandrake 9.1 Linux distro. I had trouble with it booting
when I install it on a exsisting partition. Mandrake needed to be
installed on an unpartition space.

Usually, during the first install, Linux needs three primary
paritations:

/ (root)
/home
/swap

When mandrake didn't boot correctly or I wanted a different
GUI version (KDE or GNOME), I just reinstalled the / (root) partition
without earsing the /swap or /home partitions. It installed
ok and I still had the /home files I had saved still there.

If you have any files, drivers, src, that you downloaded and
installed but don't want to loss it, save it under the /home
partition. You probably need to reinstall them again.

The other way, is choosing the upgrade option under redhat.
On mandrake, I accidently picked the wrong screen setup and
X server GUI login didn't run properly. I though I had to reinstall
mandrake, but all I did has insert the first disk and choose the
upgrade option.

So, if there is nothing important with the / (root) partition, then
pick the complete reinstall. Otherwise, try the upgrade option
again, but try it with less demand on the computer (use the
text version upgrade).

Please, don't start reinstalling your version of redhat until you
know that the data you have collected is backed up somewhere
so can restore it. This is only suggestions, but it is up to you to
decide what is the best course of action.


All times are GMT -5. The time now is 10:59 AM.