LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 11-02-2006, 02:33 PM   #1
matthaeus
LQ Newbie
 
Registered: Mar 2005
Posts: 22

Rep: Reputation: 15
Linux changes time everytime I boot


Hi,

my problem is that everytime I boot under Linux my time is switched by some minutes up to half an hour, always backwards. This started since the summer-winter-time switch. It doesn't occur, if I boot windows. Has anybody an idea what is going on and where to check?

I'm now always setting the time under Yast (I'm using Suse 10.1 with all available patches).

Best,
Mat

Last edited by matthaeus; 11-02-2006 at 02:35 PM.
 
Old 11-02-2006, 02:59 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,697

Rep: Reputation: 61
If it changes in minutes versuses hours I would say either the bios battery is weak and not keeping the time in the bios correct. Set the time in the bios then see what happens

Brian
 
Old 11-03-2006, 03:12 AM   #3
matthaeus
LQ Newbie
 
Registered: Mar 2005
Posts: 22

Original Poster
Rep: Reputation: 15
Hi,

I set the time in the bios, and after booting directly after that to Linux the time was 1 minute behind. But I doubt, that it is the bios battery, because I bought the notebook in may this year (a Sony notebook). And also the problem doesn't occur, if I boot Windows. Strange also, that it started after switching from summer-time to winter-time.

Does anybody know how opensuse 10.1 manages the time during the boot?
 
Old 11-04-2006, 06:26 AM   #4
matthaeus
LQ Newbie
 
Registered: Mar 2005
Posts: 22

Original Poster
Rep: Reputation: 15
I solved the problem now. For the record: I delete the file
Code:
/etc/adjtime
It is responsible for adjusting the time of the hardware-clock to the system-time. There was some entry which adjusted the time wrongly. The file is recreated at the next boot.

Mat
 
Old 04-27-2008, 10:48 AM   #5
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Linux config: BIOS clock UTC vs localtime

Just FYI, the issue is whether the BIOS clock stores time as "UTC" or as "localtime".

In SimplyMepis 7.0, the solution is [quote]
vi /etc/default/rcS
<= Change "UTC=no" (localtime, the SimplyMepis default) to "UTC=yes" (now both Windows/Vista and SimplyMepis/Linux expect the BIOS to store time in UTC, and the clock will read the same time booting to either OS)
 
  


Reply

Tags
bios, boot, clock


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
where do i shove sumthing which i want to be run everytime i boot? theMonkeY Slackware 2 09-06-2004 02:49 PM
Smartd Fails on boot up everytime? carlosinfl Fedora 2 07-15-2004 01:45 PM
Need to run alsaconf everytime i boot up! RaVilj Red Hat 3 06-13-2004 05:23 PM
Must run /sbin/ifup eth1 everytime I boot Reo5th Linux - Networking 2 02-27-2004 10:29 AM
Do I have to bind my nic card everytime I boot to fedora? blittle Fedora 5 02-12-2004 09:27 PM


All times are GMT -5. The time now is 11:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration