LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 06-09-2013, 09:54 PM   #1
prw8864
LQ Newbie
 
Registered: Apr 2013
Distribution: Suse 12.3
Posts: 12

Rep: Reputation: Disabled
Linking issues with libpodofo


I am trying to compile the helloworld.cpp example for the podofo library (PDF creation)

I have tried:
g++ -Wall -o "podo_creation_test" "podo_creation_test.cpp"
g++ -Wall -o "podo_creation_test" -L=/usr/lib64 "podo_creation_test.cpp"
g++ -Wall -o "podo_creation_test" -L=/usr/lib64 -lpodofo "podo_creation_test.cpp"

in all cases I get a pile of errors saying :
podo_creation_test.cpp.text+0xdf): undefined reference to // for all PDF functions

I have the library located here:

# ldconfig -p | grep podofo
libpodofo.so.0.9.1 (libc6,x86-64) => /usr/lib64/libpodofo.so.0.9.1

I also have a link in the /usr/lib directory to /usr/lib64/libpodofo.so.0.9.1

I have also tried to set this enviromental veriable with the same result

set LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib64

1) Is there something wrong in the command line
2) is there a way to check what is in the library (the symbol table)

This library was installed through yast / rpm
 
Old 06-11-2013, 07:28 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,519

Rep: Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495
The "libpodofo.so" is missing : # zypper in podofo-devel

The podofo packages also provide the podofo documentation :
/usr/share/doc/packages/podofo/README.html
Compiling and Linking Against PoDoFo → → example :
$ g++ helloworld.cpp -lpodofo -lfreetype -lfontconfig -ljpeg -lz -o hello

Using the executable 'hello' : ./hello file.pdf

-
 
  


Reply

Tags
linking


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] MUMPS: A distributed direct solver... linking issues when building examples ejspeiro Programming 6 08-29-2012 07:04 PM
Issues with undefined references and linking in WordNet Kanangill Linux - Newbie 4 01-20-2011 09:19 AM
Slackware x86_64 '-current' FireFox & Thunderbird issues with linking onebuck Slackware 6 01-22-2010 02:38 PM
Problem in using both load time linking and runtime linking durgaprasad_j Linux - General 0 08-01-2006 03:49 AM
linking issues when using templates dhanakom Programming 1 09-02-2003 01:51 PM


All times are GMT -5. The time now is 07:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration