LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-09-2003, 10:32 AM   #1
breakerfall
Member
 
Registered: Jun 2003
Location: Manchester, UK
Distribution: Gentoo
Posts: 306

Rep: Reputation: 30
Question lilo won't go into the MBR


hey there... I am using gentoo and have just done a fresh install. I have done a couple of tests over the past few days and the other installs of lilo worked fine.

The second time I tried grub and this is the final install. Disk partitions were cleared and I started again.

This time I installed lilo again and when I came to boot up it said grub not found!

Anyhow, I have cleared the MBR now and there's nothing there, but lilo doesn't want to go into the mbr for some reason

Any ideas?
Thanks

[EDIT]

Also, when I type /sbin/lilo I see this:

Added GentooLinux
Fatal: No images have been defined or default image doesn't exists

Now I know that the image is there, and the config is sound:
Quote:
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
lba32
default=linux
vga=794

image=/boot/bzImage
label=GentooLinux
read-only
root=/dev/hda3

Last edited by breakerfall; 10-09-2003 at 10:51 AM.
 
Old 10-09-2003, 11:08 AM   #2
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Youve got:

default=linux

label=GentooLinux

change the default=............. directive to

default=GentooLinux

and then type as root user

/sbin/lilo
 
Old 10-09-2003, 11:11 AM   #3
breakerfall
Member
 
Registered: Jun 2003
Location: Manchester, UK
Distribution: Gentoo
Posts: 306

Original Poster
Rep: Reputation: 30
don't I feel so stupid...

Thanks for pointing that out. Pure common sense eluded me


Thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lilo on MBR tez Slackware - Installation 3 10-22-2004 09:20 AM
Lilo only on MBR? Teoryn Slackware - Installation 9 03-30-2004 04:10 AM
LILO not in MBR contactsanil Linux - Newbie 1 01-12-2004 03:49 AM
lilo on MBR roofy Linux - General 5 05-19-2003 04:15 PM
mbr had over write so lilo is gone how to rewrite lilo to mbr mch Linux - Software 4 10-25-2002 02:55 PM


All times are GMT -5. The time now is 05:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration