LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-14-2006, 08:41 PM   #1
madogfreeman
LQ Newbie
 
Registered: Nov 2005
Distribution: Mandrake 10.2
Posts: 7

Rep: Reputation: 0
Lilo configure issues


i am running a system that has manrdiva 2006, winxp, and Extreme gaming (Debian)
when i boot i get the options
"linux"
"linux-nofb"
"windows"
"failsafe"
to allow the booting to my debian distro
i changed lilo config to this
Code:
look down for the right lilo.conf
but for some reason when i boot i still get the

"linux"
"linux-nofb" or somthing like that
"windows"
"failsafe"

options

what am i doing wrong

Last edited by madogfreeman; 02-14-2006 at 09:40 PM.
 
Old 02-14-2006, 08:53 PM   #2
baldwonder
Member
 
Registered: Sep 2004
Location: Florida
Distribution: Slackware, VectorLinux, FreeBSD,Xubuntu
Posts: 69

Rep: Reputation: 15
After you changed the lilo.conf file, did you run /sbin/lilo as root to activate the changes?
 
Old 02-14-2006, 09:39 PM   #3
madogfreeman
LQ Newbie
 
Registered: Nov 2005
Distribution: Mandrake 10.2
Posts: 7

Original Poster
Rep: Reputation: 0
ok i messed up here is the correct lilo.conf file
Code:
# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

default="linux"
boot=/dev/hda
map=/boot/map
keytable=/boot/us.klt
menu-scheme=wb:bw:wb:bw
prompt
nowarn
timeout=100
image=/boot/vmlinuz
message=/boot/message
	label="linux"
	root=/dev/hdb6
	initrd=/boot/initrd.img
	append="resume=/dev/hdb1 splash=silent"
	vga=788
other=/dev/hdb3
	label="x-gaming"
	table=/dev/hdb3
other=/dev/hda1
	label="windows"
	table=/dev/hda
running lilo in knosole as root gives back this

{root@129 sbin}# lilo
Added linux
Warning: First sector of /dev/hdb3 doesn't have a valid boot signature
Fatal: Partition entry not found

i switched windows and x-gaming to see if the windows was failing but both the Warning and the Fatal come from x-gaming

thnx BTW

Last edited by madogfreeman; 02-14-2006 at 09:41 PM.
 
Old 02-14-2006, 09:53 PM   #4
madogfreeman
LQ Newbie
 
Registered: Nov 2005
Distribution: Mandrake 10.2
Posts: 7

Original Poster
Rep: Reputation: 0
mood: powerful
why: i fixed it my self
how:
(in mandriva)
well first i mounted the debian to /debian
then changed lilo.conf
Code:
# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

default="linux"
boot=/dev/hda
map=/boot/map
keytable=/boot/us.klt
menu-scheme=wb:bw:wb:bw
prompt
nowarn
timeout=100
message=/boot/message
image=/boot/vmlinuz
	label="linux"
	root=/dev/hdb6
	initrd=/boot/initrd.img
	append="resume=/dev/hdb1 splash=silent"
	vga=788
image=/debian/boot/vmlinuz
	label="x-gaming"
	root=/dev/hdb3
	initrd=/debian/boot/initrd.img
	append="resume=/dev/hdb1 splash=silent"
	vga=788
other=/dev/hda1
	label="windows"
	table=/dev/hda
lines 19-24 are what i changed and did so on a simple hunch

i have not tested it yet but if it works i will right back
 
Old 02-14-2006, 10:39 PM   #5
madogfreeman
LQ Newbie
 
Registered: Nov 2005
Distribution: Mandrake 10.2
Posts: 7

Original Poster
Rep: Reputation: 0
yep i worked like a charm

if anyone wants a better how-to
just ask
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
configure lilo lilili Linux - Newbie 11 01-14-2006 02:47 AM
try to configure Lilo in Slackware Pzibi Linux - Laptop and Netbook 6 10-22-2005 04:20 AM
How do you configure Lilo? jacatone Linux - Newbie 3 07-03-2005 04:56 PM
How do you configure LILO under Mandrake? Ekim Gram Linux - Distributions 2 06-29-2003 07:58 PM
can't configure lilo elad Linux - Software 9 03-30-2001 08:14 AM


All times are GMT -5. The time now is 04:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration