LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-28-2013, 01:49 AM   #1
-Thomas-
LQ Newbie
 
Registered: Jun 2011
Location: Texas
Posts: 25

Rep: Reputation: Disabled
lightdm will no longer log anyone on


I use lightdm with Gentoo and XFCE4. I rarely reboot, but I do sometimes run "/etc/init.d/xdm restart". I had lightdm configured to automatically log me in, so normally I would never see it. Today, though, when I tried to restart X it gave me the login screen. I entered my password and hit enter, but nothing happened. The screen goes black momentarily and then the login screen appears again. running "/etc/init.d/xdm restart" again didn't help. The problem is the same for root and a new user I created. Entering the wrong password results in what you would expect. Rebooting didn't help. Uninstalling lightdm, deleting its configuration files, and installing it again didn't help the first time I tried it, then one time it seemed to fix the problem, then I changed two lines in lightdm.conf to set up autologin, and the problem was back. I have not been able to make that happen again. Masking the current version and installing the last one didn't help. I am at a loss. This must have happened recently. I started xfce using the startxfce4 command. It's not ideal, but I'll leave it like this for the weekend, then I'm going to try SLiM. Any help is appreciated.

Below is everything that is appended to /var/log/lightdm/lightdm.log when I attempt to log in. The meaning and significance of certain things are unclear to me, but I can tell a few things: Authentication succeeds, the greeter is closed, some other things happen, things start to go wrong, and the greeter is started again. Pretty much what I already knew. Maybe someone else can make more sense of it.

Code:
[+1524.12s] DEBUG: Session pid=8059: Continue authentication
[+1524.16s] DEBUG: Session pid=8088: Authentication complete with return value 0: Success
[+1524.16s] DEBUG: Session pid=8059: Authenticate result for user thomas: Success
[+1524.17s] DEBUG: Session pid=8059: User thomas authorized
[+1524.17s] DEBUG: Session pid=8059: Greeter requests session xfce
[+1524.21s] DEBUG: Writing /home/thomas/.dmrc
[+1524.27s] DEBUG: Seat: Stopping greeter; display server will be re-used for user session
[+1524.27s] DEBUG: Session pid=8059: Sending SIGTERM
[+1524.28s] DEBUG: Session pid=8059: Greeter closed communication channel
[+1524.28s] DEBUG: Session pid=8059: Exited with return value 0
[+1524.28s] DEBUG: Seat: Session stopped
[+1524.28s] DEBUG: Seat: Greeter stopped, running session
[+1524.28s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session9
[+1524.28s] DEBUG: Session pid=8088: Setting XDG_VTNR=7
[+1524.28s] DEBUG: Session pid=8088: Running command /etc/lightdm/Xsession startxfce4
[+1524.29s] DEBUG: Activating VT 7
[+1524.29s] DEBUG: Session pid=8088: Exited with return value 1
[+1524.29s] DEBUG: Seat: Session stopped
[+1524.29s] DEBUG: Seat: Stopping display server, no sessions require it
[+1524.29s] DEBUG: Sending signal 15 to process 8050
[+1524.44s] DEBUG: Process 8050 exited with return value 0
[+1524.44s] DEBUG: DisplayServer x-0: X server stopped
[+1524.44s] DEBUG: Releasing VT 7
[+1524.44s] DEBUG: DisplayServer x-0: Removing X server authority /var/run/lightdm/root/:0
[+1524.44s] DEBUG: Seat: Display server stopped
[+1524.44s] DEBUG: Seat: Active display server stopped, starting greeter
[+1524.44s] DEBUG: Seat: Creating greeter session
[+1524.44s] DEBUG: Seat: Setting XDG_SEAT=seat0
[+1524.44s] DEBUG: Seat: Creating display server of type x
[+1524.44s] DEBUG: Seat: Starting local X display
[+1524.44s] DEBUG: Using VT 7
[+1524.44s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+1524.44s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
[+1524.44s] DEBUG: DisplayServer x-0: Launching X Server
[+1524.44s] DEBUG: Launching process 8436: /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+1524.44s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+1524.50s] DEBUG: Got signal 10 from process 8436
[+1524.50s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+1524.50s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+1524.50s] DEBUG: Seat: Display server ready, starting session authentication
[+1524.50s] DEBUG: Session: Setting XDG_VTNR=7
[+1524.50s] DEBUG: Session pid=8445: Started with service 'lightdm-greeter', username 'root'
[+1524.51s] DEBUG: Session pid=8445: Authentication complete with return value 0: Success
[+1524.51s] DEBUG: Seat: Session authenticated, running command
[+1524.51s] DEBUG: Session pid=8445: Setting XDG_VTNR=7
[+1524.51s] DEBUG: Session pid=8445: Running command /usr/sbin/lightdm-gtk-greeter
[+1524.51s] DEBUG: Activating VT 7
[+1524.53s] DEBUG: Session pid=8445: Greeter connected version=1.7.15
[+1524.69s] DEBUG: Session pid=8445: Greeter start authentication for thomas
[+1524.69s] DEBUG: Seat: Setting XDG_SEAT=seat0
[+1524.69s] DEBUG: Session: Setting XDG_VTNR=7
[+1524.69s] DEBUG: Session pid=8471: Started with service 'lightdm', username 'thomas'
[+1524.69s] DEBUG: Session pid=8471: Got 1 message(s) from PAM
[+1524.69s] DEBUG: Session pid=8445: Prompt greeter with 1 message(s)
 
Old 09-30-2013, 08:10 AM   #2
pan64
Senior Member
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 4,838

Rep: Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287
have you checked other logs, for example ~/.session-errors
 
Old 10-01-2013, 02:53 AM   #3
-Thomas-
LQ Newbie
 
Registered: Jun 2011
Location: Texas
Posts: 25

Original Poster
Rep: Reputation: Disabled
I did check a few other logs in /var/log/ (xdm.log and Xorg.*), but I didn't find anything that looked relevant. I didn't think to look in my home directory. I do have an ~/.xsession-errors, but nothing is added to it when I start xdm and try to log in.

Last edited by -Thomas-; 10-01-2013 at 02:54 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lightdm won't log in origami-sheep Linux - Software 1 05-24-2012 01:35 PM
LXer: Simple LightDM Manager: Change The LightDM Background Or Logo Using A GUI LXer Syndicated Linux News 0 10-05-2011 05:41 PM
Postfix No Longer Writes To Log carlosinfl Linux - Server 2 03-03-2010 09:38 AM
Can no longer log in as user dive Slackware 7 07-31-2005 11:42 AM
xsession-errors / I can no longer log in Cinematography Ubuntu 2 06-12-2005 12:59 PM


All times are GMT -5. The time now is 03:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration