LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   libpci is not present/sufficient (http://www.linuxquestions.org/questions/linux-general-1/libpci-is-not-present-sufficient-4175446263/)

yun 01-18-2013 09:39 PM

libpci is not present/sufficient
 
Hi all,

I am new with Linux. I am tryign to compile flashrom on Centos but keep on getting below error although I had installed the pciutils.
Anyone can advice me what I can do?

[root@localhost flashrom-0.9.6]# make
Checking for a C compiler... found.
Target arch is x86
Target OS is Linux
Checking for libpci headers... found.
Checking if libpci is present and sufficient... no.
Checking if libz+libpci are present and sufficient...no.

Please install libpci (package pciutils) and/or libz.

Thanks!

John VV 01-18-2013 09:55 PM

first what version of CentOS ?
The current is CentOS 6.3

Also to build programs you need ( ether the source code) or the headers
the headers are in the *-devel.rpm packages

for most normal everyday programs you MUST have the basic development packages installed
"yum" make this easy

Code:

su -
yum grouplist

outputs a very long list of "groups" of packages

the normal basic needed are
"Development Tools"

--- and a good thing to have ,but not a MUST HAVE ? most of the time---
"Compatibility Libraries"

-- and if any source code is using the GTK Gnome desktop
"Desktop Platform Development"

--- and for centos 5 -- changed in 6
"Development Libraries"
And can be installed using yum
Code:

su -
yum groupinstall  "Development Tools" "Compatibility Libraries" "Desktop Platform Development"

that should install all the needed headers for almost all "normal everyday program"

also a very good thing to have installed ( if not already ) is
"Graphical Administrative Tools"
Code:

su -
yum groupinstall  "Graphical Administrative Tools"


yun 01-19-2013 02:41 AM

Thank you!

My Centos version is:

CentOS release 6.3 (Final)
CentOS release 6.3 (Final)
cpe:/o:centos:linux:6:GA

I already install as recommended but, I still doesn't seems able to install it.

Or is it possible that this is cause by my pciutils?

John VV 01-19-2013 03:06 AM

You are also aware that CentOS like RHEL ( Red Hat Enterprise Linux )
is very conservative as in it is not the "newest of the new"

the main goal of RHEL is stability and this necessitates the use of older versions of programs ( with current security and bug fixes added)

rhel ( cent) locked the version of every program before 6.0 came out in July 2011 .
and the magor versions will NOT change over the 7 to 10 year life span of the OS

http://flashrom.org/Latest_release
"flashrom-0.9.6.1.tar.bz2" --08-Aug-2012

building very new software on rhel( cent) can be a challenge sometimes

You did read the README file in the source code
Quote:


* pciutils+libpci (if you want support for mainboard or PCI device flashing)
* libusb (if you want FT2232 or Dediprog support)
* libftdi (if you want FT2232 support)

Linux et al:

* pciutils / libpci
* pciutils-devel / pciutils-dev / libpci-dev
* zlib-devel / zlib1g-dev (needed if libpci was compiled with libz support)
they "should" be installed , but .....
Code:

su -
yum search pciutils
-- you will see a list --
--- it is in the base repos --
yum install pciutils pciutils-devel

and do that for the rest

but if the current cent version is too OLD ( supported but older ) then you will have a very hard time of building it

yun 01-19-2013 04:16 AM

That is the flashrom version i am trying to compile!

I had try what I can. Getting the pciutils, ftdi/usb installed. No idea what else should be done...

Quote:

yum install pciutils.x86_64
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: centos.biz.net.id
* extras: centos.biz.net.id
* updates: centos.biz.net.id
Setting up Install Process
Package pciutils-3.1.4-11.el6.x86_64 already installed and latest version
Nothing to do

John VV 01-19-2013 08:21 AM

so you are using a 64 bit box
and the program is looking for the 32 bit versions

install the 32 bit versions of the prerequisites and the needed headers

in a yum search you will see the x86_64 and the i 686

install the i686 / i586 versions

yun 01-19-2013 08:22 AM

John,

Thank you for advice. Problem resolved - I just notice that I have pciutils-3.1.4-11.el6.x86_64 and pciutils-devel.i686 installed.

I uninstalled pciutils-devel.i686 and install pciutils-devel.x86_64 and problem goes away.

Thanks! :)


All times are GMT -5. The time now is 08:17 AM.