LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Ldconfig Segfaults On Slackware 9.1 (http://www.linuxquestions.org/questions/linux-general-1/ldconfig-segfaults-on-slackware-9-1-a-147496/)

johnleemk 02-18-2004 02:39 AM

Ldconfig Segfaults On Slackware 9.1
 
Recently I recompiled my kernel from the bare.i default to 2.6.2, and uninstalled Apache and mySQL before recompiling them from source. Now, the problem is, ldconfig segfaults. An example:
Code:

# ldconfig -v
/lib:
        liblvm-10.so.1 -> liblvm-10.so.1.0
        libproc.so.2.0.16 -> libproc.so.2.0.16
        libutil.so.1 -> libutil-2.3.2.so
        libthread_db.so.1 -> libthread_db-1.0.so
        librt.so.1 -> librt-2.3.2.so
        libresolv.so.2 -> libresolv-2.3.2.so
        libpthread.so.0 -> libpthread-0.10.so
        libpcprofile.so -> libpcprofile.so
        libnss_nisplus.so.2 -> libnss_nisplus-2.3.2.so
        libnss_nis.so.2 -> libnss_nis-2.3.2.so
        libnss_hesiod.so.2 -> libnss_hesiod-2.3.2.so
        libnss_files.so.2 -> libnss_files-2.3.2.so
        libnss_dns.so.2 -> libnss_dns-2.3.2.so
        libnss_compat.so.2 -> libnss_compat-2.3.2.so
        libnsl.so.1 -> libnsl-2.3.2.so
        libmemusage.so -> libmemusage.so
        libm.so.6 -> libm-2.3.2.so
        libdl.so.2 -> libdl-2.3.2.so
        libcrypt.so.1 -> libcrypt-2.3.2.so
        libc.so.6 -> libc-2.3.2.so
        libanl.so.1 -> libanl-2.3.2.so
        libBrokenLocale.so.1 -> libBrokenLocale-2.3.2.so
        ld-linux.so.2 -> ld-2.3.2.so
        libSegFault.so -> libSegFault.so
        libdb.so.3 -> libdb2.so.3
        libgpm.so.1 -> libgpm.so.1.18.0
        libdb.so.2 -> libdb1.so.2.1.3
        libncurses.so.5 -> libncurses.so.5.3
        libdb-3.3.so -> libdb-3.3.so
        libdb-3.1.so -> libdb-3.1.so
        libtermcap.so.2 -> libtermcap.so.2.0.8
        libblkid.so.1 -> libblkid.so.1.0
        libcom_err.so.2 -> libcom_err.so.2.1
        libe2p.so.2 -> libe2p.so.2.3
        libext2fs.so.2 -> libext2fs.so.2.4
        libss.so.2 -> libss.so.2.0
        libuuid.so.1 -> libuuid.so.1.2
        libbz2.so.1.0 -> libbz2.so.1.0.2
Segmentation fault

I tried using swaret to reinstall/upgrade libc and ldso as suggested by a search on Google, but swaret said no packages were found. :cry: This is apparently an internal problem, because guess what? Swaret can't find the GNOME or KDE packages either. I already did swaret --update, but that did not fix the problem.

Ideas? :scratch:

Edit:
Hm...it appears that ldconfig segfaults in the middle of changing directories to /usr/lib.


All times are GMT -5. The time now is 10:45 PM.