LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 04-02-2013, 10:35 AM   #1
mrjoli021
LQ Newbie
 
Registered: Jan 2012
Posts: 9

Rep: Reputation: Disabled
ldap_bind: Invalid credentials (49)


I have searched several posting on this message and I am still getting the error when I attempt to do an "ldapsearch"

I have changed the slapd.conf to use a plain-text password and I am still getting the error. I have also made sure that there are no blank spaces in the file. I have attempted to follow the LDAP setup from "http://www.itmanx.com/kb/centos63-openldap-phpldapadmin". The log file shows and iptables is turned off.

conn=1001 fd=15 ACCEPT from IP=[::1]:54486 (IP=[::]:389)
conn=1001 op=0 BIND dn="cn=Manager,dc=domain,dc=local,dc=pt" method=128
conn=1001 op=0 RESULT tag=97 err=49 text=
conn=1001 fd=15 closed (connection lost)

my server is running Centos 6.4 64.

below are the commands I am using
"ldapsearch -x -D cn=Manager,dc=domain,dc=local,dc=pt -w abc"

my slapd.conf file
database bdb
suffix "dc=domain,dc=local"
checkpoint 1024 15
rootdn "cn=Manager,dc=domain,dc=local"
rootpw abc
 
Old 04-02-2013, 12:22 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
"cn=Manager,dc=domain,dc=local,dc=pt" is clearly NOT "cn=Manager,dc=domain,dc=local"
 
Old 04-02-2013, 12:28 PM   #3
kbscores
Member
 
Registered: Oct 2011
Location: USA
Distribution: Red Hat
Posts: 259
Blog Entries: 9

Rep: Reputation: 32
cn=Manager,dc=domain,dc=local,dc=pt

needs to match

suffix "dc=domain,dc=local"

and

rootdn "cn=Manager,dc=domain,dc=local"

Also when you do the ldapsearch
use quotes
so it looks like this:

ldapsearch -x -D "cn=Manager,dc=domain,dc=local,dc=pt" -w abc
 
Old 04-02-2013, 12:34 PM   #4
mrjoli021
LQ Newbie
 
Registered: Jan 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Sorry I meant

"ldapsearch -x -D cn=Manager,dc=domain,dc=local -w abc"

And I still get the same issue.
 
Old 04-02-2013, 12:41 PM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
what version of openldap are you using? The slapd.conf file itself was deprecated a while back, and you should now be configuring it within a standard ldif file, although off hand I'm not sure of it's name / location.
 
Old 04-02-2013, 01:46 PM   #6
mrjoli021
LQ Newbie
 
Registered: Jan 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
I am running CentOS 6.4 and installed it via yum. not sure which version got installed. Is there a link or instructions on setting up an ldap on 6.4 without the slapd.conf file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ldap_bind: Invalid credentials (49) overdoseattitude Linux - Newbie 5 12-03-2012 03:11 AM
ldap_bind: Invalid credentials (49) pdrobe Linux - General 12 09-13-2012 02:41 AM
ldap_bind: Invalid credentials (49) jlpeifer Linux - Server 3 11-02-2010 03:31 PM
Ldap_bind: Invalid credentials olasamuel Linux - Newbie 1 10-28-2009 10:57 AM
LDAP_BIND: Invalid Credentials rupesh_pulikool Linux - Software 0 02-01-2005 01:27 PM


All times are GMT -5. The time now is 10:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration