LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 01-08-2008, 07:11 PM   #1
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,455

Rep: Reputation: 84
LD_LIBRARY_PATH reset by ...... what? --- xinit or nv driver


Hya,

My penguin looks like: Debian etch, (with NVIDIA_Linux-x86-1.0-7184)

Problem is:
environment variable LD_LIBRARY_PATH get reseted when X starts.

Following I found:
It happens regardless of shell (tcsh, bash).
It happens with Xfce, fluxbox (more precisely, before startfluxbox, after xinit)
Without nvidia driver, X does not start, but LD_LIBRARY_PATH is ok.

Any other nvidia drivers do not work.

I think I narrowed down to either xinit or nvidia driver is to blame.

I do not have any other etch penguin to check xinit. Lenny penguin with ATI driver has no problem.

I very much appreciate if anybody direct me to next step.

Happy Penguins!
 
Old 01-08-2008, 07:15 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Thread title fixed at poster's request.
 
  


Reply

Tags
etch, ldlibrarypath, nvidia, xinit


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xinit X problem BattousaiX Linux - Software 2 01-31-2012 05:08 PM
How to reset video driver to VESA bwpotter Linux - Newbie 2 01-31-2007 09:37 AM
Kdrive and xinit slothpuck Linux - Software 0 01-24-2005 02:50 PM
Upgrade from FC2 to FC3 broke audio -- "Unable to reset OSS driver" ericcarlson Fedora 1 01-20-2005 07:11 AM


All times are GMT -5. The time now is 10:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration