LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   KMail and PGP/GPG not working - doesn't ask for passphrase (http://www.linuxquestions.org/questions/linux-general-1/kmail-and-pgp-gpg-not-working-doesnt-ask-for-passphrase-287354/)

steve1401 02-07-2005 01:18 PM

KMail and PGP/GPG not working - doesn't ask for passphrase
 
Hi

I originally posted a similar question on the Debian forum without a deal of success, but it appears to be not specific to Debian as I first thought...

I have KDE 3.3 on a Debian SID installation, and KMial 1.7.2

I can create certificates via command line or with KGpg successfully. I can send encrypted email successfully. But when it comes to reading an encrypted email (I do this test by sending myself an encrypted email) I don't get asked for a passphrase to view it. All what happens is that KMail opens the mail with this error;

---
Encrypted message (decryption not possible)
Reason: Crypto plug-in "openpgp" could not decrypt the data.
Error: Bad passphrase
---

If I open the email in Evolution, it asks for the passphrase and I can then view the email. This suggests that PGP is setup and working fine.

Any ideas?

Steve

{BBI}Nexus{BBI} 02-08-2005 03:30 AM

Have you looked at Settings-->Configure Kmail-->Crypto?

steve1401 02-08-2005 06:42 AM

Now sorted - I found this howto, thanks to the KMail mailing list and this forum...

KMail 1.7 and pgp howto


All times are GMT -5. The time now is 12:40 PM.