LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-28-2006, 08:09 AM   #1
flebber
Member
 
Registered: Jan 2005
Location: Newcastle, Australia
Distribution: Slackware 14.1
Posts: 393

Rep: Reputation: 30
Keyboard layout config error 1 key wrong


There is only 1 tiny thing annoying me about my Fc6 install. My keyboard layout is fine my multimedia keys work but 1 key that I have the quote and the double quote button on (itś one button on my keyboard) doesn´t work. I can double press the button it produces this (´)not ('). And the shell will not recognise it.

Is there a config file I could go to and edit?

This problem turns out to be a major nuisance as with the quote and double quotes button not working I cannot write scripts.

It is the only key not working, even all multimedia keys are working.
 
Old 12-09-2006, 11:25 PM   #2
manishtomar
LQ Newbie
 
Registered: Dec 2006
Posts: 2

Rep: Reputation: 0
Hi,

I am having the same problem in FC6 installed in my x86 system. The quote can be typed using the '@' key (i.e. shift-2). Actually, these keys ('"' and '@') have got interchanged. Did you manage to find any solution?

Thanks in advance,
Manish
 
Old 12-10-2006, 06:55 PM   #3
flebber
Member
 
Registered: Jan 2005
Location: Newcastle, Australia
Distribution: Slackware 14.1
Posts: 393

Original Poster
Rep: Reputation: 30
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "intl"
EndSection

This worked for me
 
Old 12-10-2006, 11:33 PM   #4
manishtomar
LQ Newbie
 
Registered: Dec 2006
Posts: 2

Rep: Reputation: 0
Hi,

I am assuming that the above text you have written has to be put in some config file. I am sorry but i dont know which file it is as i am very new to Linux. Could u please tell me?

Thanks,
Manish
 
Old 12-10-2006, 11:46 PM   #5
flebber
Member
 
Registered: Jan 2005
Location: Newcastle, Australia
Distribution: Slackware 14.1
Posts: 393

Original Poster
Rep: Reputation: 30
Sorry That was a quick reply, I had the ball and chain nagging away. Yes that is my keyboard section of The /etc/X11/xorg.conf.

Ok so what you should do is go to a terminal. First create a backup so at the prompt# type whats in the quotes "cp /etc/X11/xorg.conf ~/backupxorg.conf" . Then you should see that file in your home directory.

Okay so "su" to root. At the prompt type # gedit /etc/X11/xorg.conf" then locate the keyboard layout section and substitute in

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "intl"
EndSection

THen save and close gedit, you may need to logout to restart X. Hope it works if it doesn't you have a backup of your current config to resort to.

Last edited by flebber; 12-10-2006 at 11:49 PM.
 
  


Reply

Tags
gnome, keyboard, working, xorgconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
keyboard layout is wrong quarry_06 Debian 5 12-14-2005 02:37 PM
keyboard layout (alternative key with mode_switch) super-momo Debian 2 02-12-2005 11:22 PM
Keyboard layout & win key in Core2 Travis S Fedora 11 10-06-2004 10:22 PM
Can't get my AltGr key to work with Norwegian keyboard layout orjanp Slackware 8 11-02-2003 08:53 AM
Keyboard layout wrong at Mandrake 9.1 depailler Mandriva 1 09-02-2003 06:49 AM


All times are GMT -5. The time now is 11:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration