LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-25-2006, 11:09 PM   #1
Synesthesia
Member
 
Registered: Jan 2004
Location: the abyss
Posts: 205

Rep: Reputation: 30
Key repeat rate lost after X killed


How do you prevent the key repeat from dropping to rediculously low levels after X is killed (or exited)? Thanks.
 
Old 05-26-2006, 09:30 AM   #2
fuzzyash
Member
 
Registered: Aug 2003
Location: Melbourne Australia
Distribution: Fedora Core 4
Posts: 184

Rep: Reputation: 30
What distro are you using??
 
Old 05-27-2006, 06:00 AM   #3
Synesthesia
Member
 
Registered: Jan 2004
Location: the abyss
Posts: 205

Original Poster
Rep: Reputation: 30
slack 10.2

I have repeat rate specified in fluxbox startup, but the repeat rate is fine before X starts.
 
Old 06-03-2006, 09:52 AM   #4
fuzzyash
Member
 
Registered: Aug 2003
Location: Melbourne Australia
Distribution: Fedora Core 4
Posts: 184

Rep: Reputation: 30
Sorry for the delay on this answer, I've had a hectic week, to much work & computer issues here at home, but all resolved now!


I run Fedora so I don't know why slack & fluxbox would be giving you this problem but...

There are several ways of doing this, the best would probably be adding the option to your /etc/X11/xorg.conf file.
To do this, edit your /etc/X11/xorg.conf file as root & find the section called "Section "InputDevice"", it should look something like this :
Code:
Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
EndSection
this section may also have a bunch of commented out example options. Then add the line :
Code:
Option  "AutoRepeat" "250 30"
just before the line "Option "XkbLayout" "us"" so it looks something like :
Code:
Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
    Option         "AutoRepeat" "250 30"
EndSection
This will force X to set the delay to 250 milliseconds & the repeat rate to 30 characters per second. This will only work if your window manager does not try to change it while it loads.

If this doesn't work, which would be very strange, then your window manager is to blame & might need to be upgraded! But before going to that extreme there are other options we can explore.

Please let me know how this works out for you.
 
Old 06-05-2006, 04:14 PM   #5
Synesthesia
Member
 
Registered: Jan 2004
Location: the abyss
Posts: 205

Original Poster
Rep: Reputation: 30
Of course I have good rate settings in X, but the problem is not in xorg; the problem is with the repeate rate in the command line. Xorg uses vendor specific drivers, while you use vesa when your out of X. I'm talking about out of X. I tried changing the settings in the xorg-vesa.conf, but that didn't work. Any Ideas? Thanks for your imput.
 
Old 06-06-2006, 01:57 AM   #6
gbowden
Member
 
Registered: Dec 2003
Location: Spain
Distribution: Slackware 14.1
Posts: 146

Rep: Reputation: 26
Hi,
Have you tried using the kbdrate command as root once you exit X?
 
Old 06-10-2006, 08:09 AM   #7
fuzzyash
Member
 
Registered: Aug 2003
Location: Melbourne Australia
Distribution: Fedora Core 4
Posts: 184

Rep: Reputation: 30
Quote:
I'm talking about out of X.
Oh... Use kbdrate, like :
Code:
kbdrate -d 250 -r 50
If you ever need to change it in X, use xset, like :
Code:
xset r rate 250 50
Both of the above will set the delay to 250 milliseconds & the repeat rate to 30 characters per second.

They both have man pages for more info.
 
Old 06-10-2006, 06:30 PM   #8
Synesthesia
Member
 
Registered: Jan 2004
Location: the abyss
Posts: 205

Original Poster
Rep: Reputation: 30
kdbrate works. thanks....But why is the rate fine before X starts, and while in X, but it goes down after quitting X?
 
Old 06-18-2006, 04:08 AM   #9
fuzzyash
Member
 
Registered: Aug 2003
Location: Melbourne Australia
Distribution: Fedora Core 4
Posts: 184

Rep: Reputation: 30
That I can't answer without getting right into your system setup. Must be a bug in slack 10.2 Upgrading will probably fix it. For now though simply put the kdbrate command you used into a script & have it start every time you login & as a simple to type name so you can run it easily.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Key repeat problem sweetnsourbkr Slackware 2 11-14-2005 08:57 AM
keyboard repeat rate joshknape Mandriva 1 11-03-2005 07:46 PM
Easy question: how do I adjust the keyboard repeat rate? aweir14150 Mandriva 1 05-29-2004 12:18 PM
repeat key disabled. how to enable it again? neon Linux - Newbie 0 11-20-2003 07:47 PM
VMware 3.0 insane keyboard repeat rate marktaff Linux - General 1 02-23-2002 07:39 PM


All times are GMT -5. The time now is 12:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration