LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 02-11-2006, 10:24 PM   #1
Rhatlinux
Member
 
Registered: Sep 2004
Distribution: Arch 0.7.1 (Noodle)
Posts: 128

Rep: Reputation: 15
Kernel panic - not syncing: VFS: Unable to mount root fs on unkown-block(3,2)


I am attempting to compile my own Linux 2.6.15-4 kernel on an IBM Thinkpad T23 laptop. I do not know what I am doing wrong. I am only using the ext2 filesystem. I am receiving this error message:
Code:
Kernel panic - not syncing: VFS: Unable to mount root fs on unkown-block(3,2)
Maybe I did not select an option that I should have. I made the required changes to /boot/grub/menu.lst. Here is my .config file: http://pastebin.com/550643

Last edited by Rhatlinux; 02-11-2006 at 10:36 PM.
 
Old 02-11-2006, 11:02 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 3,995

Rep: Reputation: 261Reputation: 261Reputation: 261
It looks like you don't have any filesystems but ext2 configured. You need to compile support for your root filesystem into te kernel (or as a module and then load it via an initrd -- see mkinitrd for more details).
 
Old 02-11-2006, 11:26 PM   #3
Rhatlinux
Member
 
Registered: Sep 2004
Distribution: Arch 0.7.1 (Noodle)
Posts: 128

Original Poster
Rep: Reputation: 15
I am using ext2 for my root filesystem.
 
Old 02-12-2006, 05:26 AM   #4
schatoor
Senior Member
 
Registered: Jul 2002
Location: a tiny place caled hendrik ido ambacht in the netherlands
Distribution: SuSE, debian, slackware, lfs
Posts: 1,358

Rep: Reputation: 45
Quote:
I am using ext2 for my root filesystem.
Yes, we got that. But are you sure you have compiled ext2 support in to the kernel and NOT as an module? Unless this module is available through an initrd file, you will get an kernel panic.
 
Old 02-12-2006, 05:35 AM   #5
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
So, recompile your kernel (just make menuconfig) and check you have compiled support for all the file systems you are using.

<M> in front of an option means that it is "Modularized".

So make sure that you have a <*> in front of the option for File Systems.
 
Old 02-12-2006, 07:25 AM   #6
Rhatlinux
Member
 
Registered: Sep 2004
Distribution: Arch 0.7.1 (Noodle)
Posts: 128

Original Poster
Rep: Reputation: 15
Code:
#
#
#
# File systems
#
#
#
CONFIG_EXT2_FS=y
#
CONFIG_EXT2_FS_XATTR=y
#
CONFIG_EXT2_FS_POSIX_ACL=y
#
CONFIG_EXT2_FS_SECURITY=y
#
# CONFIG_EXT2_FS_XIP is not set
#
# CONFIG_EXT3_FS is not set
#
# CONFIG_JBD is not set
#
CONFIG_FS_MBCACHE=y
#
# CONFIG_REISERFS_FS is not set
#
# CONFIG_JFS_FS is not set
#
CONFIG_FS_POSIX_ACL=y
#
# CONFIG_XFS_FS is not set
#
# CONFIG_MINIX_FS is not set
#
# CONFIG_ROMFS_FS is not set
#
CONFIG_INOTIFY=y
#
CONFIG_QUOTA=y
#
CONFIG_QFMT_V1=m
#
CONFIG_QFMT_V2=m
#
CONFIG_QUOTACTL=y
#
CONFIG_DNOTIFY=y
#
# CONFIG_AUTOFS_FS is not set
#
CONFIG_AUTOFS4_FS=y
#
CONFIG_FUSE_FS=m
The ext2 is set to be built-in to the kernel.
 
Old 02-12-2006, 10:48 AM   #7
Rhatlinux
Member
 
Registered: Sep 2004
Distribution: Arch 0.7.1 (Noodle)
Posts: 128

Original Poster
Rep: Reputation: 15
I put a * for every option in the filesystem section and recompiled my kernel. I am still receiving a kernel panic.
 
Old 02-13-2006, 01:04 AM   #8
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
Did you copy over the new kernel to your boot directory?

If you haven't done it, you are still booting from your old kernel.
 
Old 02-13-2006, 06:40 AM   #9
Milesss
LQ Newbie
 
Registered: Feb 2006
Posts: 4

Rep: Reputation: 0
Maybe your kernel looks for root partition in wrong place? Have you tried to pass "root=/dev/hd**" option to kernel at boot?
 
Old 02-13-2006, 01:21 PM   #10
guysoft
Member
 
Registered: Jun 2004
Location: israel
Distribution: mandrake, MEPIS and menny live-cds
Posts: 71

Rep: Reputation: 16
while i was setting up a RAID array i found out that after kernel 2.6.12 you must use mkinitramfs and not mkinitrd. otherwise you get kernel panic.
 
Old 02-13-2006, 05:44 PM   #11
Milesss
LQ Newbie
 
Registered: Feb 2006
Posts: 4

Rep: Reputation: 0
I think I have figured out what can cause this. There may be two reasons:
1. You haven't turned on support for IDE in your kernel.
or
2. You haven't selected Dos MBR support under File Systems->Partiton Types->Advance Partition selection (I don't remeber exact name of option).

I've had similar problem with 2.6.15.3 kernel and selecting these options to compile into kernel solved it.

Last edited by Milesss; 02-13-2006 at 05:48 PM.
 
Old 02-14-2006, 10:53 AM   #12
Rhatlinux
Member
 
Registered: Sep 2004
Distribution: Arch 0.7.1 (Noodle)
Posts: 128

Original Poster
Rep: Reputation: 15
Quote:
I think I have figured out what can cause this. There may be two reasons:
1. You haven't turned on support for IDE in your kernel.
or
2. You haven't selected Dos MBR support under File Systems->Partiton Types->Advance Partition selection (I don't remeber exact name of option).

I've had similar problem with 2.6.15.3 kernel and selecting these options to compile into kernel solved it.
I compiled the kernel about 10 times since I posted. You were absolutely right. I had IDE support complied, but I did not have an option compiled that was related to ATA2. Then I could not enable DMA using "hdparm -d1 /dev/hda." I needed to enable the "Pentium IIX IDE chipset support" for DMA to work. I also enabled the "Use DMA when avaliable" so I did not have to manually enable it using hdparm. I did not have to enable anything under "Partition Types."
 
Old 02-14-2006, 11:04 AM   #13
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
Knowing your computer inside out is the most important consideration required for *successful* Kernel Compilations.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel panic - not syncing : VFS: unable to mount root FS on unknown-block Dankles Slackware 23 01-28-2011 03:01 AM
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,2) Volgin Linux - Software 1 12-11-2005 07:46 PM
Kernel panic: VFS : unable to mount_root fs on unkown-block (0,0) Jammin Linux - Software 3 09-01-2004 09:19 AM
Kernel Panic: VFS: Unable to mount root fs on unknown-block(3,65) kpaske Linux - Newbie 1 08-07-2004 12:03 AM
Kernel Panic:VFS:Unable to mount root fs on Unknown block dinesha Linux - Software 2 02-27-2004 12:37 PM


All times are GMT -5. The time now is 05:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration