LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Kernel Panic debug (http://www.linuxquestions.org/questions/linux-general-1/kernel-panic-debug-377645/)

kraydl 10-28-2005 01:42 AM

Kernel Panic debug
 
I'm getting a Kernel panic error.

My partition info:
(internal scsi drive - contains GRUB in the /mbr)
sda1 XP 2gb repair
sda2 XP 250gb main
sda3 XP 3gb support

(external usb scsi drive - where mepis linux is installed)
sdb1 25gb ext3 /
sdb2 20gb ext3 /home
sdb3 8gb ext3 /tmp
sdb4 3gb linswap /swap


Grub boot screen:
MEPIS at sdb1, kernel 2.6.12
Windows at sda2
MEMTEST


XP boots fine on the internal drive.
MEMTEST ran 21 times with no errors.
Booting Linux from the external usb drive I get the following error:

"Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block (0,0)"


I changed my GRUB kernel line to this:
kernel (hd1,0)/boot/vmlinuz-2.6.12 single debug 3 confirm


5 pages of output later, I received 4 errors right before it stopped. Here are those last few lines of output starting with the first error:

RAMDISK: Couldn't find valid RAM disk image starting at 0.
usb 1-2: new high speed USB device using ehci_hcd and address 2
FAT: codepage cp437 not found
FAT: codepage cp437 not found
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,3)
<3>usb 1-2: device descriptor read/64, error -71

Any ideas? Thanks for the help.


Here's two other files if interested:

Contents of my file:/mnt/sdb1/boot/grub/menu.lst
-------------
timeout 15
color cyan/blue white/blue
foreground ffffff
background 0639a1
gfxmenu /boot/grub/message

title MEPIS at sdb1, kernel 2.6.12
kernel (hd1,0)/boot/vmlinuz-2.6.12 root=/dev/sdb1 nomce quiet splash=verbose vga=791
initrd (hd1,0)/boot/initrd.splash

title Windows at sda2
rootnoverify (hd0,1)
chainloader +1

title MEMTEST
kernel /boot/memtest86.bin
-------------


Contents of my file:/mnt/sdb1/etc/fstab
-------------
# Static entries below, do not use 'users' option in this area
/dev/sdb1 / ext3 defaults,noatime 1 1
/dev/sdb4 swap swap sw,pri=1 0 0
none /proc proc defaults 0 0
none /proc/bus/usb usbfs devmode=0666 0 0
none /dev/pts devpts mode=0622 0 0
none /sys sysfs defaults 0 0
/dev/sdb2 /home ext3 defaults,noatime 1 2
-------------

syg00 10-28-2005 04:05 AM

Installing to a usb is a *lot* different to using usb at boot.
You neeed all the usb support compiled into the kernel (not modules), and available before kernel load.

Try adding "rootdelay=10" to the kernel line in grub - might work if everything is in place.
Might not.

kraydl 10-31-2005 09:14 AM

rootdelay=10 worked. Thanks!


All times are GMT -5. The time now is 07:08 AM.