LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-04-2006, 10:19 PM   #1
The_Nerd
Member
 
Registered: Aug 2002
Distribution: Debian
Posts: 540

Rep: Reputation: 32
Kernel panic after compiling 2.6.17 on DSL


Alright, I've just installed Damn Small Linux 3. I have a SATA drive, and it isn't noticing it. After a little googling, I notice that DSL doesn't support SATA (the kernel), but DSL-N does. However, I don't really want to reinstall everything, so I thought I'd just go pick up the newest kernel from kernel.org. I went through some tutorials, and compiled it just fine. I installed it, and set it up into GRUB. However, when booting, it gets past the "Uncompressing Linux: Ok, booting the kernel.", and then it says, "Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)"

What did I do wrong?
 
Old 08-05-2006, 03:41 AM   #2
meetscott
Samhain Slackbuild Maintainer
 
Registered: Sep 2004
Location: Phoenix, AZ, USA
Distribution: Slackware
Posts: 411

Rep: Reputation: 42
Make sure you have your filesystem support built in and not as a module. Also, of course, enable sata when you are configuring. Another option is to pick up a config from Slackware. Those are solid. Again make sure you change the config from the Slackware kernels to have your filesystem like Reiserfs, ext3, or whatever compiled right in, NOT as a module. Enable sata and you should be good to go.

One other thing. Make sure your entries in /etc/fstab are okay.

Last edited by meetscott; 08-05-2006 at 03:42 AM.
 
Old 08-06-2006, 03:52 PM   #3
louieb
Member
 
Registered: Jun 2006
Location: Texas
Distribution: Ubuntu 8.04
Posts: 94

Rep: Reputation: 17
kernel panic

whenever I get the kernel panic message. It has bee due to a space mising in the initrd line of my grub.conf aks menu.lst file. Hope you have this easy a fix.
File is found in /boot/grub/

Code:
# space missing  do not work
initrd/initrd.img-2.6.15-26-386 
# this works
initrd /initrd.img-2.6.15-26-386
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
compiling kernel problem --- Kernel panic: unable to mount root fs ........ anthonymts123 Linux - General 5 07-31-2006 03:29 AM
compiling kernel 2.6.13.3: panic! Mr.Bloom Linux - General 7 10-21-2005 06:42 PM
Kernel panic after compiling - Hoarx MarioT Ubuntu 1 06-08-2005 06:14 AM
Kernel panic after compiling 2.4.29 ? gnirtS Debian 8 03-15-2005 11:08 AM
Kernel panic after compiling 2.4.26 alantang Linux - General 4 02-01-2005 03:51 PM


All times are GMT -5. The time now is 11:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration