LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-13-2009, 05:25 AM   #1
beli0135
Member
 
Registered: Jul 2008
Posts: 39

Rep: Reputation: 15
Question Kernel 2.6.28 and Postgre starting problem


Hi all.

I have postgre getting started in boot.local. It works with default kernel which I have (came with openSUSE 11.0), but when I downloaded full version of new 2.6.28 and compiled it, everything works, except it hangs on starting postgre for a long time.
I had no choice but to comment it's line in boot.local

I don't know what could be the problem (maybe some option in kernel must be checked or unchecked), so if anyone knows, please tell me.

Thanks!
 
Old 01-15-2009, 05:16 AM   #2
beli0135
Member
 
Registered: Jul 2008
Posts: 39

Original Poster
Rep: Reputation: 15
Not anyone?
 
Old 01-15-2009, 07:26 AM   #3
AuroraCA
Member
 
Registered: Jul 2008
Location: Northern CA USA
Distribution: Ubuntu, Slackware, Gentoo, Fedora, Red Hat, Puppy Linux
Posts: 370

Rep: Reputation: 35
Have you looked at your error logs? Start by looking in your /var/log/syslog. This should tell you what's going on during system startup and include any problems encountered.
 
Old 01-19-2009, 01:23 PM   #4
beli0135
Member
 
Registered: Jul 2008
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by AuroraCA View Post
Have you looked at your error logs? Start by looking in your /var/log/syslog. This should tell you what's going on during system startup and include any problems encountered.
There are no errors. Starting postgre, and it freezes.
 
Old 01-19-2009, 05:15 PM   #5
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,938

Rep: Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341
Did you try to create a symlink from /etc/rc5.d or /etc/rc3.d (depending on your default runlevel) to the script used to start postgresql and see if it works this way?
 
Old 01-20-2009, 05:31 AM   #6
beli0135
Member
 
Registered: Jul 2008
Posts: 39

Original Poster
Rep: Reputation: 15
Nope. I just put in boot.local a line:
rcpostgresql start
 
Old 01-20-2009, 06:30 AM   #7
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,938

Rep: Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341
Does postgresql starts when you run this command from CLI?
If it does, then try the symlink, to see if it can start at system bootup.
Code:
ln -s /etc/init.d/rcpostgresql /etc/init.d/rc5.d/S99postgresql
 
Old 01-21-2009, 05:38 AM   #8
beli0135
Member
 
Registered: Jul 2008
Posts: 39

Original Poster
Rep: Reputation: 15
I will try, thanks.
 
Old 01-22-2009, 01:08 PM   #9
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,988
Blog Entries: 11

Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
Going back to the kernel causing the issue ... it could be time-outs
on the network layer, e.g. postgres (or postgresql, not postgre!)
could be compiled with IPv6 support, and it may be turned off in your
kernel, you may not have iptables configured the same in both kernels...

I'd be diffing the .config files for the default and yours. Chances are
high the problem is home-made.


Cheers,
Tink
 
Old 01-23-2009, 04:23 AM   #10
beli0135
Member
 
Registered: Jul 2008
Posts: 39

Original Poster
Rep: Reputation: 15
Interesting. I believe in old kernel (which I am using at the moment at work, and still have no time to mess with it) is generic which come with openSUSE.
I remember I did turn off ipv6. Maybe this is the problem. Maybe I just have to reinstall postgres.
 
  


Reply

Tags
kernel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel starting problem parmeshwer Linux - Software 2 12-10-2008 05:27 AM
Problem Starting X After Compiling Kernel for Highmem jonegold Slackware 2 01-12-2007 12:39 AM
mysql and postgre help sharp81 Linux - Networking 1 12-15-2005 07:21 AM
The problem after starting new kernel LittlesnowLinux Debian 1 01-05-2005 01:37 PM
Problem starting KDE, RH9, Kernel 2.6.5, XFree86 4.4.0 tektig Linux - Software 1 04-27-2004 03:00 PM


All times are GMT -5. The time now is 07:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration