LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 07-02-2002, 10:16 AM   #1
Stephanie
LQ Addict
 
Registered: May 2001
Location: Arizona
Distribution: 9.2 Mandy 1.4 Gentoo 5.1 FreeBSD WinXP
Posts: 1,166

Rep: Reputation: 45
Keeping my screen active


WHen you are in the consoe, and dont use it for a while, the screen goes blank, but is still on, so if you move the mouse, it flips back to life immediately.

In X, it wont do that. I think the card itself stops transmitting, so when I move the mouse, it take time for the screent o come back up.

Is there a setting I can change to make X go blank, but still come immediately back to life as it does in the console?
 
Old 07-02-2002, 10:37 AM   #2
Mik
Senior Member
 
Registered: Dec 2001
Location: The Netherlands
Distribution: Ubuntu
Posts: 1,316

Rep: Reputation: 46
Disable the advanced powermanagement which blanks out the screen. And just use a screensaver which makes the screen black.
 
Old 07-02-2002, 12:13 PM   #3
Stephanie
LQ Addict
 
Registered: May 2001
Location: Arizona
Distribution: 9.2 Mandy 1.4 Gentoo 5.1 FreeBSD WinXP
Posts: 1,166

Original Poster
Rep: Reputation: 45
Sounds easy enough, but where is that located?
 
Old 07-02-2002, 04:28 PM   #4
mrGee
Member
 
Registered: Dec 2001
Location: Netherlands
Distribution: redhat suse mandrake freebsd
Posts: 344

Rep: Reputation: 30
there are some solutions and they are all related to
your XF86Config-4
You could try
Option "DPMS" "off"
in section Device
or use option "StandbyTime" "time"
time in minutes
man XF86Config
man xset for detailed info

DPMS option seems to work
(on my mdk 7.1 box there was an option "power_saver"
could n't find it on my 8.2 reading XF86Config manual)

good luck

Last edited by mrGee; 07-02-2002 at 04:29 PM.
 
Old 07-02-2002, 07:55 PM   #5
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Response to your question to Mik:

(If in KDE)

K---Configuration---KDE-----Power Control---Energy

And uncheck the uppermost option.

Then, go to the K--Conf---KDE--Look and Feel--Screensaver

To pick a screen saver.

Hope that helps
 
Old 07-12-2002, 03:01 PM   #6
Stephanie
LQ Addict
 
Registered: May 2001
Location: Arizona
Distribution: 9.2 Mandy 1.4 Gentoo 5.1 FreeBSD WinXP
Posts: 1,166

Original Poster
Rep: Reputation: 45
OK, I tried both of these ideas and the damn thing still goes to power save mode.

Any other ideas, or even better.. is there package that I could uninstall that controls that?
 
Old 07-12-2002, 03:32 PM   #7
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
setterm -blank 0
 
Old 07-12-2002, 04:22 PM   #8
mrGee
Member
 
Registered: Dec 2001
Location: Netherlands
Distribution: redhat suse mandrake freebsd
Posts: 344

Rep: Reputation: 30
it seems to depends alot on what window
manager you use, kde and gnome have their
own power/screen options.
In my Xfce it works with the option dpms "off" in
XF86Config-4. Just as in console i only have
to move my mouse to get my screen back. Monitor is
always on just goes to black after time.
I don't use kde alot but when screensaver is active and powerdown options are off, the screensaver at least keeps
alive.
 
Old 07-12-2002, 07:49 PM   #9
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
Stephanie, I'd love a W2K distro of Linux from you.

Ok, I misunderstood your Q. You could set it up in BIOS during boot-up. Hit whatever key the screen says. Usually, DEL or F2. Go to Power Man.
 
Old 07-15-2002, 11:27 AM   #10
Stephanie
LQ Addict
 
Registered: May 2001
Location: Arizona
Distribution: 9.2 Mandy 1.4 Gentoo 5.1 FreeBSD WinXP
Posts: 1,166

Original Poster
Rep: Reputation: 45
DPMS? I think I have seen that in my BIOS.

I will change that to off and all my power management to off.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VNCView into non-headless, currently active screen? techsimian Linux - Software 1 02-01-2005 05:24 PM
Keeping yourself secure Ephracis Linux - Security 1 12-02-2004 04:56 PM
Telnet/SSH screen stops responding after a while but the session is still active alllle Linux - Networking 4 05-04-2004 01:52 PM
screen / ssh setup -- keeping it secure Kyanos Linux - Networking 2 12-02-2003 06:57 PM
keeping track of active desktops jalburger Linux - Newbie 0 07-02-2002 09:02 AM


All times are GMT -5. The time now is 04:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration