LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 03-23-2002, 10:39 PM   #1
islandkid
Member
 
Registered: Mar 2002
Location: Victoria, BC, Canada
Distribution: None (www.linuxfromscratch.org)
Posts: 103

Rep: Reputation: 15
kdm (can't log in)


kdm just restarts when I try to log in. I believe this is because I don't have an .xsession file in my $Home directory. What is the contents of .xsession suppost to be? I found something somewhere saying that you need a line 'startkde' and that the permissions need to be set to 755, but just this alone isn't working for me. I think I might need something else in the .xsession file.
 
Old 03-23-2002, 11:19 PM   #2
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 55
you might need to do
exec startkde
in your .xsession or/and .xinitrc files in your home directory.
Does it happen only with a particular user or it affects all the users icluding root, if so take a look at /etc/kde/kdm/kdmrc file, you'll track it down to /etc/X11/xdm/Xsession file, and you'll have to fidle with it.
 
Old 03-23-2002, 11:42 PM   #3
islandkid
Member
 
Registered: Mar 2002
Location: Victoria, BC, Canada
Distribution: None (www.linuxfromscratch.org)
Posts: 103

Original Poster
Rep: Reputation: 15
yes, it is the same for root and all users.

my kdmrc file looks like this:

[Directories]
dir_apps=/etc/X11/applnk

This is a very new version of kdm. Maybe it doesn't use Xsession. I'm not sure.

Last edited by islandkid; 03-23-2002 at 11:43 PM.
 
Old 03-23-2002, 11:54 PM   #4
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 55
is that it? That's all you have in kdmrc? Boo...
This is mine, but I use RH
[Desktop0]
BackgroundMode=Wallpaper
BlendBalance=100
BlendMode=NoBlending
ChangeInterval=60
Color1=88,116,152
Color2=88,116,152
CurrentWallpaper=0
LastChange=0
MultiWallpaperMode=NoMulti
Pattern=
Program=
ReverseBlending=false
Wallpaper=none
WallpaperList=
WallpaperMode=Scaled

[General]

DaemonMode=false
Xservers=/etc/X11/xdm/Xservers
[Xdmcp]
Enable=false
Xaccess=/etc/X11/xdm/Xaccess
Willing=/etc/X11/xdm/Xwilling

[Shutdown]
HaltCmd=/sbin/poweroff
[X-*-Core]
Setup=/etc/X11/xdm/Xsetup_0
Session=/etc/X11/xdm/Xsession
AllowRootLogin=true
AllowNullPasswd=false
[X-*-Greeter]
SessionTypes=default,kde,gnome,enlightenment,afterstep,failsafe
GreetString=Red Hat Linux (%n)
ShowUsers=None
NoUsers=adm,alias,amanda,apache,bin,bind,daemon,exim,falken,ftp,games,gdm,gopher
,halt,httpd,ident,ingres,kmem,lp,mail,mailnull,man,mta,mysql,named,news,nfsnobod
y,nobody,nscd,ntp,operator,pcap,pop,postfix,postgres,qmaild,qmaill,qmailp,qmailq
,qmailr,qmails,radvd,reboot,rpc,rpcuser,rpm,sendmail,shutdown,squid,sympa,sync,t
ty,uucp,xfs,xten
MinShowUID=500
AllowShutdown=Root
[X-:*-Core]
AllowRootLogin=true
AllowNullPasswd=false
[X-:*-Greeter]
AllowShutdown=All
[X-:0-Core]
[X-:0-Greeter]

I've stripped out comments though, there are numerous options that can be turned on and off, look if you have all the mentioned files in /etc/X11/xdm/ directory.
 
Old 03-24-2002, 02:16 AM   #5
islandkid
Member
 
Registered: Mar 2002
Location: Victoria, BC, Canada
Distribution: None (www.linuxfromscratch.org)
Posts: 103

Original Poster
Rep: Reputation: 15
oops, sorry, that was my 'kderc'. This is my kdmrc:

[Desktop0]
BackgroundMode=Wallpaper
BlendBalance=100
BlendMode=NoBlending
ChangeInterval=60
Color1=30,114,160
Color2=192,192,192
CurrentWallpaper=0
LastChange=0
MinOptimizationDepth=1
MultiWallpaperMode=NoMulti
Pattern=
Program=
ReverseBlending=false
UseSHM=false
Wallpaper=default_blue.jpg
WallpaperList=
WallpaperMode=Scaled

[General]
PidFile=/var/run/kdm.pid
Xservers=/usr/share/config/kdm/Xservers

[Shutdown]
HaltCmd=/sbin/poweroff
LiloCmd=/sbin/lilo
LiloMap=/boot/map
RebootCmd=/sbin/reboot
UseLilo=false

[X-*-Core]
AllowNullPasswd=true
AllowRootLogin=true
AllowShutdown=Root
AutoReLogin=false
Reset=/usr/share/config/kdm/Xreset
Session=/usr/share/config/kdm/Xsession
Setup=/usr/share/config/kdm/Xsetup
Startup=/usr/share/config/kdm/Xstartup

[X-*-Greeter]
AntiAliasing=false
DefaultUser=guest
EchoMode=OneStar
FailFont=helvetica,12,-1,5,75,0,0,0,0,0
FocusPasswd=false
GUIStyle=HighColor
GreetFont=charter,24,-1,5,50,0,0,0,0,0
GreetString=Welcome - guest password: guest
GreeterPosFixed=false
GreeterPosX=100
GreeterPosY=100
HiddenUsers=adm,alias,amanda,apache,bin,bind,daemon,exim,falken,ftp,games,gdm,gopher,halt,httpd,iden t,ingres,kmem,lp,mail,mailnull,majordom,man,mta,mysql,named,news,nfsnobody,nobody,nscd,ntp,operator, pcap,pop,postfix,postgres,qmaild,qmaill,qmailp,qmailq,qmailr,qmails,radvd,reboot,rpc,rpcuser,rpm,sen dmail,shutdown,smmsp,squid,sympa,sync,tty,uucp,xfs,xten,
Language=en_US
LogoArea=Logo
LogoPixmap=
MaxShowUID=65535
MinShowUID=0
PreselectUser=None
SelectedUsers=
SessionTypes=default,kde,failsafe,gnome,
ShowUsers=NotHidden
SortUsers=true
StdFont=helvetica,12,-1,5,50,0,0,0,0,0

[X-:*-Core]
AllowNullPasswd=true
AllowRootLogin=true
AllowShutdown=All
NoPassEnable=false
NoPassUsers=

[X-:0-Core]
AutoLogin1st=true
AutoLoginEnable=true
AutoLoginUser=guest

[Xdmcp]
Enable=false
Willing=/usr/share/config/kdm/Xwilling
Xaccess=/usr/share/config/kdm/Xaccess
 
Old 03-24-2002, 11:56 AM   #6
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 55
Can you post contents of your
/usr/share/config/kdm/Xsession
file.
 
Old 03-24-2002, 03:53 PM   #7
islandkid
Member
 
Registered: Mar 2002
Location: Victoria, BC, Canada
Distribution: None (www.linuxfromscratch.org)
Posts: 103

Original Poster
Rep: Reputation: 15
I replaced the paths to the kdm directory with the paths to the xdm directory and everything is working fine now. I guess there was just something wrong with the ones in the kdm directory.

Here's Xsession from the kdm directory:

#! /bin/sh
# Xsession - run as user

# redirect errors to a file in user's home directory if we can
for errfile in "$HOME/.xsession-errors" "${TMPDIR-/tmp}/xses-$USER" "/tmp/xses-$USER"
do
if ( cp /dev/null "$errfile" 2> /dev/null )
then
chmod 600 "$errfile"
exec > "$errfile" 2>&1
break
fi
done

test -f $HOME/.xprofile && . $HOME/.xprofile

sess="$1"
shift

case "$sess" in
failsafe)
exec xterm -geometry 80x24-0-0 $*
;;
""|default)
exec $HOME/.xsession $*
;;
esac

# start windowmanager
type "$sess" >/dev/null 2>&1 && exec "$sess" $*
type "start$sess" >/dev/null 2>&1 && exec "start$sess" $*
type "$sess-session" >/dev/null 2>&1 && exec "$sess-session" $*
sess=`echo "$sess" | tr A-Z a-z`
type "$sess" >/dev/null 2>&1 && exec "$sess" $*
type "start$sess" >/dev/null 2>&1 && exec "start$sess" $*
type "$sess-session" >/dev/null 2>&1 && exec "$sess-session" $*

# windowmanager not found, tell user
exec xmessage -center -buttons OK:0 -default OK "Sorry, $sess not found."
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't log in as root from KDM, how do I get GDM back? Navyblue Linux - Newbie 3 07-28-2005 12:21 AM
New KDM Theme --> cannot log in max2004 Fedora 5 07-03-2005 02:15 PM
Kdm will not let me log out or shutdown J_Szucs Linux - General 3 05-27-2005 10:00 AM
occasional kdm log-out and application closure crashes dizzi Slackware 4 07-15-2004 05:10 AM
How can I log into system without KDM? DavidTempler Linux - Newbie 4 06-22-2004 07:18 AM


All times are GMT -5. The time now is 09:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration