LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-21-2005, 03:54 PM   #1
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Rep: Reputation: 30
KDE Intercepts the Super_L Key


Hello

I have RH 9.0 on one partition. Slack 10.0 on the other.
I use the same xmodmap for my keyboard. Code is at
the end of this post.

I have a small footprint logictech keyboard with a "win"
key. (keycode 115) which is mapped to Super_L.

On Slack with KDE 3.2.3, after pressing the Super_L key,
releasing it launches the main menu. I don't have that
problem on RH with KDE 3.1-12

Grrr! I hate it when that happens, it interferes with my
emacs.

Does anyone know how to disable this process?
NOTE: KDE control center keyboard shortcut service recognizes
this key as "Win", and xev doesn't appear to register anything
but the menu events.

This question was originally posted to the slack forum.
No takers :-(
Thanks
Tim
--------------------------------------------------------------------------------
remove Lock = Caps_Lock
remove Control = Control_L Control_R

! Assign original caps lock key to left control key
keycode 0x42 = Control_L
! Assign original left control key to caps lock
keycode 0x25 = Caps_Lock
! Assign original right windows key to right control key
keycode 0x74 = Control_R

add Lock = Caps_Lock
! add Control = Control_R Control_L Control_L
add Control = Control_R Control_L

! Left windows key becomes F13
!keycode 115=F13
keycode 115=Super_L
remove mod4 = Control_L
remove mod4 = Control_R
remove mod1 = Control_L
remove mod1 = Control_R
 
Old 08-21-2005, 06:28 PM   #2
NetRAVEN5000
Member
 
Registered: May 2005
Distribution: Ubuntu 9.04
Posts: 320

Rep: Reputation: 30
Go to the KDE Control Center > Regional & Accessibility > Keyboard Shortcuts. At least that's where it is in KDE3.4.2.
 
Old 08-21-2005, 07:16 PM   #3
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Original Poster
Rep: Reputation: 30
Hello NetRAVENS5000:
Quote:
Originally posted by NetRAVEN5000
Go to the KDE Control Center > Regional & Accessibility > Keyboard Shortcuts. At least that's where it is in KDE3.4.2.
What should I do when I get there? I am somewhat familiar with that feature - that is the correct path yes.
tim
 
Old 08-21-2005, 09:22 PM   #4
NetRAVEN5000
Member
 
Registered: May 2005
Distribution: Ubuntu 9.04
Posts: 320

Rep: Reputation: 30
Quote:
Originally posted by Tim Johnson
What should I do when I get there? I am somewhat familiar with that feature - that is the correct path yes.
tim
Go to where it says "Popup Launch Menu" (in 3.4.2 there's a "Search" bar at the top - you can also type "Popup Launch Menu" in there to find it) and then double-click it to change the key combo.

Also, in KDE 3.4.2 the Windows key is being used as a modifier key for key combos. Anyone know of a way I can do the *reverse* of what Tim here wants to do and make it so the Win key *does* pop up the window? When I try to put that as the shortcut, it says "Win+" like it wants me to put another key in there with it but that's not what I want. . .

Last edited by NetRAVEN5000; 08-21-2005 at 09:35 PM.
 
Old 08-21-2005, 11:27 PM   #5
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by NetRAVEN5000
Go to where it says "Popup Launch Menu" (in 3.4.2 there's a "Search" bar at the top - you can also type "Popup Launch Menu" in there to find it) and then double-click it to change the key combo.

Also, in KDE 3.4.2 the Windows key is being used as a modifier key for key combos. Anyone know of a way I can do the *reverse* of what Tim here wants to do and make it so the Win key *does* pop up the window? When I try to put that as the shortcut, it says "Win+" like it wants me to put another key in there with it but that's not what I want. . .
I've set the pop lauch menu to Win-F12 and the alternate binding to shift-F11, with no change.

Let me be clear here, that this does not appear to interfere with using Win(Super) as prefix key.
What does is occur is best illustrated with an example:

Let's suppose that I have bound Control-n to the emacs 'next-line' function and Super-n to the emacs
'next function' function. I mean to scroll to the next line and mistakenly put my finger on the win(super) key.
Then I release the super key to use the control key as I had meant. The result is that the popup then appears.

It is the key release event that causes this problem and it is really a minor annoyance.

thanks very much for the help so far. Any other ideas?
tim
 
Old 08-21-2005, 11:30 PM   #6
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by NetRAVEN5000
Go to where it says "Popup Launch Menu" (in 3.4.2 there's a "Search" bar at the top - you can also type "Popup Launch Menu" in there to find it) and then double-click it to change the key combo.

Also, in KDE 3.4.2 the Windows key is being used as a modifier key for key combos. Anyone know of a way I can do the *reverse* of what Tim here wants to do and make it so the Win key *does* pop up the window? When I try to put that as the shortcut, it says "Win+" like it wants me to put another key in there with it but that's not what I want. . .
Oh sorry, could have been more clear on that last posting, but in fact, the 'win' key (keycode 115) *is* being used for
the popup menu - regardless of keysym - by KDE.
 
Old 08-21-2005, 11:39 PM   #7
NetRAVEN5000
Member
 
Registered: May 2005
Distribution: Ubuntu 9.04
Posts: 320

Rep: Reputation: 30
?What?
Yes, the "Win" key pops up the menu - that's what I was trying to help you fix.

Sorry if I confused you with the last paragraph of my previous post - what I was saying was that, on my system, the menu *isn't* doing this when I press the "Win" key but I want it to. When I try to tell it this, though, it wants me to press another key, too - I don't want to press a key combination, though, I just want to press the Windows key. It had little to do with fixing your problem, it was just me asking how to get it to work the way yours does.
 
Old 08-22-2005, 12:12 PM   #8
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Original Poster
Rep: Reputation: 30
When setting hotkeys in control center->R & A->Keyboard shortcuts:
KDE waits for another keypress after I press and release"win". I'm now
guessing that feature is controled from somewhere else. I have to reboot
my computer to access the ver of KDE, as it is on another partition from my
main (RH 9.0) partition. But I can mount that partition and what appears to
be the relative path to the configuration files is (mounted ...)~/.kde/share/config.
I can poke around there a bit today and see if I find any syntax that might be
enabling the 'win' key to launch the main menu independent of the global hotkeys
service.

I appreciate your attention to this and maybe we will yet determine it, or perhaps
a different topic line like "enabling win key for popup launch menu" might get some
different insights.

Thanks again
tim
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Intercepts Super_R Tim Johnson Slackware 2 07-27-2005 11:19 AM
KDE Key Assignments grndrush Linux - Software 1 07-06-2005 01:05 PM
Key Bindings in KDE lawrencegoodman Linux - Newbie 1 09-28-2003 12:02 AM
Key bindings in KDE 3.1 thebeardedladie Linux - Newbie 0 04-19-2003 05:15 AM
Key Bindings and Kde 2.2 Will Linux - General 0 08-23-2001 11:06 PM


All times are GMT -5. The time now is 04:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration